BFD3.4.0.24 - Bug Reports

Yep same here, no net, no working BFD3.4.

1 Like

I know it’s been mentioned before but the content scanner just can’t handle groove libraries.
I have so may that I’d collected over the years and I guess this is a good time for me to sort them out but the scanner just crashes and I have to force close with the task manager.

Will this new version be generating crash logs?
I haven’t seen any notifications like before and deleted the fxpansion crash log folder from my desktop.

Steve

Having an issue with some of the snare mic channels not showing up in the mixer.

I’ve got an awful lot of snares to go through and check but so far, Metal Snares, Wooden Snares, Horse Power are all missing the bottom mic channel.

I noticed the VRT snares have Snare Dynamic and Condenser mic but I’m sure the others should have a bottom mic channel.

In their place they have a snare top 2 and snare top.

Just to note, this only seems to happen if your swapping out a snare from an existing preset.
If you’re just building a kit from scratch and you insert any other those snares the bottom mic channels are showing

Another thing I just tried, if I load the drum from the browser pane I get the missing bottom mic channel, but if I load the snare by right clicking on the snare and picking a snare from the, ‘Drums’ list it doesn’t happen.

Steve

I’m not seeing any such issue on Mac. I take it you both are on Windows?

Yes windows 10 here

Steve

Hi
Just installed the Metal SN collection, and tried to insert them on a preset, but it refuse to load(visually) with the bottom mic. I can hear it, but its not there. It only loads(visually) Top 1-2 and side channels. I’ve tried all possible actions, save and load channel, but the only way BFD3 accept all 4 mics, is by resetting BFD3. A bit of a hassels since I rely on my own build presets. In fact, it relates to all presets.
Steve also mentioned it here…

BFD3.4.0
Imac 2013, Logic Pro X.

Was it a factory preset that you tried to load the snare into??? Could you tell me which one if so?? I’m unable to reproduce this issue here at present.

Yes, for me it’s doing it with factory presets and it’s not just the metal and wooden snares.

I tried loading snares from the horespower expansion and got the same thing.
Also does it with the BFD Crush snares.

The Virtually Erskine gives me 2 bottom mic channels and no top so swings and roundabouts huh? :wink:

It doesn’t seem to be 100% repeatable here.

I just loaded a BFD3 preset (60s pop 126bpm PG) then loaded the Horse-Power snares (no bottom mic channel) and then went to the metal snare and bottom channels did show up this time.

I might try and make a video at some point but got a lot on at the moment.

Steve

As Steve mentioned, I also tried different factory presets. And an additional sn instrument only produce 2 channels.

The migration was a complete shambles for me, and the new version is unfit for purpose. This is on a Mac (Catalina); continuously crashing, not finding libraries and more. And I consider myself fairly experienced.

Thankfully, I have managed to reinstall the previous version thanks to another poster uploading it, and all is back to normal.

‘The BFD migration takes less than a minute,’ said the e-mail. I’ve wasted a few hours so far and don’t recommend it.

1 Like

Chinese login issues
My Chinese friends can’t access new server successfully!

  • Steps to Reproduce:
    Start up BFD3. This happens every time I run BFD3

  • Expected Result:
    To run without any messages.and have all of my stuff scanned.

  • Actual Result: & Steps To reproduce

Every time I start BFD3 in either Reaper or as standalone it comes up with a pop up window saying:

"Do you want to copy your BFD3 settings and presets from FXpansion into DFD Drums folders now? We recommend doing this as soon as possible for a smooth transition. If you cancel, BFD will defer the migration until you are ready. You can trigger the migration later in Preferences Panel/Data/Migration

Press OK to migrate now, or CANCEL to defer."

I press OK.

Then the next message comes up: “There was a problem copying your BFD factory system settings files.”

Then I press OK.

The program hangs for a few seconds and then 2 windows pop up. The back window is the BFD3 Content Locations. No boxes are checked.

The top windows says: “Your new BFD3 content is now setup and ready to use”

I press OK and the program works normal.

In the first step If I press CANCEL instead then I get the message:" You can always migrate later using the preferences panel"

Then the program still works as normal after that. In the standalone I don’t get the additional Metal Snares that I added.

I have to go and re scan to get the Metal Snares pack I added.

  • Reproducibility:
    Happens every time I open BFD3 in stand alone or in Reaper DAW.

  • Additional Notes:
    Windows 10 Home edition.Version 2004. 64bit

I get basically the same issue.

I did these exact steps and it still doesn’t work for me. Still get the pop up messages.

But I did the regedit thing that you posted and that fixed my issue perfectly. Thank you Drew! I only had to change the status of fxp2inm_migration to migrate.

Hi.
I cant open BFD in standalone or within Protools, it just wants to run licence manager. Its been like this since i migrated a week ago. Would really like to get BFD up and running again. Im on Mac, Mojave and Protools Ultimate 2021.3.0

1 Like

Heya. Are you definitely running 3.4.0.24, you didn’t roll back to 3.3 did you??

Hey Drew.

Im still on 3.4.0.24

BFD 3.4 won’t recognize non-ANSI(?) characters. I have a favorite that won’t load upon launch, and all Groove Palettes and Grooves with non-ANSI characters don’t load. 3.3 was ok in this regard.

• Same issue with the constant nag to import BFD3 content. I didn’t HAVE BFD3 content until I bought BFD 3.4 during this migration. Side note: my content is on a different volume from the default configuration. I generally don’t customize things, because that’s where testing fails in the QA process, but I needed to do it this way due to storage constraints.

also:

• Sorting content by name (like grooves) does not handle numbers correctly. It’s doing individual character comparisons, not a comparison of full numbers. 11 should come after 10, etc…

Mac OS 10.13.6

There are repetitious nags for the user’s OS password on Mac OS when loading BFD3.4. It does not seem to care when the “always allow” button is chosen, as it keeps nagging. This happened in standalone but seemed to stop(?). Then it happened again, with even more repetitions, when starting Logic X (scanning plugins seemed to trigger it). No other plugin has done this to me.

Note: My BFD content is installed on another volume, for whatever that’s worth. The standalone application and license manager applications are also not located in the default folder (I’m desperately trying to organize my Applications folder and slowly losing the battle).

[goes to check things]

Oh… look at that: there’s a new copy of BFD License Manager in my Applications folder where I never put it. THIS is a PROBLEM. If I move a program, DON’T engage in some kind of warfare against my own system management!

Mac OS 10.13.6

EDIT: If you need to trigger the start of the license manager and don’t know the path, instead of forcing a new copy where I don’t want it, USE SPOTLIGHT to FIND it. It’s in the API.