BFD3.4.0.24 - Bug Reports

Yeah, there are a couple of similar, minor points on MAC, that you just have to work through a bit.

  • Make sure that BFD has permissions to your Documents and your Removable Volumes. That’s an old one, but it bears repeating.

  • It’s better if you add and scan the path to each expansion separately, instead of searching an entire drive. I found it got bogged down and got stuck on a few if I did them all at once, but got through them all just fine when I added them individually.

  • If you have some libraries that have become unlicensed in the process (I’m looking at you, BFD2), make sure they’re unchecked from your Content Locations, or you’ll re-open to the content location page every time.

Also, BFD3 is more sensitive to multiple Volumes with the same name than before. I have a backup FXpansion drive that I often have online, and I now have to eject it. I think this is really a Mac OS issue, because the same issue just cropped up in ProTools recently.

Besides from the missing bfd2 and Zildjian digital vault content I could complete the migration and 3.4 works in standalone as well in vst.
However if I disconnect my windows 10 pc from the internet and start BFD (standalone or vst) I get a message that it has been disabled because it needs the licence manager. When I reconnect the ps to the internet, everything works fine again.
Does this mean that bfd will only run when the pc is online? As I have a dedicated studio / audio pc I don’t let it be connected to the internet.

1 Like

BFD3.4.0.24 standalone is working great. Everything fired up and sounds good to me.

I cannot for the life of me get Reaper to see the .dll tho.

I shall keep trying :slight_smile:

EDIT: Nevermind, got it working :slight_smile:

  • Steps to Reproduce:

Changing the mic positions, in this case I was changing the distance/width of the overhead mics

  • Expected Result:

The graphic of the kit and its mic placements moving with the dial change, representing where in the ‘room’ the mics are.

  • Actual Result:

The graphic doesnt change after a mic position change unless I click on the graphic of the kit, grab it and move it.

  • Reproducibility:

Move mic positions, no graphical change, click on the drum kit graphic until it ‘grabs’ it and I move it, then the mic positions change and click into place.

  • Additional Notes:

Not a big deal, but something I noticed. Is it just my install or is this a bug for everyone?

This may well be a bug but not necessarily

When I first opened BFD3.4 it attempted to migrate my settings, it hung and then gave me an error message which I wish I’d logged because I can’t remember what it was but basically it failed.

I tried this 3 or 4 times but each time it failed.

I then opened BFD3.4 in my sequencer (Bandlab) and a notification popped up telling me the that BFD3.4 had successfully ran the migration process.

Usually the advice is to set BFD up before opening in your sequencer but this time the opposite did the trick.

Steve

1 Like

Hello!

BFD3 crashes when dragging grooves.

I’ve upgraded from BFD2 in the last days. Installed BFD3,4,0,24 on my Macbbok Pro. (BFD2 is not installed in this machine). Everytime i try to drag a groove in reaper (or to the desktop in standalone) BFD quits instantly.

1 - To Reproduce:

  • Open BFD3
  • Select groove editor
  • Drag a groove to Reaper/or Desktop

2 - Expected result:

  • Midi file inserted in a Reaper track/ Midi file copied to Desktop

3 - Actual result:

  • Reaper Quits/ BFD quits

4 - Reproducibility:

  • Everytime i try to drag a groove, the exact moment mouse passes BFD window, it quits.

5 - Additional Notes:

  • I am sure this is not happening to everybody but my system is pretty normal. For now the only way i have to use BFD grooves is to export them and then import in the DAW. I am running OSX 10,12,6 on a MacBook Pro 11,2. BFD3 was never installed in this machine before.

…please forgive my english!!

2 Likes

Perfect English :slight_smile:

I just tried recreating this bug and couldnt Im afraid. Midi files are dragging into Reaper ok, and to the desktop.

Im on Win 10 here btw, fully up to date, and using the latest version of Reaper.

Hi,

I would like to repeat the question of guitartom, bfd3.4 only works when my DAW is online, when offline it’s definitely not pretty, loading the plugin crashes Cubase in the most brutal way and the standalone version simply does not start. Is this working as designed , i really hope not since this would force me to stop using Bfd after using it for more than a decade.

3 Likes

Hi
Your ongoing development on this product is good news indeed!
I have migrated successfully, have content installed except obviously the BFD2 content that I like to use (i can’t do without 400 Supraphonic and some other kit pieces). Great drum studio, very stable, + new fx are of quality and most welcome.
I had discovered (as a couple of recent posts also mention) the authorisation does not stick if I have logged out of pc or restarted microsoft windows? All my other applications here seem to be functioning fine.
I noticed a firewall rule could have been the issue with me, because since I unticked public networks it has been all good (I don’t know why I had that selected).
I hope that may help others with a similar issue? It’s early days though so I am still not 100% that the issue has gone.
Thanks for the xpansion!

1 Like

Update on what I said above * I spoke too soon, problem of authorisation still existing. I hope you get to the bottom of this issue soon.

1 Like

W. no wifi, standalone and plugin in Cubase instacrash.
in VE Pro as well, now, actually

1 Like

I have successfully migrated BFD3 from FXpansion to inMusic with no major issues. Picked up the free content (nice). Got everything installed and activated without too much trouble (I don’t own any kit content other than the BFD3 library). I was having the migrate settings from previous version pop up issue, I fixed that through editing the registry, thanks to whoever posted that on here, sorry can’t remember who it was.
The issue I’m now having is that Pro Tools 2020 isn’t seeing the BFD3.4 plug-in. I’ve tried all the obvious fixes, reinstall, trash cache and rescan plugins all to no avail. Works fine as standalone.
Is there a workaround or is this something that needs fixing in the next update?

Do you still have the old .dll in any folders that Pro Tools is scanning? I had both fxpansions bfd3.dll and the inmusic bfd3.dll, both with the same filename.

I renamed the newer inmusic on to 3.4 and my DAW (Reaper) then saw both.

However, to stop potential hassle, if you have both, I’d get rid of the old one and leave the filename alone.

I did have both libraries and BFDs installed initially but I got a message warning of conflicts as soon as I opened the standalone. I’ve wiped all BFD libraries, licence tools and applications (including all the folders and things that get left behind when you uninstall) and started from scratch. Still no dice.

Hello,

  • Steps to Reproduce:
    Launch BFD 3.4.0.24 on PC with AMD Phenom processor
  • Expected Result:
    Access to the software
  • Actual Result:
    Message “You processor doesn’t not support SSE4.1 instructions”.
  • Reproducibility:
  • Additional Notes:
    I followed successfully all of the migration process.
    But I can’t execute the new 3.4.0.24 version with this message “Your CPU doesn’t support SSE4.1 instructions”. It works great with last version, i have a dedicated PC for music with AMD Phenom processors (6 cores at 2,8Ghz/16 Go RAM/SSD disks/Asio audio card) and no problem of performance.
    So could you set this requirement optionnal or give me the instruction to revert back.
    I try to revert back but now when i launch the version 3.3.1.33 the gui is closing immediately.

Thanks for your help.

Heya, thanks for letting us know this. We’re gonna look into having a flag that will allow 3.4 to run on older machines.

2 Likes

Pro Tools support on Windows comingg in the next build. I put this in the known issues thread. Shouldn’t be too long!

1 Like

Thanks for the clarification Drew. Any indication how soon?

Hi Drew,

Is there a known issue with Pro Tools on Mac too? After updating BFD, Pro Tools crashes during launch. After moving the BFD plugin folder to “Unusued” Pro Tools returns to normal operation.

Cheers,
Tim

Just to echo other posts from @guitartom @Tjeerd @omegaBlock and @Civilization3
I have the same bug (please tell me it’s not intentional) and I suspect everyone else will have it too if they disconnect their internet prior to launching BFD3.

Understandably the licence manager needs internet access to authorise BFD3 and kits but does it need to run every time you launch BFD3?

Is there an off line authorisation process for people who don’t want internet on their music computers or have very limited internet access?

Should be pretty obvious what steps need to be taken to reproduce, just disconnect your internet before launching BFD3 (If you disconnect after launching BFD3 it doesn’t happen).

Would be interesting to see if this DOESN’T happen to anyone.

Steve