BFD3.4.0.24 - Bug Reports

Please post any bug reports for BFD3.4.0.24 here. Please follow the guidelines below.

  • Steps to Reproduce:
  • Expected Result:
  • Actual Result:
  • Reproducibility:
  • Additional Notes:

Steps to Reproduce:

The exact steps required for a bug to be reproduced consistently. This must be direct with no superfluous steps listed as order of operations. This is vital in determining if something can be reproduced.

Example of a good repro: :+1:

  1. [STEP 1]
  2. [STEP 2]
  3. [STEP 3]
  4. [STEP 4]
  5. [STEP 5]

The example above outlines in detail, the required steps that lead to the bug behavior.

Example of a bad repro: :-1:

  1. [STEP 1]
  2. [STEP 2]
  3. [STEP 3]

The example above fails to outline important details required to easily reproduce the bug behavior without requesting further information.

Expected Result:

What should actually be happening if everything is functioning correctly?

Actual result:

What is the unexpected behavior are you experiencing? This is often the same as the topic title.

Reproducibility:

How often do you encounter the bug behavior? Every time you perform the repro, 3 out of 10 times. A bug that cannot be reproduced cannot be fixed. Please consider this before posting a topic for a bug you cannot reproduce easily.

Additional Notes:

Are there any caveats for this to occur. Does it only happen after first install/boot? Does it only happen if this 3rd party device is connected? Does this happen for media, streaming services, or both? etc…

2 Likes

I’ve just updated to 3.4.0.24 and I’m getting a message every time I start BFD3 to copy over my prior settings, but when I try it doesn’t work. I even uninstalled my old FXPansion BFD3, removed all registry settings I could find, uninstalled and reinstalled 3.4.0.24, etc. Even ran BFD3 standalone as Admin. Keeps happening.

It’s somehow seeing FXpansion BFD3 content that should no longer exist, or is failing to write somewhere. Using Windows 10 x64.

To reproduce:

  1. Launch BFD 3.4.0.24 (plugin or standalone)

Result: get asked to import my FXPansion BFD3 content.

  1. Click Ok

Result: “There was an error trying to load your BFD content.”

  1. Then the setup Content Screen comes up (every time), it says my content was setup successfully

  2. Exit BFD3

  3. Try again, only this time click Cancel to defer instead of OK

  4. It tells me I can always migrate later via the preferences panel…so far so good

  5. Exit BFD3 and try again

Result: process starts all over again from the top. Can’t get it to not show that message about importing settings.

Also guys, the Contact Support page in it’s current state is awful and requires far too much information. Name, address, phone…Why not ask for my SSN, covid vaccine card, and run a credit check? :rofl:

I just wanted to get help and report a bug!

5 Likes

Hi,

I was able to get the new version installed, but I am getting a license error/notice on startup for the Sonic Reality Vinny Appice expansion despite the license manager showing authorized.

I also am getting the license error for the BFD2 content I had and cannot load my BFD2 presets. Should BFD2 license holders be authorized for London Sessions to get around this?

Also, is there any way to get the Eco or Zildjian content authorized?

Thanks.

Greg

funkybot - I was also getting the error to load BFD content until I installed the new version in a new directory, not where the previous version was installed.

Also had to manually move my presets though.

Greg

Thanks Musicmanicny, I tried installing to a new folder too with no luck. Was previously in D:\VST Plugins\FXPansion\BFD3, now it’s in D:\VST Plugins\BFD Drums. Still no dice.

Using Windows here.

I’ve just seen talk of a new version on the Reaper forum and came to look.

I guess I need to set up BFD on another computer if there is a chance its going to completely break my installation. I use BFD every day so I need a working copy.

This release went straight to the public? Or did I miss something?

Also Windows here. I changed the directory for the application, not the plugin FWIW. I was was previously in c:\program files\fxpansion and changed to c:\program files\bfd drums

@Musicmanicny
What Zildjian content are you referring to? BFD1, BFD2, and BFD Eco software is discontinued, and users were supposed to get copies of Eldorado and London Sessions as replacement content, but that hasn’t happened. I have reported it to the web team and will know more soon.

@funkybot
Definitely install to the factory default BFD Drums locations and not the FXpansion ones. The content import bug should be fixed in a 3.4.1 build soon.

I’ve reported the support form issue to the support team.

Hi Drew - sorry I thought that the Eco_DV showing up as not licensed was the Zildjian Digital Vault. Maybe it isn’t. Is the advice to delete the eco and eco_dv directories? Even though the software/engines are discontinued the messaging about the content isn’t clear,. Any thoughts on my Sonic Reality issue?

Right, so Eco and all it’s variations in terms of software, are not included in the migration. We currently have an issue with getting people the right content packs. So you should really get a copy of Zildjian Digital Vaults Vol. 1. If you email support@bfddrums.com and show them your BFD Eco DV serial number (your FXpansion one) they should be able to give you a copy of the pack.

Also the Sonic Reality issue is an odd one - it’s not loading any of the content at all??

@BFD_Drew

Drew, so 3.4.1 should fix the import settings issue? If so, I’ll wait for that. Just did another uninstall/reinstall using all default paths and ran into the same issue. Sounds like there’s a few of us running into this.

BFD3 Thingy

You can totally fix that yourself by:

  1. Going into C:\ProgramData\FXpansion\BFD3\System
  2. Copying everything in there.
  3. Going into C:\ProgramData\BFD Drums\BFD3\System
  4. Pasting everything into there.
  5. Going into C:\Users[USERNAME]\Documents\FXpansion\BFD3
  6. Copying everything in there.
  7. Going into C:\Users[USERNAME]\Documents\BFD Drums\BFD3
  8. Pasting everything into there.
  9. Launch BFD3.4 standalone.
  10. Hit cancel on the settings+presets copy dialog
  11. Go into the Contents Locations panel.
  12. Rescan all content locations (make sure you add any audio packs that are missing too!)
  13. Hit the button to rescan user content paths.

That is effectively what the migration process does. All your presets and kits should now be in 3.4 and the dialog should disappear.

2 Likes

@funkybot Agreed on all points.

I have this and v3.4.0.24 does not find it. The content is located in my existing BFD2 directory. (BFD2/Audio/Zildjian)

That’s not the ideal installation location for that pack. I think we need to do some reconfiguring of your install locations. I’ll PM you.

@BFD_Drew None of those old FXPansion\BFD3 folders even exist on my machine anymore. I had already uninstalled all things FXPansion BFD3 related yesterday while trying to fix this on my own.

Now those folders existed the first time I installed the 3.4.0.21 update but after I ran into this issue I wiped all the FXpansion BFD folders. I think there’s something else going on here. How is it determining I have BFD3 content to copy? That seems to be where the problem is.

Want to take this via email?

Oh wow. That seems to be totally borked then! This didn’t come up in QA, so I’m thinking there is some peculiarity that got overlooked. I’ll email you.

Right, on Windows, to stop yourself being annoyed by the constant nagging of asking to copy files, here’s what you can do - please make sure you’re comfy using the Registry Editor:

  1. Open Registry Editor
  2. Navigate to: Computer\HKEY_CURRENT_USER\SOFTWARE\BFD Drums\BFD3
  3. Check for these entries: FirstRun, fxp2inm_migration, and NeedScan
  4. If you don’t have them all, create them. They should all be string types.
  5. Set FirstRun to ‘No’ without quotes.
  6. Set fxp2inm_migration to ‘migrated’ without quotes.
  7. Set ‘NeedScan’ to ‘no’ without quotes.

This will stop BFD from nagging you about copying across old files. I HIGHLY recommend you still do this manually though. You don’t want to lose any of you precious kits or presets that you’ve created and saved out.

1 Like

Migration at the first start is successful if you start BFD3 one time as administrator.
Next time you can start BFD3 normal.

Greetings jhkaufi