[RESOLVED] BFD can't find libraries

Hi,

I just migrated to a new Mac running Monterey and BFD 3.4.3.7. BFD seems to successfully scan my content locations and they all show up when scanned, but my expansion pack libraries don’t show up now when I click on the “Library” button. The content is on an external drive and I’ve never had this issue with earlier versions on my previous Mac. Same issue in standalone and Logic.

Has anybody found a fix for this?

Thanks.

Edit: I can see the individual drum pieces in the browser. Just not the presets and kits.

I seem to have solved my issue. It was user error.

If it helps anyone else, the mistake I made was to assume that when changing computers I could just download a fresh copy of BFD to the new Mac and change the content paths to the 200Gb of expansion pack library content I already had downloaded to an external drive, so I don’t have to download it all again. My error was that I did not install the expansion libraries on the new machine. This didn’t work, presumably because some files were missing.

The fix was simply to install the expansion packs properly via the License Manager. So far it is now working normally (I am still installing). I can see presets and kits.

However, it seems absurd to me that I now have to download 200Gb of content I already have sitting on a drive. I don’t see any other options in the installer to avoid this but I welcome any suggestions.

You don’t need to install every pack again, I think what you’re running into possibly is missing kits and presets, as opposed to the drums themselves?? Do the drums themselves show up? If so, then your content is working fine and it’s just a preset and kit thing we need to solve; which can be solved by moving the old FXpansion presets and kits folders into the new BFD Drums/BFD3 folders. I can walk you through that, but please let me know about the question above first.

Hi Drew. Thanks for the response. You’re spot on. The individual drum kit pieces were indeed showing up for each expansion pack. It was just the presets and kits for each expansion pack that did not show in the browser. I figured it may be a case of just moving some preset and kit data from the old Mac to the new one, but as I wasn’t sure how I just went ahead and reinstalled the packs. At this point it’s all working just fine, so I don’t need any additional assistance. It’s good to know for the future that we don’t have to reinstall all the content though. Thanks again for your help.

Hi Drew,

I have a similar problem, where I have just downloaded and installed bfd3 on Monterey (I had to use your license manager fix to get around that other issue so thanks for that) But now when I open BFD3 either as a plugin in logic or standalone, it can’t seem to locate anything at all. In the standalone version I get the yellow flags next to the kit pieces and in Logic it just says “searching” in every tab (image attached). I made sure I downloaded all of the contents to the recommended default location which was /Users/myname/downloads/BFD Drums

Do you know of any fix for this or where I might be going wrong? Thanks for advance!

Hey, could you go into the Tools menu at the top, and check the content locations panel - post a screenshot of what you’re seeing in there. It is likely that the library isn’t connected.

The logic thing is a different thing.


Thanks for the real speedy reply.

It may well be a basic error- I’m a bit of a novice at the moment unfortunately. Is the logic thing fixable, as that’s where I intend to use it?

Thanks

Looks like you’ve added the installer folder for the bfd3 core library? That won’t work. You need to run the installation program.

I’m not sure how that went wrong tbh…I just went through the installer and chose default options. Would you mind giving me a bit of an idiot’s guide of how to fix this? Would I need to uninstall it and start over?

Thanks for the help

@josephus Firstly, uncheck the middle location with samples. Click, remove selected content paths (groove/preset installers). Quit BFD3. Go to your Downloads folder and run the installers for the grooves and presets. Choose the install location you want. Open BFD3 and rescan your content locations. Done.

As a side note… you really shouldn’t be installing sample libraries to your main OS drive if you can help it. Any cheap USB-C/Thunderbolt drive will work fine for BFD3 sample libraries.

1 Like

Thanks very much for the help-

I unchecked the middle option and removed selected content path which leaves me with the other two

For the second part, I can’t see any separate installers for grooves and presets- Only the main installer which I ran through the license manager…Should I be seeing something else?

I apologise in advance if I’m being completely stupid and the answer is obvious- the chances of that are quite high :laughing:

thanks for your advice on the thunderbolt drive also.

1 Like

So the BFD3 Core Library Installer. Double click that.

Every installer has one of those files, and it needs to be run.

I ran the BFD3 core library installer. I restarted BFD3 and rescanned content paths but I’m still getting the yellow warning flags flags next to kit pieces… :weary: Would completely uninstalling and starting again cause any problems for me?

The grooves and presets installers I was talking about were the Sonic Reality ones. Those I might install in your users/Documents/BFD Drums/Grooves + then /Presets.

Where are you installing the actually sample content for libraries/expansions, in the same Documents/BFD Drums location? If you’re installing everything to that single parent folder location, add that content path in BFD3 Prefs. Upon scanning, it should find what it needs to and add those content paths.

For using one drive, I might suggest installing the samples themselves in users/Music. Add a folder named BFD Drums and install there. The BFD3 Core Library installer will install the presets, grooves and kits for that in, Library/Application Support/BFD Drums, even if you’ve chosen a specific location to install the samples. Wherever you choose to install, you have to add that parent folder location in BFD3 Prefs.

I’m not sure this made sense? :rofl:

1 Like

It made perfect sense- thanks so much for helping out- It works perfectly now in the standalone application.

However, when I open it in logic, and click on ‘kits’ or ‘drums’ I get this…


It just says the word ‘searching’ and never loads anything. Do you have any suggestions about how to fix this issue?

If anyone can help me fix it I’d be happy to make a donation to them

thanks

This user just posted a fix for what may be your problem as well. Not sure, but check it out.

1 Like

Thanks again mate- I’ll give it a try!

1 Like

Ok so, It appears the problem is that the plugin won’t authorise in Logic…I’ve tried resetting and rescanning selection to no avail…Would uninstalling and the reinstalling cause any problems or is it safe to try?

Hi Josephus,

I would contact inMusic support for re-authorization.

Kind regards,

Living Room Rocker