[RESOLVED] BFD can't find libraries

Hey Drew
I am having the exact same issue as Joseph. Works fine in stand alone, but freezes in Logic when you run the Tools to search for content. It is default to the drive set up in stand alone so it should see it but I just get the spinning wheel.
I am happy to post pics.
Latest OS, Mac Studio, latest BFD.
Thanks.

Okay so I believe I fixed it.

Go to applications folder and right click Logic Pro and click ‘get info’. Half way down this list is an option that says “open using Rosetta”- check the tick box and then start Logic. Go to plug in manager and then rescan selected plug-in and try opening BFD to see if it’s fixed

Thanks
Will try asap.
I guess this means we are running logic in Rosetta and not natively?

I guess so yea. I don’t really know what that means in the grand scheme of things but now I can record with BFD so personally I don’t care what mode it’s in :grin:

Thanks that did the trick, and Logic seems ok running in Rosetta as well.
Really appreciate it .
Cheers

1 Like

I’m having the exact same issue. So are we saying on ARM Macs BFD3 will only run as a plugin under Rosetta? That’s a bummer if so, because it will negatively effective the performance of your DAW by about 30%. Can anyone from FXpansion confirm this?

No one from FXpansion can confirm it, because FXpansion no longer owns BFD! :wink:

But yes, currently we only support Rosetta. M1 native support is in development and scheduled for a 3.4.5 release, hopefully before the end of July.

Thanks. I’m just discovering all of this and transferring licenses to inMusic. urgh. What about running BFD3 from inside Komplete Kontrol?

Ok, I just tried that and it works. I guess because its a VST host, not AU. I think this is a much better option than Rosetta personally.

josephus,

I created an account to say thankyou. Months ago I contacted support directly and heard literally nothing back, it’s great to find someone like you willing to help others.

It’s good to hear that an M1 version is on its way. I’ll wait until then.

Thanks again,

Steven