[EXPECTED BEHAVIOR] License manager not responding

Nope, it doesn’t work in Studio One which is 100% of my usage. I am not trying to licence anything new. It worked fine yesterday. It simply lost the authorizations and claims I am not logged in to my inMusic account and the LM can’t connect.

OK. So what I had to do is remove all my content paths and one by one add them back. So BFD was not searching the content paths, another bug.

So it seems there are multiple issues.
I have the LM off
I have the Wifi off.
Under those conditions, BFD 3.4.2 works fine for several days - perhaps a week or more, and then decides on its own to dump authorizations?
And then of course when you turn the wifi back on to run the LM - it can’t connect, it can’t find, it can’t confirm or deny, it doesn’t know what happened - It has Alzheimer’s.

1 Like

Continuing the discussion from License manager not responding:

Aaand now standalone said goodbye too. Just great. I am so lucky not to make money with music and just be a paying customer. Get the servers up and running or whatever you messed up…

Same here, still not working. Blank license manager.

If BFD wasn’t my favourite sounding drum software I would never use it. Thank god Superior Drummer 3 has midi maps for BFD3 or I would get nothing done. That said, I have to start bouncing to audio from now on at the end of sessions just to have something to listen on days when this thing doesn’t want to work.

And just to rant some more, I just noticed BFD3 is $429.99CAD new (I’ve been a user since BFD1). How can they sell this to new users right now? It’s absurd.

Alright, end of rant.

1 Like

Ps. Poor Drew must be so stressed out as well. I hope he gets a raise.


I’ve just had this as well (for the first time)

I’m not 100% but it just seems like it’s a connection error to server.

Mine came back on straight away after re opening licence manager.


Okay, up and running again. I had to log out of license manager app itself (User>Log out) itself and log back in. Previously I was just closing it and reopening to see if it worked. I even deleted and reinstalled it and that didn’t work.

Anyway, hope log out/log in works for others.

Edit: Now BFD is just crashing on startup…over and over.

1 Like

this is getting ridiculous. i show no listing in control panel (windows10) of the license manager… just BFD3 and related kits and components. although i show it in start menu and explorer (file location) but when i try to uninstall it … it sends me back to the control panel where it is not listed. lol

and inmusic HAS NO DOWNLOAD FOR BFD3… in my account under downloads for BFD3 it has a link to the license manager lol which freezes on launch, will not uninstall and reinstalling on top of what is there on the system does nothing… freezes on start up.

luckily BFD3 is working at the moment but that will probably soon quit. from speaking with support (email) not long ago i was told that the license manager refreshes authorization once a month. hence why authorizations go red and have to re-authorize them. this makes no sense but apparently the license manager has to be online at least once a month?

looks like i may have to delete EVERYTHING soon and start over if they don’t get this sorted and fast before LM wants to call home and locks me completely out with no use of my software. :frowning: seems inmusic hasn’t got a clue and maybe that is why they will not respond. after all this is claimed to be a ‘support’ forum lol

this is all i get now…

Technically, this is a user support forum and not the official place to go for support.
I think that’s the case with most software forums that I’m aware of.

You don’t have to uninstall the licence manager via the windows control panel, just go to;
C:\Program Files\BFD Drums\BFD License Manager and deleted the folder.

If you have something like ccleaner it can sometimes be useful to clear out any residual registry entries so I’d suggest running that, then reinstall the licence manager.

If you do go down the, ‘reinstall everything’ route, you don’t need to delete your libraries, grooves and presets, just uninstall BFD3 itself.

Hope that helps


This is what @BFD_Drew had mentioned and said he was trying to convince them of their folly.
I thought it would be 3 or 6 months before a refresh was needed, not monthly.

I think this is a seriously bad move on their behalf that may well lose them a lot of custom and certainly won’t gain them any. They seem to be shooting themselves in the foot on this one.

I thought it was a bug at first and I’m still hoping it is,either that or they’re just trying it out and are having teething problems.

If they are determined to ignore their user-base and press on with this, the least they could do would be to implicate some kind of warning system that gives the user a weeks notice to go on-line and refresh their auths rather than have them bewildered and angry an unable to use their product that they paid for.



yes i agree this is a terrible move on their part. even the crappy codemeter protection Vengeance Sound uses for Avenger that so many hate refreshes i think in 90 days so those that may be traveling abroad don’t have much of an issue. once a month is ridiculous imo

i may try the folder deletion and see if that takes for the LM. i don’t want to remove BFD3 if i can help it since things are working for the time being. as for the libs i don’t think i will have to bother like i did last time since all are new installs via the new LM. i had to redo them all to get BFD3 working at least for me.


1 Like

well the deleted LM folder and reinstall has the same result which makes no sense. it doesn’t load far enough to even get any graphics :frowning: i suppose i will wait until everything goes tits up before i reinstall the BFD3 program. thnx for tryin’ steve

1 Like

Sorry to hear that and sorry I’m out of ideas for suggestions.


yeah… it is what it is but i would like to know if this was all caused by me removing an external USB drive because all was well until i unplugged it. and as i said… i don’t have it handy at the moment

I’d forgotten that, it’s possible the LM is looking for something that was on your other hard drive.

You could try going to; C:\Users\YOU\AppData\Roaming\BFD Drums\BFD3 and deleting the DataPaths file.

Then open BFD3 and to go to the contents page and point it to where your library is.

If you can’t locate the folder in maybe that you don’t have, Show Hidden Files, Folders and Drives checked.
To make sure it’s checked go to Control Panel/File Explorer Options then click on the ‘view’ tab and you’ll see it listed under, Hidden Files and Folders


thnx nah i know my sys and ‘show hidden’ is the first thing i do on a new OS install

as for the datapath.xml i scanned it and found no references. the external drive was listed as G: when it was plugged in and i cannot find any reference to it.

only other thing i can think of is i updated my video card driver since i have no graphics at all in LM when it launches… well except for the frame and top menu so i don’t think it is graphics related at least not my vid card or driver.

again it looks as if i will have to wait until BFD3 stops working then redo program install. i am not going to reinstall any libs if i can avoid it.

thnx again for trying


1 Like

just a heads up…

if you note i stated in my first post that i had an external HD attached to a USB port and it was seen as G:??? now get this… i plugged in a thumb drive to put a couple of mixes on to listen to in the car for reference. i forgot to unplug it and for shits and giggles i tried the LM as i do most every other day to see if there is a change in it working. low and behold the LM works just as it should which shocked me then i realized i had not removed the thumb drive. i shut down the LM and unplugged the USB thumb drive which was automatically assigned the letter G:\ (next letter in line) by windows. i tried to start up the LM and BANG it was frozen again with 19Mb on my RAM and it reported ‘not responding’ with no graphics just as it had done the last couple of weeks or so. again i was shocked so i repeated the situation 3x with the same outcome… LM works with the thumb drive in assigned to G:\ but fails when the thumb drive is removed. this is easily repeatable. so i ask what is up with the LM or BFD3 for that matter authenticating the machine by the G:\ drive designation? it does not matter WHAT i have plugged in as long as it gets the letter G:\ assigned to the device. THIS IS RIDICULOUS!!!

this is NOT my system as the problem… the problem i am having is in the programming of the software and how it authenticates the machine in use. it’s the stupidest thing i have ever seen… especially since i used to be a programmer.

Is your license manager trying to access g: as a download location perchance? Maybe try changing the download location to another drive (c:) and then try it again without the thumb drive?

1 Like

good thinking gman :slight_smile: that was it… i had downloaded the installers for the libs and ran them from that HD since it had plenty of room and deleted the installers but failed to change the download location back to default C:\User\Downloads so that is where it was hanging.

what a strange chain of events to figure this out. thnx again gman and i apologize to inmusic for my oversight. reckon i need to eat some crow lol


p.s. sry i did not notice it was gman that offered the solution… so i edited

1 Like