[EXPECTED BEHAVIOR] License manager not responding

i unplugged one of my usb external drives and now the license manager will not respond… just a white box and no graphics. i would try to plug the external usb data drive in but i don’t have it at this time lol but for the life of me i can’t figure out why a usb drive would affect the new BFD License Manager. does the license manager authenticate a machine using plug in external devices? if so that is kinda dumb imo… it should only use actual hardware physically attached to the motherboard or preferably integrated on the motherboard itself.

anyways… any help would be appreciated. just another headache… it is one right after the other :frowning:

I can’t currently connect to the server, I’m guessing there is a technical problem. I’m beginning to get pissed off with this stupid Authorisation system. BFD was working fine earlier now it’s not authorised and I can’t even refresh my product list in License Manager to reauthorise.

I’m having the same thing.

So is BFD set up so that it can randomly disable the software when it gets a straw up it’s ass?

This does not bode well for professional use.

– Aa


So BFD3 gives me the alert, "BFD3 has been disabled because You (sic) are not logged into your inMusic account. Please run the BFD License Manager.

When I launch the license manager, it shows that I AM logged in. None of my licenses are showing, however.

This is completely fucked. Did they get hacked or something? If I set up BFD how I like it, disable internet access, can I prevent this in the future? Or does BFD REQUIRE a phone home internet connection?

Bad. Very Bad. Please return my $$$.

– Aa

1 Like

Yep - same for me. Need to schedule recording sessions around the License Server being down.

BFD (Deal) could you please provide schedule of when your long time crap products license server will be up so that I can make my musical life revolve around your needs??

Thanks so much.

So done with you. Next $$$ goes to TTracks.


Same problem here. This is aggravating.

Also, is there anybody at BFD tech support? They’ve NEVER responded to any of my queries. I don’t think the send button on the support even functions. I have managed to find a direct email, however, and no response from that either.

Abandonware now? But still willing to take my $$?

I’ve heard of a class of people who purchase their software but run pirated copies anyway. I think I understand now.

well i don’t think my problem is related to a server being down. the manager on launch does not even get far enough to load graphics and i suppose the ‘call home’ is AFTER the program loads. “not responding” usually means at that point the program has frozen and is not loading completely. although idle it IS showing it loaded 19Mb into memory at the point it becomes unresponsive. :frowning:

3.4.2 has been working relatively well for the past couple of weeks.
I shut down last night. Today when I open up, BFD was compelled to unlicense everything.
I start up the LM and it says:

“There Was An Issue Retrieving The List Of Products”
“Our server was unable to process your request - Try again shortly”

We did the usual dance of shutting down/reboot/launch LM etc. Got nothing.
An hour later- still nothing.
Yes, we’re connected to the interweb -( I’m typing this from the same computer)
Mac Catalina

Things were working very nicely -We thought we were one of the lucky ones.
Clients give you that condescending stare if their project takes that extra minute for some reason to load.
Imagine what they think when all those yellow triangles of death come beaming through.

So what do I do now?

UPDATE!! - and just like that- 2 HOURS LATER - the LM decides to grant us access and we’re up and running again.
We’ve been using BFD since the beginning some 15 years ago! Never had these problems.

Mine is still not working: “There is an issue retrieving your list of products”

I never complain on forums about anything but this is ridiculous. Utterly frustrating.

Probably the same here.
When I noticed that there was no sound, this is what I saw.

“BFD3 has been disabled because
An unknown error occured
Please re-install BFD3 to resolve and contact BFD Drums tech support”

I believe that the tiring reinstallation task is probably useless… I’d like to wait for their handling.

I can’t work!

As a software developer myself I’ve been very lenient with this whole thing But now I can’t work my music because BFD3 randomly decided to unauthorize everything? Get your sh together people. All other companies with online licensing I use make it work flawlessly. So it’s on you and you alone to do so too. You really seem like you’ve got no idea at all what you’re doing by now.

So … 12 hours and counting, and still despite being able to login to License Manager it can’t display my licenses so that I can reauthorise the stuff that randomly deauthorised itself! FFS. @Drew any ETA on when this is going to be working or should I just go to the beach for a couple of days?

I just opened BFD3 and didn’t get any messages so I opened the licence manager and like others here none of my products were showing.

So I opened BFD3 again, loaded a kit and it worked fine so no problem there.
Opened the licence manager again thinking I would log out and then try to log in again but this time all my products were showing.


1 Like

Bully for you @Steve63. Unfortunately still not working for me (and others I would guess).LM logs me in but then fails to retrieve products list. Two error dialogs. ‘Our server was unable to process the request. Please try again shortly. Server Message:’ and then ‘Could not connect to the server. Please try again shortly.’

1 Like

Right, I’ve got it. I got the list only when I logged out and then using a browser logged back in to my account. That might help others sort it hopefully? What a PITA.

Nay, Nay thrice nay. Everything looked like it was authorised but then when I open up an Oblivion preset in BFD standalaone loads of frigging yellow triangles. I’m beyond gutted at this stage.

Standalone: works fine.
Plugin:said license error.
LM: can’t connect.

This is beyond a joke now.

Sorry, I wasn’t saying it worked for me to rub peoples face in it, I should have clarified that maybe opening the LM then BFD3, then the LM again might help other people.

As I said, I was going to log in and out again to see if that worked.
I thought the LM always uses your browser to log in but could be wrong.
If it does always use your browser, maybe something is stopping it calling home?

You could try uninstalling and reinstalling the LM.

I’m assuming you’re suing the build of BFD3?
I know it doesn’t solve your problem right now but I think BFD are aware there is still a bug with the LM


Does it work in your sequencer and are you trying to licence new kits?