BFD3 v3.4.3.7 - "BFD3 has been disabled..."

Okay. We now know why this is happening. Hotfix in the works.


I have confirmed that re-installing BFD3 using: ( BFD3_3-3-1-33_Update.dmg ) will let BFD3 work under OSX Monterey 12.0.1 (both standalone & in Logic 10.7.0). BFD3 seems to be unable to locate some of its content, however. BTW: BFD Eco works with no problems under OSX12.

I seriously don’t recommend going back to - for anyone. Very few situations where that is going to be helpful given that FX/ROLI are slowly turning off servers and things.

I’ve confirmed with a few users that our Monterey fix works. If you want an advanced copy of the License Manager hot fix, please PM me.

We’ll get the fix out for public release ASAP.


I could use a manual method for removing older fxpansion/roli files. Is there any info on that?

Here’s a warning - if you use the “migrate” feature, it might result in crashes!

Thanks for the assistance Drew!

I’d like the LM hot fix, please!

I tried the new LM Everything seems to be working now. Thanx.

1 Like

Nice one, thanks for letting me know!

1 Like

License Manager fix definitely the ticket for getting BFD update to work in Monterey. Thx!


Hi could I also get the LM fix? Fellow user with same problem on Monterey as above with the new MacBook, really need to get my BFD up and running! Thanks

Hey Drew, greetings, is it possible to have thi hot fix for Monterey too here please ?

I’m not PAYING for version 4 to get away from all of this BS. I just upgraded to BFD3 this season, and my reward was HOURS of extra WORK to convert my projects from BFD2 to BFD3, and it’s been an absolute miserable experience. Why would I spend more money? I did that with Cakewalk for years. Six versions of their product before I realized they were never going to actually address the real issues, but they WOULD keep asking for more money.

1 Like

I can completely understand everyone’s frustration with BFD. I started using it with BFD1 and it has always been overly complicated. Every time their is a major update to an operating system BFD stops working. If there was another drum program that sounded as good as BFD I would use it but so far I have not heard one. We are all musicians wanting to make music, but technology as wonderful as it is can really get in the way sometimes. I hope they will fix this error many of us are getting that prevents us from using the software now.Cheers!

I’d like the LM hot fix, please! Thanks!

I guess I’ll post this publicly for now, saves everyone having to PM me.

Please make sure you have BFD3.4.3.7 installed first.

BFD License Manager_3053_OSX.dmg (1.7 MB)

Close all BFD software. Then please download and replace your existing BFD License Manager with the new one above. Then launch BFD3. It will ask you to login to your account via License Manager. Do that.

Then authorize your software and packs.

If you get the “maximum simultaneous authorizations” message, please let me know and I will clear out your authorizations.



Thank you very much, it works for me !

Hi Drew thanks for that, I got the maximum simultaneous authorizations message could you clear mine please? i can message you more info if needed

LM_3053 worked straight away for me, thanks. Didn’t even have to re-authorize. This is how it should be. Fingers crossed.

That did nothnig, here’s my scenario, on my MAC 2012 Pro, 64gb ram, 12core cpu, 4 drives amounting to 6TB, Mojave Os, everything seems to be going okay after the migration etc. Even when I got the ‘BFD has been disable’ annoyance, once I launched licence manager and signed in via browser everythnig is great, beside the annoying duplicates issue. Stand alone and in DAW are rocking.

On my macbook pro, Monterey 12.0.1, 2.2 qudcore i7, 16gb the ‘disabled’ message comes up in standalone version only, no matter what I try, including all the suggestions on here, it just won’t go away, rather dissapointed much like everyone else. However, in my DAW, Cubase Pro 11, it works ok, some slight glitches here and there but I suspect that is becasue of the OS I am using? Not sure if BFD is fully up to date with Monterey yet, I am fortunate to have the macbook as a testing ground.

I have been using BDF since it’s inception and first public release, huge fan, nothing else comes cose to it in my opinion. Over the years I have spent a small fortune on this product, I have more than half of the xpansion packs too. Some of the problems I read on here that people are having I have faced too, but I grin and bear it and hope for resuts. I have tried loads of other drum software, all the competitors, and even still have them loaded on my mac, but when doing professional produtctions I ONLY use BFD, 99% of the time anyway. It’s the best.

Apologies for the long winded message, but I’d love to be able to get rid of that annoying ‘disabled’ problem. Thanks for listening.

editing 13/11/2021

Testing more on Monterey, still no luck with standalone version of BFD…
I noticed this while using BFD in my DAW today, when selecting a channel and applying an effect to the channel, the effect flashes on an off, you can see when I applied spacial effect to the AmbMix channel and when I applied eq to the snare, it flashes on and off? Please see link:


I hope it’s viewable, if not let me know and I’ll upload it somewhere else.


1 Like

Thank you, it works!

Thank you! I’m up and running in Monterey.