BFD3 v3.4.3.7 - "BFD3 has been disabled..."

Hi all.

First time poster.

I used LM to update to version 3.4.3.7 this morning. Since then, I can’t run BFD3 as either plug-in or standalone. This is macOS Big Sur, on 2 machines - 6-core cylinder MacPro and a 2019 8-core MacBook Pro.

I get “BFD3 has been disabled because You are not logged into your inMusic account.”

I’ve seen posts with similar issues, which suggest logging out and re-logging back in on LM.

I’ve tried that, but no luck. Still doesn’t work. The log-in is successful, LM says it’s logged-in and can see my license. …but BFD3 itself is not working. :frowning:

Any ideas?

Edit: I note that other threads mention an older version as being current. Not sure why LM should be pulling a newer version, unless the version numbering is not linear?

I also seem to have a later version of LM than what’s currently mentioned - 3.0.5.2.

No idea how I’ve ended up with these later versions, or if they’re valid.

I notice that I have the update 3.4.3.7 available. Has anyone updated to this version successfully and without issue? Bit wary to update given @ChrisCabbage’s problem as the current version is working OK for me.

Please logout of the License Manager, and your inMusic Profile account, and then log back in.

If that doesn’t cure it (pretty sure it will) then we can do a deep dive!

Hi. As I mentioned in my opening post, I’ve already tried that.

Oh sorry about that, I missed it. Doing a million and one things!

Let me run this past a developer. Be back in touch.

I took the plunge and updated. Working fine, no issues so far. Thanks @BFD_Drew.

I updated to MacOS Monterey and am now having the same problem. I have logged out of both the License Manager and my inMusic account. When I log back in, it shows BFD3 and all my products authorized. But when I launch BFD3 (v3.4.3.7), I get the same message - “BFD3 has been disabled because you are not logged into your inMusic Account. Please run the BFD License Manager”. So I am stuck…

Please navigate here:
MacHD/Users/[USERNAME]/Library/Application Support/com.inmusicbrands.softwareunlock

In there you should have a file called SESSION - please send it to me in a private message.

Then delete it, and try logging in again.

Exactly the same issue, I shouldn’t have upgraded to eagerly! @BFD_Drew is there anything I can do ? Also nice to know you are still affiliated with BFD!

I found the SESSION file but when I try to upload it to you in a pm, it says it is not authorized (needs an extension like .txt, etc. When I added a .txt to the file, I still couldn’t attach it because I am a “new user”… I did delete it and reopened BFD3. Still get the same disabled message asking to log into inMusic account, which I do, but same problem…

1 Like

SESSION file sent.

My laptop is now Monterey and MacPro is Big Sur. Effect is same on both.

Deleting the SESSION file doesn’t cure the problem.

@ChrisCabbage @deleuze @Danjo

Hey guys. Do any/all of you have multiple versions of BFD3 installed? Any bfd3.dll vstplugins hanging around in other folders? Are you all on OSX?

What version does License Manager say in the About box?

I’m gonna pin this for a bit so it can stay on everyone’s radar and we can get to the bottom of it.

Hi @BFD_Drew I went as far as uninstalling all BFD products, even going through library folders and looking for Audio units etc.

I removed all content and bits of BFD3 last night to and used Licence manager to start over. Just to be sure I changed my inmusic profile password before doing this, and used a different default web browser.

After all this, still have the same issue OS 12.01 Monetary. Licence Manager 3.0.5.2. BFD 3.4.3.7 Standalone Mode for now. Worth nothing that it was working just fine on these versions on Big Sur just before my OS upgrade last night, when I decided to join the forum!

Licence manager appears to look normal, when I launch the app I still get the error “BFD3 has been disabled because You are not logged into your inMusic account.”

Any assistance or advice is appreciated.
Thanks,
Dan

Are you on MacOS? Which version

I’m mainly Big Sur, but tend to keep my laptop up-to-date.

I forgot to turn off automatic updates on my MBP and upgraded to Monterey, and that’s when the problem started for me, although BFD3 has been my only audio issue so far.

only single version of BFD3 (3.4.3.7) for me. License Manager is 3.0.5.2. I noticed in my applications I still have a copy of the old FX License Manager, which I assume I should get rid of, although it hasn’t caused any issues before…

My laptop, which is running Monterey, was working before / until the update though. :face_with_raised_eyebrow:

Okay. Interestingly I have updated my Big Sur to Monterey here, and now my previously working installation is broken and will not authorize. So I’ve reproduced the problem. I don’t know why it is happening. I need a developer to take a look at this.

2 Likes