BFD3 v3.4.3.7 - "BFD3 has been disabled..."

Ah. Thanks! Could maybe be a slightly different problem between my 2 systems then.

…but I guess we need to have things working on Monterey anyhow.

Just here to confirm this issue. Upgraded from Big Sur to Monterey on my second (less productive) MacBook. BFD (latest version) is not authorized and logging out/in the inmusic account and deleting the SESSION file doesn’t help.

Here to confirm too. I got a new MacbookPro with the M1 Max chip and couldn’t downgrade to Big Sur.

I have the same issue everyone is describing.

More info. I downgraded from BFD to (I kept the installer) on my MBP with Monterey. I opened BFD and it gave me the disabled message. I logged in on the License Manager, then BFD opened normally in Monterey. Is the problem the latest BFD update?

That’s what my experience is pointing towards. I had it working on Monterey.

Apple just dropped the new M1 with 64GB RAM. I seriously might upgrade before my current machine has died, which I’ve never done before. Hope you guys report success on M1/Monterey soon.

Please re-install FX license manager and BFD3.3.1.33.
You can use BFD3(Not3.4) on Monterey

Is there a link to those versions…?

If you bought the BFD3 in era of FXpansion.
You can download here.

1 Like

OK, but even though I’ve used the same Mac for 8 years, I’ve exceeded my authorisation count. :frowning:

…and I think this means that I lose access to some of the expansions too.

This happened to me many years ago with BFD2. I emailed FXpansion and they reset my authorizations for me. Not sure this is possible now that they’re not really supporting BFD anymore?

Well, do you have installer? If you revert to that you should be good on Monterey.

I don’t have that. :frowning:

It’s happening because there’s a malignant pile of garbage called DRM interfering with legit customers using the product THEY PAID FOR.

1 Like

I can use BFD3 in standalone on Mac OS Monterey, but receive the “Disabled because you are not logged in” message when I try to open it through Logic (10.7) in Rosetta.

Please advise. I love the sound of BFD3, but I’m already running in Rosetta and these kinds of problems are making me consider a move to SSD3.

Just chiming in here as a 1st time poster but long time BFD3er. Another Monterey user, a new machine (M1 Pro chip) and a fresh install of BFD3. Only ever installed on 1 previous machine. BFD3 is saying its been disabled despite license manager showing that BFD3 is authorised correctly. So very much the same situation as others here.

To make matters worse, I ended up de-authorising BFD3 on my old machine to see if that would help with the new machine… Nope. And now can’t get the old machine re-authorised so don’t have BFD3 up and running on any computer.

Hoping the developers can find a solution quickly.

EDIT: just to clarify, this is for both standalone and plugin

I seem to have gotten to the point on my main production system, where I’m going to have to remove everything - the old fxpansion version and the inMusic version and start again.

I’ll wait until the devs have updated and fixed the issue. Happy to test when a new version comes around.

I’ll put the project on-hold. Not ideal though, when the DRM gets in the way of using the products. :frowning:


I updated recently and so far have not encountered problems. We’ll see in 90 days.

1 Like

I get the same error and tried everything posted here with no success. Using Mac with Monterey. I have been a user since BFD1. If there is a BFD 4 in the future-make it easier to manage and install.

1 Like

Ok Thanks @BFD_Drew I will hold off reverting back to BigSur for now. I am also worried that my authorisation count might have exceeded.