[UNDER REVIEW] BFD3 notes in REAPER getting randomly "choked" after working on a project for a while?

Hello. I’m really not sure what is this bug and if it’s been happening to other people as well. I bought BFD3 with the Core Library a few months ago but actually I haven’t had much time recording with it until now. When I wanted to work on something new I saw the software was transfered to inMusic and an update was offered, so I uninstalled the existing BFD3 (possibly wasn’t needed) and installed the new one (v3.4.2 build 4) from the new license manager.

I’m using REAPER v6.31 on Windows 10 and what’s happening is that at some point while working on a project, the cymbals and even the drums when it’s audible start dying out randomly on their own, only when the project is in play or recording mode. Then if I want to render the project, rendering time whenever there are drums become horrendous; it took almost 2 minutes to render a few second test and the note choking was also on the rendering. Reopening the project fixes the issue.

Also another thing to mention is that I have no available presets or kits showing other than the custom one I created. Any idea what happened to them? Because I remember there were included kits/presets, but perhaps it was before I installed the new version and it somehow got lost on the way?

Thanks in advance.

1 Like

Yes, this has happened to on occasion me since the last version. I don’t know exactly how to consistently reproduce the issue. However, there certainly is an issue here, like you say closing and reopening a project usually fixes it… until it happens again.

OK, so at least it’s not just on my PC. Are you also using REAPER?

And have all of your pre-included kits gone missing as well?

No not on Reaper. I don’t have a problem with lost kits/presets. I did have to remove and reset content paths recently because BFD was not finding drums even though the content paths were set.

Yes, this was one of the early bugs I ran into when v3.4 first came out. This was on Mac, in standalone mode. I forget whether I saw it in VST or AAX. All kit pieces and articulations would suddenly start choking after the same sample duration.

I found I was able to force it to happen if I loaded several presets or kits in a row successively. Once it started, the only way to stop it was to kill and restart. Restarting the engine, resetting BFD, and loading a different kit didn’t help.

I’m not sure anything in particular fixed it, other than newer code - if that was even the solution. I haven’t run into it in a long while, and I don’t think at all since going to v3.4.2.4. But, it is one of the things I test every now and then, because I never really got a satisfying resolution of it.

In my case it seems to happen (after it begun) only when the play or record button is active, and also as I said it completely messes up the rendering speed. I’m not sure the choking happens consistently either. It will choke everything at once, but sometimes it takes just a fraction of a second to choke a sample and sometimes it might take more than a second.

Have this problem in Studio One 5.3 (and 5.2 before the recent update and in the still installed 4…6 or whatever the last v4 was). I can get rid of this by loading everything to RAM so this is a workaround for rendering the final round but it has never happened in the previous BFD3 versions.

I wonder if the developers would be able to reproduce this bug because we don’t really know what triggers it.

And does anyone have an idea where did the included presets go to and how to bring them back?

This sounds distinct from my issue. Mine was all kit pieces and articulations, all at once. A number of other users reported it at the time, but at this point it looks like we’ve all stopped complaining about it.

I attributed it to a defect in the interface between the audio engine and the host - in my case, the standalone host. Now that I’m remembering back, I think it was either totally absent or significantly more rare in AAX or VST.

It does cut all sounds, but I said the time it takes varies. It seems several other people did say they are still experiencing a similar issue.

Confirming “cymbal choking” while playing back project sections in DAW editors. Could be any kit piece articulation, cymbals are just really obvious.

Seems to happen the first time running through a section. If I stop/rew the transport, it generally plays the sample correctly the 2nd time thru. Have not needed to reboot.

Latest version of BFD, 2 different DAWs/latest releases, PC, up-to-date OS, 32GB RAM. Cannot recall ever having this problem in all the years BFD2/3 has been in use.

So… is there some possible RAM optimization/utilization/configuration setting to explore? Scrambled cutoff assignments?

2 Likes

Does it make your rendering very slow when the bug occurs? Because that’s what happens on my PC and that won’t be related to RAM optimization.

Also BFD seems to crash at times.

I tried changing buffer sizes, restarting the engine, resetting BFD, and a bunch of other things. Once it started, that was it. I couldn’t fix it. I had to kill it and restart it.

I was a able to reliably trigger it by successively loading several kits or presets. Once I’d get to around the 7th or 8th, it would start choking. Lately I can’t forcebly trigger it, and haven’t seen the issue in a while.

No, but then again, I was in “arrangment” mode, not rendering if by that you mean exporting a finished project.

Thx, was about to look into changing my I/O buffer size for Playback, probably a red herring as it’s never been an issue before.

Just loaded and played back the project. Everything ran just fine… idk.

1 Like

Hey @TLdrums,

Thanks for the report, we will investigate.

Regards, Callum

1 Like

Good. I don’t know if it has anything to do with this, but I’m playing/writing the hi-hat using the variable notes and CC4 values.

Me too, this happens in Protools, Logic and standalone on Mac. I can’t say I’ve ever seen a piece of software with more bugs in it than BFD3. Hopefully they will sort this one out, as it makes it kind of useless to me. It also happens at random intervals in a rendered file.

Same here on Mac in Logic, after some time (sometimes a few minutes) pieces are choked. Sometimes it gets back to normal, sometimes not.