[PRE REVIEW] Cymbals cutting


It’s been a long time since a have this issue. Well, since I have BFD.

I have a Windows 10 PC with Intel(R) Core™ i5-7400 CPU @ 3.00GHz 3.00 GHz and 16 gigs of RAM, but I often find my BFD cutting cymbals. Usually I just restart my DAW, but when I want to do a quick export of my project, I have lot of missing cymbals or cutting ones, it’s really annoying. I have to do a real time wave export and hear my 5 minutes long drum track again and again.

Even when lowering BFD quality I have this problem… But I find it odd to have this issue while having a decent computer.
I installed BFD on my main SSD and the library is on the HDD. Do I have to swap the drives ? Unfortunately I don’t have the space on my SSD to store the libraries… Anyone can help me on this … ? :confused:

Thanks !

1 Like

I would advise against swapping your drives. You don’t want to put your OS and apps on an HDD, as that’s painful. I’d suggest picking up an external USB-C, or 3.1/2 SSD and use that for your samples. Or just take out the HDD and put an SSD in it’s place.

Alternatively, you can try messing with the streaming settings in BFD3. I don’t think 16GB is enough to load the samples RAM.

Thank you for your quick answer.
I saw mixed views on having the libraries on an external drive. I’m curious to know what other people think about this ?
But that can be a way to solve the issue.

16 GB RAM is not enough for the full detail option ? That’s incredible, knowing that it’s the only VSTi used and I have every other program closed… BFD is sure hungry.

I think it’s enough personally, assuming it’s fast DDR4 RAM you should be fine but it’s not all about BFD3, it’s about your entire project.


1 Like

16GB should be plenty for full detail on any modern CPU and any reasonable hard drive. I ran off a 5400rpm USB2 drive for a long time. In the olden days, I spent a bunch of time tweaking buffers etc to get BFD to work. It’s been many years since I’ve had to do that.

The cymbals cutting issue in v3.4, I think, is not a performance issue. A few people experienced it after v3.4.1 came out, including myself, and on more than one platform. I found that by loading several kits in succession, I could trigger it consistently. Then, an update or two later, the problem just went away.

I think someone said that some preference was being overwritten which could have caused this. I don’t know about that. I wasn’t able to trigger or fix it through performance settings.

Now, I’m on Mac, and you’re on PC, so maybe we experienced something fundamentally different. But maybe not. Make sure you have the latest BFD, defrag your HD, make sure your virus scanner isn’t scanning it when you’re running BFD, and all that boring stuff. And if you still have an issue, open a case.

1 Like

I was referring to 16GB not being enough to load samples directly into RAM, instead of streaming. I thought when I tried loading kits into RAM, it was using over 10GB at least and then as Steve mentioned, depending on the rest of your session, it could be a problem.

I have my samples on an NVMe drive (even with a slower PCIe bus) and streaming with full detail has been fine, so I don’t even bother loading into RAM instead.

Like I said, if you didn’t want to go the external drive route and you were considering investing in a drive of some kind, you could just pop an SSD in place of the HDD you have. Even at the same SATA3 bus speeds, that should perform way better. Then you can get a cheap enclosure for the HDD and use that as a backup, etc…


I also have an issue with what sounds like cymbals cutting off/choking.

Not sure what’s causing the issue as I cannot re trigger the affect or re produce it in any way. In my case it’s random, and very annoying.

I can’t pin it down to any one cymbal could be a ride or a crash - It happens unexpectedly.


Go to Tools → Show Preferences → Engine and try a larger Stream buffer then restart the engine. Play around there. Especially if you have the RAM.

Make sure you never have “Preview RAM Only” on.

I was able to reliably trigger it by loading several kits in succession. After 6 or 7, it would always trigger. That problem went away after the 1st or 2nd v3.4 release.

In the olden days this was indicitive of an issue with buffers and HD speed. I wasn’t able to trigger or fix it in v3.4 by playing with the engine. It seems to me this issue is a of a different nature.

But who knows. Maybe yours is a different issue that just sounds the same.

1 Like


Very likely a different issue with a similar outcome.

I’m putting it down to teething issues.

I’m lucky to have a beast of a computer now. And I run everything on full that I can throw at the software.

Who knows ? next release - looking forward to it.

My problems seem lesser at the minute than everyone else’s


Hi @FromAutumn,

Thank you for the report. Your fellow users have given you a number of things to try. If, after trying some of these, you are still experiencing this issue, please let us know and I will take the report further.

Out of interest, which DAW are you using?

Kind regards,

1 Like

Im glad that i'm not the only one. Sometimes everything works good, sometimes madness of mising out cymbals or chocked. I switched to SSDs and nothing changed, 16GB or RAM here as well.


I’m all M.2 NVMe drives and 64 gig ram, Ryzen 9

I’m just glad I’m not producing anything serious at present.

I had to finish last album with Superior - but that’s life.

Hopefully it will all get sorted.


If you’re using imported midi files it’s always worth checking the keymap to see if there’s any keys assigned to choke, that could cause your cymbals to cut out.


They are not. I was actually drummer for 15 years, also producer freelancer and composer for at least 12+. I can asure you its not that sadly.

Thank you so much for all the answers !
I’m glad to see I’m not the only one having this issue.

Unfortunately it’s hard to reproduce as it is doing it randomly… An other problem is, as someone stated, when we load many kits one after the other → we need to relaunch BFD. But that’s not the same problem.

I understand what you meant, Fender_Bender. I once tried to load it all to the RAM but it really didn’t work hahaha.
funkybot may have touched something. I had 16 000 on stream buffer and RAM buffer. I put the two at max (65536) and even if the kits’ loading is slower, I had no problem on a few exports. I will try it again later, maybe it was all luck.

Thank you Clive for taking this issue into consideration.
I’m using Cubase 10 Pro and it’s when I render an .mp3 export.

1 Like

Have you checked all of Win 10’s settings for RAM priority and stuff? Or tried turning off more redundant services? Win 10 seems to be attempting to return me to my old days of Windows XP optimisations for the sheer amount of services running needlessly in the background :slight_smile: Win 11 even more so :slight_smile:

Still, I do like turning em off :slight_smile:

1 Like

Same problem. I found changing engine settings (see attached screenshot) seems to have worked for me…so far anyway :persevere:

1 Like

I’ve messed with these also but made no difference for me.

I now run everything with the greatest value, though still get it randomly.

When I’ve finished what I’m doing with Superior I’ll give it another go with BFD, but I don’t have a lot of time.

Maybe it will get sorted with the next version - hopefully.


1 Like

Did you try 16 bit mode?