Is BFD3 abandoned now?

I have an old project that used BFD3. Opened it today and like so many others, the BFD3 licencing has ruined my day. This message below appears, I rescan my library and licence everything again, but it just keeps happening.
For any new projects, I’m only using BFD2 now, but for those that already used BFD3, I have to either sit here trying to get it to work, or spend ages re-mapping to BFD2 and mixing a new kit from scratch, in the process losing all the BFD3 kit pieces in my library.
Are there any plans to fix all these bugs and make BFD3 work, or is it just abandoned now until BFD4?

I can only suggest you make sure you’re running the latest versions of both BFD3 and the LM.

If that’s already the case, have you tried logging out in the LM, closing the LM and then logging in through your browser.


1 Like

I am having this problem also.
Logged out logged n several times… Sometimes the plugin version works.But standalone does not at all.
Yes, I have latest versions of LM and BFD3

1 Like

Yes I’m up to date. Logged in, out, shook it all about, this damn thing just doesn’t work.
Appreciate all you’re doing Steve.

Standalone bluescreen/reboots here. Don’t need it so not an issue for me, but obviously it should work.

The only way to get BFD3 working 100% for me was to delete everything relating to fxpansion off of my PC, redownload everything (including expansions) and start from fresh. Maybe that was overkill but it was the only way to be sure (like nuking from orbit).

However I still have to deal with the Licence Manager crap (and it is licence, thank you US-spell-check but you can go now) every 90-days or whatever duration it feels like this month.

I havent had a problem with BFD3 during the migration from FX. After I did the updates BFD rescanned and has been working fine since then. Many BFD3 users have reported these licensing issues however. I wonder what the determining factors are for those that have the issue vs those that don’t. If we could find that out it might help with troubleshooting.

1 Like

I didn’t really have many problems after I updated. It randomly crashed some of my projects and forced me to open in safe mode and remove BFD3 to rescue the project. After that I started any new projects with BFD2. It always crashed Cubase on shutdown aswell, but for the most part, it worked ok. Until this…

The problem is the always the lack of technical details about computer config, software setups, maybe other licenses, security apps, maybe some cracked software, bad internet connection and so on and on.

In answer to the question, no. We are supporting BFD3.

In response to the screenshot, that is a dialog that would have shown up in any build of BFD3, even going back to when it was released in 2013. It is telling you (clumsily perhaps) that you have unauthorized content.

This could be content that has been added to the Contents Locations list, but isn’t appearing in the License Manager for some reason - maybe you haven’t registered the serial, or maybe it is some odd bug with user made content.

It would be useful to know which content is triggering this.

I certainly don’t have any cracked software. I’m using Cubase 10.5 Pro on Windows 10.
I have plugins from East West, NI, UAD, Waves, Spectrasonics, Line 6, Steinberg, Yamaha and even BFD2 running perfectly normally.
The problem is 100% BFD3.

Thanks Drew,
In this instance, it’s those hi hats selected in the screenshot causing it. They then disappear from the browser.
So, I shut down, re-scan everything and it confirms that BFD and all my expansion packs are licenced and authorised, now they’re back in the list. I select them again and this all happens again.

Actually there’s a little bit more to this, I only discovered ths problem because I loaded a preset that I had previously saved and the hi hats and toms displayed the yellow exclamations, so I went to find the missing kit pieces to load them into the kit. That’s when this happened, so I’m guessing I’d get the same thing with those missing toms, I just haven’t tried those yet, cos I can’t remember which ones I used.

Okay, those hats are from the BFD2 Core Library, and also the BFD London Sessions library. Please try re-downloading London Sessions and reinstalling it, and explicitly not using the old BFD2 Core Library.

Honestly, I’m not having any problems with BFD3, even after going to Monterey. Relicensing has worked smoothly for me. I can’t tell you what’s different between my setup and those that aren’t working.

1 Like

I’ve not had any issues here with this current build.

Cautiously updated to windows 11 just before christmas and BFD3 barely flinched. :smile:


1 Like

You dont use a firewire focusrite interface by any chance do you?

Yeah man, this was my experience too. Win 11 and BFD worked just fine together.

1 Like

No, but I do have a fairly obscure soundcard, Scope XITE-1. Works fine for Cubase and Studio One et al though.

1 Like

Oooh yeah, new one to me, that card. Looks like its still supported. Oh well, was just asking as my firewire interface would bluescreen Windows when changing sample rate thanks to a Focusrite ‘upgrade’ of abandoning the driver.

Perfectly good device made completely unusuable on my system, much to my dismay.

Same boat here, but on Mac. I’ve got a Focusrite Saffire FW interface. The Mix Control software is only supported up to Mojave, though I bet the interface itself will work with macOS versions higher than that. It’s been a solid interface for me for 10 years. It has built-in VRM for mixing on headphones and it works well.

I have this issue too
Basically, BFD is unusable, when we create content we want to not be stuffing around with useless licensing.
I have a major project due, BFD has suddenly decided that all my content is unlicesed, and now I have wasted valuable time trying to get it going.
I can’t seem to contact the licensing server, same issue as the original poster.
So either this is abandonware, or the staff or so skint that it is not able to be supported.


This is simply not good enough, I could go to my secondary computer, where it all works.

Can I suggest, that we all start looking to migrate away from this, I don’t think its going to be long before BFD starts causing problems for everyone.

1 Like