Cancelling scan

Is there a way to not have BFD3.4 start scanning the moment you launch it? I can’t get past the scan or manually cancel it. I have done a huge rearranging of my files to simplify things, but because BFD sees new content paths it goes straight into scan.

What I want to do is delete all the current paths and start adding them again one by one, but as BFD3.4 locks in perpetual scanning mode I cannot delete the now defunct paths, which means every time I launch BFD I get this scan, which means I cannot delete paths, which means it scans… ad infinitum.

I am stuck in a loop that is impossible to fix.

no matter how long it takes … let it finish the scan. once it finishes you can deselect or remove paths. mine did the same thing… seemed like it got stuck and had to force close the window via taskbar right click (Windows OS) or just restart my whole system and it would do the same until finally i just let it finish scanning on it’s own. left it running and went to watch tv lol scanning got very slow and seemed stuck but just let it sit… like mine it will probably finish scan on it’s own. then and only then (at least on mine) you can click anything on the program without it popping up up top say “not responding” (probably what you mean by ‘manually cancelling’ it) if you have to… start the scan before you go to bed and check it in the morning. sometimes it can get quite slow but you must let it finish one complete scan on it’s own. (prob writes a .cfg file or something somewhere) this is MadDogE134 from KVR forum… and i too had things all over the place in Windows from over the years and i too consolidated locations but as i stated there i had to reinstall ALL my expansion libs using the new ones from the License Manager. some of my old libs on my sample drive just would not work until i did. good luck and try to be patient. cheers

p.s. if you wake in the morning and it is STILL frozen you will just have to remove and reinstall the program and/or libs because something may be corrupted on your installs which is last recourse. but your problems sound just like what i went through.

This is what happened to me too.

I gave it something like 20 seconds and then closed it via the task manager 5 or 6 times before it eventually completed its scan.

You can deleted the data paths file but I don’t think it will speed up the rescanning and it definitely won’t stop scanning.

If you’re on windows and you really want to delete it then you’ll find the datapath file is at:
C:\Users\Comp(OR YOUR NAME) \AppData\Roaming\BFD Drums\BFD3.

Steve

When the scan fails, I close BFD from the standalone’s X on the top right, not the task manager. Then, I give it some seconds and run BFD again, and it has usually completed the last order given. (Usually a Remove All Paths, so that I can start anew, adding one by one folder.)

I don’t know if the above holds for the latest version, I didn’t have to do a complete scan as of now, and 4 new expansions that I installed scanned ok.

Thanks for the replies. Going to try what knothardly suggests. I have already downloaded all new versions of the libraries, which is why I needed to do this scan. I had left it a couple of times for an hour or so, which I thought was enough, which is why I thought it had frozen. When I say manually cancel I was using the “Cancel Scan” button on the GUI and I assumed that that would cancel it fairly quickly, but it just carries on with a “waiting to cancel” message.

not saying it will work letting is sit over night if need be… it may in fact be frozen but after leaving it for so long and it still sits then you KNOW it is frozen :slight_smile: i just pretty much went through the same thing you are going through and letting if finish worked for me and now i finally have a functioning product. sometimes sadly you just have to make sure things are doing things. i kept forcing a close thinking it was frozen too after like 20 mins or so of waiting when in fact it was still processing. cheers and good luck

So I left it overnight and sadly the same result. This is with a new install of BFD3.4 and all the newly downloaded expansion packs. It just has the blue processing circle (which is animated, not frozen) but then 0% processed. Guess I’m screwed.

this may be a pain in the ass… and you may have tried or done this… but i have but one suggestion. remove everything… program and libraries then install just the program and the core library then start the standalone. you may have to show the scan the location for the core library. at this point does it complete the scan and give you access to the program and the core sets? if so then install the expansions one at a time and after each start up the program and have it find the new content or add the path in the locations for each expansion. basically take baby steps and not pile up everything at once and see if you can get it working.

one other thing… if you removed everything in the past and when you installed the new program installer did you check or uncheck the migration option? if you have the migration option enabled it may be hanging while looking for things that aren’t there hence why it sits and spins. if it were truly ‘frozen’ the blue spinner would not be rotating. (movement)

i will try to help as long as i have ideas … one other thing which i doubt is the case but win10 is funny about permissions so maybe try running the standalone first scan after a fresh install with admin rights. right click the program launcher and select “run as administrator”

as i recall i had some trouble because i installed all my expansions on my sample lib drive under one main folder name. but how i got it to work was selecting each sub directory (folders under the main BFD Lib folder) and adding each path and not selecting the main BFD Lib Folder i placed all my expansions under so the scan didn’t overload.

for example i installed the core library under my sample lib drive in a folder named “BFD” and when the core library installed it created a folder named “BFD3 Core Library” i ran the scan and all worked with it by itself. i closed things down and created a new folder under “BFD” called “BFD Expansions” and that is the folder i installed all subsequent expansion to the product one by one and after each one i installed under the ‘expansions’ folder i created i ran the standalone program and it found new content but that was with the actual BFD expansions i bought FROM Fxpansion… my 3rd party expansions i placed in the ‘expansions’ folder but i added each subsequent folder’s path to the location area in the scanner.

hope this is not confusing you… just trying to help

cheers

Thanks for the continued suggestions. My first port of call is to try the standalone. I never use it but you never know. I definitely untick ‘migration’ in any installs I do. I have deleted any fxpansion and BFD1 content. It really shouldn’t be this difficult.

Woah! Standalone just restarted my computer, not good. OK so that’s not going to work either. I give up I think at this stage and wait for next version. Glad I didn’t purchase Modern Retro now, wouldn’t be able to use it anyway.

you are most welcome…

even in the past support has always said at least to me to do the initial scan via the standalone program and not the plugin itself. so maybe a fresh install since it crashed after attempting failed scan with the plugin and try the first product scan in standalone? but seriously i understand your frustrations… we have been down the same road it seems from my readings of your comments both here and on KVR. maybe give it a day or so to lower stress level lol (that’s what i do) then i try again. cheers and good luck

Right from the early days of BFD1 it was always strongly recommended that you get everything up and running in stand alone before anything else.

Setting things up from within a host sequencer introduces another level of unknown variables.

Steve

Was it a blue screen or did it just spontaneously restart?

What’s your audio IO/Soundcard and does it come with asio drivers.
Blue screens are often the result of drivers.

Have you set BFD3’s audio outputs device and what to?

Did BFD3 create a crash log?

If it was a blue screen you might find this a useful utilty but not always.

https://www.resplendence.com/whocrashed

Steve

right steve if he has never used the standalone initially then audio I/O setup is a must and could be the culprit on the restart/crash. by default it is set to windows default sound driver. i didn’t even think of that. thnx for chiming in :slight_smile: cheers

1 Like

Can’t even launch it to change the driver, just blue screen then restart. No crash log. This is the problem with the plug-in too. Basically I can’t get rid of the stuff that may be crashing it or select any drivers because I need it to launch so I can delete/change the stuff that’s crashing it. Classic Catch 22.

even after complete removal of all product and fresh install starting from scratch? again i know this may be a pain… but it is the best chance of success imo

OK, interesting development. I opened Cubase and loaded the plug-in, this time it scanned fairly quickly (a couple of minutes or so) and all my content (apart from a bonus Rock Tambourine - probably BFD2) loaded. I have no idea why this now works.

I do still have my funny problem with the left hand finder with extra preset ‘copies’ with no associated graphic showing in the left-hand finder. I have narrowed it down to London, Sphere, Jazz Noir and Horsepower. The other presets seem OK (haven’t looked at them all yet though). These are all new downloads of the expansions, so not sure what’s causing that, but at least I can get some sound now.

1 Like

double check all known locations and see if you have presets in multiple places. but i am glad you are getting somewhere :slight_smile:

p.s. the main reason i keep talking about complete removal and fresh install is to avoid anything left from previous installs, corrupted or inaccurate files as in configuration files and such.

Ah yes, back to “Hunt the plethora of BFD install paths”. My favourite game.

1 Like

yeah when i was looking for my Taiko stuff i did find some doubles from old expansion installers (not my Taikos) that i recently installed. many are having luck with the migration process by the installer but i have not… i had to do everything manually

cheers

p.s. be sure to check your 32bit folders too (x86) … yes the old installers are only revamped and not completely rebuilt installers. i don’t know which (may be 3rd party) but after my fresh installs… i had a C:\Program Files (x86)\Fxpansion folder created with stuff slapped in there

1 Like