BFD3.4 issues with migration and install

I’m having many issues upon migrating FXpansion to Inmusic or BFDdrums. Below is a line item description of my issues.

1.) First off , the “confirm button”. Will I have to click this confirm button on “copying settings and presets from FXpansion to BFD” EACH TIME that I want to use BFD3.4 ?
It seems each time I try to bring up BFD3.4 I get this “confirm button”. So, I press O.K and then…

2.) I get an alert. I get it EVERY TIME. The alert says, " There was a problem copying you BFD factory system settings file".

So, after I click O.K for this alert,
3.)BFD stops responding. It freezes, while it seems licence manager is comes up. AGAIN, this happens every time.

4.)The BFD license manager comes up, “checking the status of files already loaded”. Is this supposed to happen every single time I use this software now?

5.) The BFD content location dialog box comes up. Is this the norm also? I see all the paths on my computer where data lies. It’s all over the place. I’ve had BFD 1 BFD 2 and BFD 3. I have no idea how/why this is the case. I have always let things download and install to the default. That said, even with all these paths indicated in my BFD3.4 software, I’m still unable to get certain drum kits. BFD1, and BFD2 and one of my expansion packs. (Deluxe)

6.) The BFD license manager, in the downloads tab shows files found while checking the status of files already loaded. After that runs, it then asks me to please run the “INSTALLER” by clicking the “play” button. Why is this done every single time? Seems odd.

7.) It THEN tells me the folder doesn’t exist. BFD3.4 found this path to begin with, not me. How could it not exist? I assume it found it because it DOES exist. Well, so then I click the button to allow it to create the folder. But, strangely, why does it ask me to do this again, the next time I open this software? It’s like I’m in a loop. Meantime the expansion pack seems to install but taking quite a while. And again I have to ask, will this happen each time I want to use BFD3.4?

These above processes repeat every time I open the software. It takes apox. 40 minutes or more. That can’t be acceptable. This is all very frustrating as up until now, this product has worked smooth as silk for years. I just brought up the interface and started using the software. Now, I have all these other processes goin on before I can do a thing. This seems counterproductive. (to say the least). Will this all be addressed in the near future?

Thank You

Brad Hofrichter

Hi Brad,
in my case it helped to run license manager and standalone as administrator.

I had pretty much the same thing happen to me, I got the migration notice followed by, 'There was a problem copying you BFD factory system settings file" message.

I did this about 3 times and then opened BFD3.4 in my sequencer (Cakewalk bandlab) and it seemed to work as I got a notice saying, ‘Migration Complete’

I have no idea why opening BFD3.4 in my sequencer worked and it may well have just been coincidental but it’s worth trying maybe.


I had very similar problem with the migration and install. It was a nightmare. I ended up having to manually go through my drive and delete EVERYTHING related to BFD and FXpansion and do a clean installation but still weirdness persists.In my BFD browser I have duplicates of all presets, kits and drums (not grooves) yet the content only exists in one place/folder on my drive. I also had the problem when first attempting to migrate/install where the process found paths to content that “didn’t exist”. I think there is clearly deeper file management/access bug at work here. I too have been using BFD upgraded through several versions. I think a clue to this possible bug might be that in previous versions various things were located in an FXspansion subfolder whereas this latest version has dropped the use of this folder.

1 Like

That smells like a bug to me. Shouldn’t have to do that if it was designed properly. And if it’s not a bug then there was certainly no warning or instruction to do so.

1 Like

Yeah I too had the same duplications. I’m still having problems. I don’t understand I have this program for years, since BFD1 BFD2 BFD3, and it’s always worked just fine, I migrated and now my program is useless. It just freezes now. I wish there was some real support from the company. I need help to ge
t this program running. It’s very frustrating.

Yeah, No, this didn’t work at all. My standalone BFD3.4 freezes no matter whether I open as administrator or not It’s completely useless.


A couple of things to try as I had this issue as well.

  1. From a clean reboot - try hitting the “Cancel” button instead of “Confirm” to “copy settings” - Does BFD 3.4 open OK?

  2. AFAIK - the freeze comes from BFD doing a content scan in the background. If you leave it alone it will settle down. If you click around trying to make it work, you will push the app into “not responding” land. Agree that this doesn’t solve anything just be aware that the background scan is happening.

In my case after jacking around with this for days. I finally did a reboot (just to get rid of any BFD BS running the background and started standalone “as administrator”, got the popup and it succeeded. Box seems to go away after it’s happy.

Agree with others here - this is poorly written. Will be interesting to see what happens at In Music. I feel like we’re at a bit of an end game with it and I suspect Geist will die on the vine.



This post appeared above somehow. I activated something by accident I guess, having trouble typing.

In fact, there is a BFD4 in the works, the 3.4.11 for Mac OS is working perfectly with no keychain or wifi needing to be on, and Geist is FXpansion, not BFD Drums. :shrug;

1 Like

This is primary: if the items have been copied (check for it manually), you want to delete the original FXpansion items. If there is nothing more to copy you’ve broken the loop there. In your position I would manually copy and paste and then delete the originals.

i think we’ve isolated a problem that can be addressed. i recommend rethinking your installation and making it very simple; establish ONE “BFD Drums” higher level directory under which all your BFD libraries, Expansions etc content as well as User content directories (Grooves, Kits et al) ie., 'BFD2", “BFD3” reside.

I didn’t know there was a default, or I don’t know what that means, as I have to select a directory to install into. See if your experience resembles this (windows IDK, could be it doesn’t): The installer asks me to choose a directory under (then FXpansion now) ‘BFD Drums’ and a simple ‘OK’ to that has it saying that directory doesn’t yet exist, do I want to create it, Yes to that, and now eg., ‘BFD Core Library’ is established inside ‘BFD Drums’.

But ‘Data all over the place’ looks to me like the root of your difficulties.

Thanks for your suggestions. #1- Yeah, I’ve gotten past that dialog (I think) I hit cancel. but it’s the scan that never ends. I’ll try again and leave it. but, it’s totally useless now. It just hangs. I was thinking of deleting everything. starting over with an FXpansion download of 3.1 and start from there. But, It seems it’s a bigger mess each time I try something. I’m told the developers are the same guys as the guys from FXpansion, so there’s no explanation other than a badly written piece of software. At some point I might have to just get rid of it, take my losses, and move on to Addictive Drums. They aren’t nearly as good sounding but it works. It’s silly. It’s been a month.

That might be the case. I do NOT know how that happened but I have had BFD since ver 1.5 so through the course of all these years it’s possible that all those directories were created as I installed each new version. I try to keep it simple but I can’t tell you what I did 10 years ago or 6 years ago. If I thought I could clean this up properly I’d give it a try but It’s a mess that’s way too big for me to figure out anymore. I tried to keep the program on my system drive and everything else on an external drive but 10 years ago I might not have realized or understood to do that. I can’t say. Within the next few months I’m looking to get a new computer and maybe a fresh BFD install at that time with the newest version ONLY, might be the answer.

Well, it looks like the kind of mess that has to be pretty much wiped and started over, for sure.

the Mac version cannot be a particularly poorly written bit of kit, it works perfectly and the two issues were entirely fixed. I wonder if there’s a skeleton crew remaining with Mac-centric coders, the windows version is not developing as fast and problems appear which seem unique to.


I agree with you re: “data all over the place” FXp changed their installer process over the course of time with BFD versions. My installation probably looks much like yours. There are multiple paths. You probably have the following.

C:\Program Files\Fxpansion
C:\Program Files (x86)\Fxpansion

Plus whatever your library location is (if different than default)

Some things to try and/or be aware of.

  1. The new 3.4 version resides in paths named "…\BFD Drums. All the old FXp stuff is under the original path “…\Fxpansion…”. Keep this in mind if your rooting around in directories.

  2. If you open the License manager - Be sure to only use the new one as you will have two of them now. I made this mistake a couple of time and this looked to be the reason for the multiple download issue. Both license managers have their own download status/pending cache info stored in …\appdata\ and I think they get crossed up if you open both managers at different moments. - just a guess.

  3. Set your new BFD 3.4 shortcut to always start in admin mode. It’s a checkbox located under properties, under the “compatibility” tab if you haven’t already.

  4. If 3.4 simply does not open up for you at all. Try renaming your library path if you can, which will force BFD into asking you to set up content paths for the first time. You can then try starting over.

If you want to pursue this and are comfortable with a Teamviewer session, I’m happy to assist.

Again, poorly written error exit process. Just because it works on a Mac isn’t a free pass.




Thanks so much for the information. This all makes sense. The problem with trying to re-name folders and locations is that I no longer get an option to choose anything, locations or otherwise. It all freezes up and hangs. If you could do a Team viewer session that would be fantastic. Let me know when we cna do this. I’m, here in Arizona so I don’t know the time zone you’re in but I’m sure we can work that out. here is a screen shot of the locations. I can’t scroll any further down so be aware there are even MORE locations but they’re not showing in the screen shot. Some are even in “My Documents”. I have no idea how that happened.

I forgot to post the screen shot hold on I’ll get that posted.

Unable to load the file. Well I’ll find a way.


No worries on the screenshots. We can have a look on teamviewer.

I’m on the east coast but lived in Phoenix a short while - too hot!

I’ll shoot you an email shortly and we’ll schedule some time for this afternoon or whenever.