BFD3.4.4.31 Release Notes

Yes you should. There were a few bugs in build that the latest fixes.Most notably, routing settings not being recalled.

Do you know how I can download the latest version o BFD3? My license manager presents no way to download anything. The downloads tab has nothing in it so I can’t download the latest version.

The downloads page shows what’s currently downloading.

Try the products page. Select BFD3 from your products, and then in the lower part of the page you should have a Download button to the right.

1 Like

Hi, please help

Since upgrading to version the .dll doesn’t work. The standalone won’t even load, just saying it’s there but it can’t load?? Also, in Cubase I got one message saying “we can no longer use 32 bit VST” or something similar.

I’m certainly no developer and a lot of the stuff that goes back and forth on here is right over my head, but I’m no dunce and can understand a system. But to have a 64-bit piece of software not install a 64-bit .dll seems illogical captain.

It used to be the case that you could load some software and it would work. Especially after you’ve paid a shed load of money to get the ‘good’ stuff. So frustrating.


I’m also unable to authorise after moving from from an Intel machine to an M1 (Montery):

If Safari is used by the BFDLM to log into the InMusic account, the web page hangs; I set my default browser to Chrome, it logs in successfully.

BFDLM then reports authorising BFD successfully; but upon launching the stand-alone BFD application, the programme is disabled with the message: “No license file was found.” If I re-launch BFDLM, the BFD software is shown as authorised in the “Installed Products” tab; but in the “Registered Products” tab, the authorisation status is red: “Not authorized (no license file found)”. Each time I launch the BFDLM, it prompts me to “authorize” (sic) BFD3, which I indulge, after which the all-clear is given and then…same thing. Infinite loop.

I’ve spent the day trying everything from each thread, including deleting every BFD-related file from all my mass storage. At one point, I was able to get the stand-alone to launch; but after I added content, it went back to “no license file was found.”

Drew, you’re a hero for personally participating in this thread. I understand that this situation is out of your control, and sincerely appreciate your efforts here. I look forward to getting back with BFD as soon as this business of ferrets is resolved. (Fender Bender, that avatar looks familiar.)

1 Like

I am in the exact same boat as you on the eternal reauthorise loop with no luck. It “authorises” in LM then as soon as I open BFD3 it has the “no authorisation found” message you have. What is weird is that the first time I opened BFD3 in stand alone it worked? I closed it and opened reaper and it haven’t worked again. Same just got an M1 and running Monterrey

I have the same “no license found problem”. Had to do a windows reinstall and the BFD3 re-install won’t authorize. I went back to an old version, hopefully there will be a fix eventually.

I am the same. I did a complete wondows re-install in an attempt to fix a BFD issue that I wasn’t getting any answer about. Now I can’t even authorise.

Can I ask, has anyone had any response back from recently? I’ve been trying to get a response since early last week and I’m getting nothing, not even a confirmation that they have had my email.


Update on this. Got a message back from helpdesk, all sorted now.

1 Like

What did they say?

Still stuck with Auth loop on 2021 Macbook Pro (M1 Pro)
Older 2015 Macbook Pro is fine with Auth

They reset my authorisation on my account, all seems good now (touch wood).

They reset my authorizations today (maxed out but didn’t get the error message for that)

Followed the support steps again to reauthorize and reinstall and still have the broken authorization loop

Thanks for pointing me to support, at least I’m working with them now on this

Your getting this with windows? I thought it was a M1 Mac issue. It’s atrocious this BS

What did they do to fix it?

Like i said in my previous post, they went into my account and reset my authorisations. Admittedly this was after me completely re-installing windows and then BFD straight after, then having to get onto the support line because it was still coming up as ‘maximum authorisations breached’.

1 Like

BFD3 updates has been a catastrophe since Inmusic took over. I lost all my favorites presets and grooves in the update. Hours and hours of work. And support just said bad luck ! Before BFD3 was such a fantastick plugin.

So far so good for me, no issues here

Im on an M1, aside from it not working native, hopefully I will get the M1 beta invite soon for VST3

BFD2/BFD 3 3.3.1 LM
OSX 10.14.6
Logic 10.4.6
INMusic account up and running

I feel I should update as I currently can’t try/view any demo packs and crashes occur when dragging grooves to logic but I have to say as a fairly experienced tech/music maker I’m a little nervous.Started on BFD 1 still use BFD2 , now using BFD3 more and more Some GUI layout stuff irks a bit but I love the sound detail and comprehensive control / flexibility of BFD3 . A powerful drum tool indeed.

  1. Have projects using demo kits/bfd2 presets etc. should I update, Is it safe ?

2)Are BFD1/BFD2/BFD3 authorisations (withINMusic) based on the number of computers (2) or the number of operating systems installs.e.g Mojave/High Sierra on one machine and El Capitan/High Sierra on another? If it is the later are 4 installs of BFD1/2/3/ permitted?

  1. I’m backed up ( Time Machine and CC) If it goes Pete Tong does INMusic system prevent me form using Tim Machine to dial back to v 3.3.1

Currently running:

BFD 2 on El Capitan on old MacBook
BFD2 and BFD3 (3.3.1) on Mojave /Mac Pro.

It all works except I can’t audition any more packs ( though I have horsepower/Retro/Oblivion demo packs appearing/working)

I have the latest LM dowloaded (30622)ready to run but I’m not convinced all will go well based on forum posts.As my LM no longer works would I be better off just sticking with what working ? Based on the above info any advice would be much appreciated.

Thank you

Machine/Library/Application support/ FXpansion…system Presets /grooves etc.
User/Library/Application support / FXpansion…User Prefs/Demo Cache
User/Documents/FXpansion/BFD user Presets/Grooves etc.
Audio 0 BFD Samples /
BFD3 Core Library (audio/grooves)and
BFD2 (audio/grooves)
BFD1 (data etc)

FXpansion servers no longer have the demo packs feature. If the pop-up annoys you, someone explained how they got rid of it on macOS.

You can actually have both the FXpansion and inMusic LM and BFD3 running on the same machine. For the time being, I would just keep your FX version running. However, in the meantime, you can start to migrate over to inMusic and get things ready because in your case, you will have a few steps to do.

Just so you’re aware, inMusic’s DRM is different than FXpansion’s.You still get 3 machine authorizations, but inMusic’s LM will do license checks over the internet every 90 days, or in some cases less. You can work offline in between that period. It’s been a bit bumpy, but it mostly works. The last few times my products got de-authorized, I was able to authorize them again without a problem. You’re on older Intel Mac’s, so you shouldn’t have any compatibility issues. I’m running the latest BFD3 on Mojave and it’s fine.

So, if you decide to go that route and update your BFD version this is what you need to do. On your FXpansion account page, you should see a link to migrate your account over to inMusic. You will need to create an account with inMusic. This is very important… Make sure your email address is the same for both FXpansion and inMusic. That’s the only way the migration will work. Once that’s all done, you can download the new LM here:

This LM is completely separate from FXpansion’s. Once you sign into the new LM, should should then see your eligible products to authorize and download. The only thing you will need to download first is BFD3. Don’t worry about the Core Library or your expansions. Open the new BFD3 in standalone and add your content locations.

You can’t use the BFD1 or 2 serials, or content. They are unsupported products through inMusic and don’t get migrated. However, you can get replacement serials for both libraries (Eldorado & London Sessions). Once you get those new serials, you will enter them in the inMusic LM, authorize and download the new content. They are the same sounds, but just packaged differently by name, so you can’t use the OG BFD1&2 content with this BFD3. If you have other expansions that don’t get migrated, I think you can get replacements for those as well. Here’s the thread about it: