BFD3.4.3.7 Released

I agree that dealing with upgrades and BFD3 can be tricky but I did the update very easily and quickly on my system running Big Sur.

Now my products got de-authorized and they won’t authorize again, sort of. I logged out of LM, closed it, opened again and logged in to inMusic via browser. LM says it authorized successfully, but still shows, not authorized in red? Tried many times logging in and out to no avail. No issues when I updated to the latest build yesterday. Might roll back for now, as I’m in the middle of a project. This seriously needs to get sorted. This can’t happen when you have paying clients and you’re using BFD on the project. Just switch to iLok and be done with it. iLok has been solid for me for over a decade.

Edit: Rolled back to last working version of LM and BFD3 and same thing. The LM will not authorize my content.

Edit2: Finally, it just all of a sudden worked. Didn’t do anything at all, just tried logging in like before. Back on the latest build and LM. Maybe a server issue with inMusic? The Sun did unleash an X-class solar flare today, but we shouldn’t have internet/power disruptions until this Sunday/Halloween when the CME arrives.

This is not a Monterey issue for me, as I’m on an older OS.

2 Likes

Grateful for the update. Will make use of it shortly.

Not sure why there is an issue here — or a need for reauthorization after any extended period. However, I’ve noticed this elsewhere, too, with non-music software.

I have software on another older computer that has only ever needed to be authorized ONCE (not counting updates). I turn it on, no messages, no warnings. Just works as it should.

As Tolkien said, “One authorization to rule them all.” Anything more than that is wasteful and potentially disruptive to the workflow of those who go offline for extended periods with their production machines. Just my opinion.

5 Likes

@rolandk - an opinion shared by just about everybody here :slight_smile:

2 Likes

Never forget that you dont know what you dont know :slight_smile: For example, we have no idea if the authorisation system is under BFD’s complete control, they have a parent company and I’ll be surprised if some products in the parent companies portfolio dont share authorisation systems. I would imagine if this was something BFD themselves wanted, it would have happened way before now.

I mean, its not like we havent all had issues with the current system, but it was all a bit of a sudden move to a new owner, and there has obviously been fall out. BFD are back to releasing regular updates and trying to fix everything, including long standing bugs and things that can stop us working. I dont wanna have to go to an inferior competitor! :slight_smile:

I hope you feel better from your not chill injuries soon! If an updated BFD is still broken for you, getting it fixed could help the next poor soul that runs into the same issue! :slight_smile: Its less about me being calming and more about wanting this thing working properly for all of us so it sticks around! :smiley:

I havent tried Horsepower I dont think, I’ll consider giving it a go next time there is a sale.

Thanks for the YT channel love! T-APE is amazing! MMXX T-APE, Bytebeat Sequencer and Fractal Exprorer - PhonicBloom

Companies buying each other, and products getting sold off to different companies, is ALWAYS BAD FOR CUSTOMERS. I hate that anyone thinks this is normal and should be responded to with perpetual patience. When I came into this BFD3 situation, I was open minded. They implanted a bag of burning feces into that opening.

I’m sick of being treated like a helpless end user by companies and the parent corporations that dictate their arbitrary and thoughtless schemes. Fact is, we ARE helpless. In the USA, there’s ZERO customer protection law for computer industry BS.

ENOUGH!

[EDIT: My good will and benefit of the doubt was burned away and I am utterly disgusted at this point]

2 Likes

So BFD License Manager doesn’t show me any updates. I manually checked for updates. Nothing.

WHAT THE ACTUAL F, BFD? I am so goddamned SICK OF THIS BS!

[EDIT 1: Yes, I logged out and logged in again]

[EDIT 2: I just now noticed the “download here if on an older license manager than x.x” note in the first posting. Exactly how long is it going to take before the goddamned license manager does the things it’s supposed to do, and why am I on an older version when I got the last updates you guys put up??]

[EDIT 3: Yeah. No change. Turns out the license manager doesn’t actually DO ANYTHING to show you updates are available unless you SELECT A PRODUCT. Someone at BFD needs to learn how to design software that serves users. Oh, right, I keep forgetting: License Manager ONLY EXISTS to SERVE INMUSIC BRANDS, NOT USERS!!]

[EDIT 4: Nice to know the basics don’t even work. It downloaded 77.9MB of 74.3 MB]

[EDIT 5: It’s nice that the installer FINALLY tells the user to QUIT the License Manager]

[EDIT 6: It deleted the downloads on me. What if I wanted to archive them somewhere? Luckily they’re in the Trash and I can get them back, but that’s yet another decision made for the user when not asked for it, promoting this “always online with super-high bandwidth internet” ideology.]

[EDIT 7: The content manager will not let me point the “License!” button dialog to the BFD License Manager in the folder where I placed it. WHERE I WANT IT because I don’t want EVERYTHING dumped into the Applications root folder. It’s right there, in my Applications: Audio: Utilities folder, but the Open button is disabled. All I can do is click on Cancel. Does this even matter? The License Manager says all my products are activated. Why is this button even here drawing attention to itself? It only appears on El Dorado and XFL, not not London or Jazz Noir.]

[EDIT 8: OH LOOK, the BFD2 Presets ARE STILL LOADED WRONGLY! Room mic is still being changed to OH! WHAT A GODDAMNED SURPRISE THIS BUG HAS STILL NOT BEEN FIXED!!]

[EDIT 9: And the same SHIT happens to the OH mic setting on a save/reload of the project. I literally have to correct this goddamned bug’s bullshit MULTIPLE TIMES before the settings will stick. FIX THIS SHIT!!!]

I feel your frustration. I decided that I didn’t need a heart attack at my age and stopped bothering to use BFD. I may try again in a few updates’ time. If it doesn’t work first time I’ll probably retire it again.

2 Likes

I’m up and running with it (latest build) Touch wood.

That being said, I’ve now finished off the last two albums with Superior Drummer. Not that I prefer it. But I couldn’t trust using BFD because of all the faults (bugs) everyone on here has frustratingly faced.

I’m now on another album and having to program BFD and Superior (as I’m not good with drum maps and the like). We shall see how it goes.

I’m now faced with the horrific task (shortly) of going to Windows 11. 10 was was enough.

I hope bfd works on Windows 11 by the time I get round to it.

As I’ve said before on here, I find it very sad so many folks are having a bad (to under state it) time with it.

I’m not showing any problems at present - but that doesn’t mean there are none.

I don’t want to see bfd go the way of the Dodo - It’s a brilliant product, that’s been dropped into the deep end of the other side of the music business. Previous bad management decisions - lets hope that’s all behind.

I’m sticking with it, but I know most folk are at breaking point and are seriously considering cutting their losses.

Sad situation that we’re all in.

Neil

2 Likes

“I’m now on another album and having to program BFD and Superior (as I’m not good with drum maps and the like). We shall see how it goes.”

I program in BFD using a Steven Slate Drums 5 keymap, as it was what I was using previously and prefer it over the BFD3 keymap. It’s pretty easy to import keymaps. You may have to edit them slightly to match up, but once you do that and save it, you’re ready to go.

I’d suggest using the Superior keymap to program in BFD3, if you’re more familiar with it and if you need to switch back, you just copy the MIDI over to Superior and it will line up. Only thing is you probably will have to tweak velocities sometimes, with a different sampler and drums.

I used SSD5 alongside BFD3 on a recent track and using the one keymap it worked out fine.

1 Like

BFD’s not my problem with drum maps - as Cubase takes care of that for me and it’s 100% transparent.

I have to use Superior in the piano roll. Some of the Superior 3 packs are very similar, but the ez drummer packs all seem to be different.

I’m a very slow programmer, which can sometimes be very frustrating in it’s self.

One day I’ll sit down and make all the drum maps I need, but time is against me, and I’m not 100% computer literate - I make it up as I go along.

It’s a struggle for us all at present.

So good luck to everyone.

Neil

EDIT

Further to install latest.

I’ve now had two authorisation requests from licence manager.

Twice in three days.

Luckily they were straight forward and authorised instantly when asked to do so.

I’m not sure how this will play out when off line due to internet interruptions - of which lately there have been many.

Neil.

2 Likes

Getting fed up with BFD3 here too. Sadly it is an expensive software, specially if you’ve been using for many years, bought expansions, etc. Come on guys! We just want to click ‘install’ and have a software that works properly! Tired of fixing all these countless bugs and still not managing to work with it. We will have to buy a different drum software here (and learn to use it very quickly!), as we cannot risk losing time and money anymore having a plugin getting stuck in the middle of a recording project. We run a commercial recording studio, and we are putting BFD3 aside for now. Please give this new version a priority! We will be waiting. :v:

4 Likes

I’m stuck with the Update because i get a message “The application BFD Licence Manager .exe needs to be updatet”
I have the last Version 3.0.5.2 from your webside and it’s running.
Any ideas why i can’t update to 3.4.3.7 ??

I have Mac OS Mojave. Licence manager 3.0.05 and no2 3.0.52 hang when I click on downloads. It gets to about 233G (Whatever that means) and slows to a crawl. 20 minutes later it 226G. Since the move to Inmusic, no BFD applicatio past 3.3.1 works on my computer. So new kits I purchased show up as unlicensed even though the newer version of LM (3.0.0.5) says they are licensed. (I realise that’s because the older BFD wisn’t recognised by the new LM). BFD also rescans all my folders every time I open it.
I have bought BFD since version 1.0, but this new change of comapnies has created a mess. I appreciate that those responsible are trying to work it all out, but I would just like to use the program without all these hassles.
Any suggestions on how to resolve my problems would be appreciated.
Thanks and regards.
Peter North

So sorry that I updated to the latest version. Kept getting the server not responding error until I finally logged out then back in. Now several of my expansions are not authorized in BFD3 even though they are showing authorized in the License Manager!!! WTF…

I noticed that I reauthorized on 10/31, which was less than 30 days after my last reauthorization, and 5 days after I updated to v3.4.3.7. I thought we went to a 90 day schedule?

What’s the deal?

@BFD_Drew @BFD_SKoT

2 Likes

We think it’s a daylight savings issue on the auth server - not the software itself. We’re looking into it. I’ll post more once we know for sure.

Anyone who had their auths expire, please logout and login to License Manager again, and re-authorize.

Monterey users: You have a slightly different issue in that BFD3 and LM aren’t recognising the auths. We’re working on a hotfix for this. I’ll post ASAP when it is ready.

1 Like

5 minutes ago, I tried to update my BFD3 software to the latest version. Result: server error; not connecting.

Tried to start my old version of BFD3, which I have definitely used in the the last 30 days, but now it needs to contact server because it has been deactivated.

This should not be happening. I think keeping customers happy should be a higher priority than trying to soothe the company’s feeling of insecurity about piracy, or tracking user activity.

UPDATE: I logged out, then logged in again. Problem fixed. I remembered this advice from the last time it happened. Hmm. My authorizations aren’t reliable, apparently.

1 Like

CYMBAL CHOKE ISSUE: Playing V-Drum cymbals. Everything working fine with Slate Drums. Not an equipment issue. Also, when I click on the cymbals in the GUI, they sound normal - no choke. As soon as I play them through the V-Drums, they choke.

I’m on a PC using Windows 10 latest update. DAW is Studio One Pro. Buffer is 64. Rate is 44k. Engine settings are standard/default. 2GB file size setting. Ordinary.

BFD3 was updated yesterday. (And now this. Ugh.)

Obviously BFD3 is interpreting a regular hit as a choke message.

Now what?

Please check if you have ‘choke with aftertouch’ turned on in the preferences. If you do, turn it off. Any difference?

Can you send me some midi from your drum brain so I can check it here?