BFD Crash (Logic Pro X)

BFD3 crashes on startup.
From Standalone:

From App:

The only plugin/instrument loaded in the session is BFD.
Help - please.
Apple M1, Ventura 13.4, Logic Pro 10.7.8

Hey @songkid

Could you send me a crash log and runtime log for these issues please? These can be found at:
Mac: /Users//Library/Logs/BFD Drums/BFD3/BFD3 Runtime.<date+time>.log
Mac: /Users/Library/Logs/DiagnosticReports/
If you cant see the library folders you may need to press shift+command+period to show hidden folders

Do you have an external audio device connected? If so could you tell me what it is?

Standalone Crash
Could you try launching BFD3 standalone with no audio devices connected to it and tell me if it still crashes?
If there is no crash, try the following and let me know what happens;

  1. With BFD3 still open, plug in your external audio device
  2. Open BFD3s audio prefferences by clicking BFD3 in the menu bar at the top of the screen and go to Settings>Audio prefferences
  3. Press the refresh button in the audio prefs

I think your audio settings will update to your external audio device at that point

Logic crash
Try the following and let me know if this stops the crash

  1. Launch Logic and create a new project
  2. In the menu bar at the top of the screen, click on Logic Pro> Settings> MIDI…
  3. Untick the MIDI 2.0 box
  4. Add BFD3 as an instrument to that project


Thank you @Joeface53!
(logs sent via PM)

The interface I use is the the Presonus Studio 192.

Standalone Crash Results:
Did not crash after following steps 1-3 above.

Logic Crash Results:
New project does not crash after steps 1-4 above. However, after save and reopen of newly created project, immediate crash again.
Screenshot 2023-06-20 at 11.56.55 AM

Although I, too, am experiencing BFD Stand-Alone crashing on startup, BFD is working perfectly as an AU Plugin in Digital Performer 11.22 . My use is always as a Plugin, so I’m pretty darn happy to have BFD up and running again on my year-old Mac.

System is M1 Mac Studio Ultra, Ventura 13.4, MOTU 828ES interface connected via Thunderbolt.

1 Like

That’s awesome. Does not work for me as a plugin either - unfortunately. Pretty darn bummed, bc I love the sounds. I hope to get this resolved so I can then move onto my next issue: migrating my BFD2 license to (hopefully?) use those sounds as well.

I have those “An Audio Unit plug-in reported a problem …”-warnings happening as well, though it varies from session to session. Sometimes hours go by without seeing them, and then, suddenly, up they pop. Using Logic 10.7.7 (*) under Monterey on an M1 Mac Studio Ultra. Fairly sure it’s not a BFD issue though, cause the web is awash with reports from people experiencing the same thing with plug-ins from other developers as well, and I’ve had it happening too in sessions where I don’t use BFD.
9 times out of 10 however, I click ‘Recover’ and, after Logic reloads all the plugins, I can continue working.

(*) I worked with 10.7.8 for a week or two, but then rolled back to 10.7.7 again because 7.8 never felt like a solid version of Logic.


Hey @songkid

This is a really frustrating one. The combination of an arm64 mac with macOS 13.4.1, and Logic 10.7.8 installed is what causes this crash. A large number of third party AUs currently crash in Logic as a result of this. We’re hoping for a logic update that resolves this, but we’re working on a fix in house in the mean time.



The BFD plugin still crashes in Logic Pro X although BFD standalone works for me. I tried the above recommended fix - the MIDI 2.0 box was already unchecked. I am using a MacBook M1 Max running Ventura 13.4.1. Any advice would be appreciated - I love the BFD sounds and wish I could use them.

1 Like

LogicPro is in a pretty bad place at the moment, I find. Well, everything to do with AUHosting seems to be anyway. Next to the annoying “An Audio Unit plug-in reported a problem …”-warning, I have, occasionaly, plug-ins opening up with a black GUI, or they open up in Controls-view instead of their normal view, or sometimes you load a plug-in but its slot remains greyed-out meaning that you can’t open it. I have also encountered situations where a chain of plugins loaded in one track persistently upsets Logic, but if I then copy and paste that same channel strip configuration to another track, all problems disappear.
It’s all very random, totally unpredictable, there seems to be no rhyme or reason to it whatsoever. Days can go by without a single issue, and then, for some reason or other, it starts happening again. It’s this apparent randomness that makes it so frustrating, cause that makes it also impossible to troubleshoot.

Amidst all this AUHosting turmoil, BFD3 performs surprisingly well most of the time here on my machine, I’m happy to report, although it is definitely among the plug-ins that seem to bring up the “An Audio Unit plug-in reported a problem …”-warning more frequently than others do. (The plugins from DMG Audio also belong to the category of plug-ins of which I’m meanwhile quite certain that LogicPro views them with suspicion and doesn’t tolerate everything they do.)


Hey @songkid

Logic has a new 10.7.9 update. We’re still testing it out here but it appears to fix the MIDI 2.0 crash. Logic Pro for Mac release notes – Apple Support (UK).


1 Like

Thanks. I upgraded to the latest version of Logic (10.7.9) and Ventura (13.5). The crash problem remains.

Hey @jacubert

We’re going to need some more information.

Could you tell me what build of BFD3 you have installed? Could you attach a screenshot of the error you get in Logic? Could you attach a runtime log and crash report?

Runtime logs can be found at: /Users//Library/Logs/BFD Drums/BFD3/BFD3 Runtime.<date+time>.log
The most recent runtime log won’t have a date.

Crash reports can be found at: /Users/Library/Logs/DiagnosticReports/


Screenshot 2023-07-26 at 8.39.22 AM
The ONLY instrument in this project is BFD3. If I didn’t have sooooo many projects created with BFD, I would cut my losses. I sure hope you guys can fix this.

Hey @songkid

How often are you seeing this crash? Can you send me a copy of a project you’re seeing the crash in? Can you send me a crash report?

Crash reports can be found at: /Users/Library/Logs/DiagnosticReports/



The screen shot is attached. I am using BFD with a Status in BFD License Manager of “Up to date.” Please provide an email where I can send both the runtime log and crash report - I did not see where I could upload the reports here.



1 Like

Unfortunately the same error remains. I have been unable to use BFD Drums in Logic and have given up in favor of other products.

I tried reinstalling BFD and now my computer (not just Logic) crashes. I have deleted everything related to BFD off my computer. It is very disappointing because the samples are so good.

That kinda sounds like you might have something else going on? I don’t think BFD has ever crashed my OS. Always at the App level and safely able to Force-Quit.

Not sure what kind of computer you have, but if it does have removable memory, you can try to reseat the sticks. Any removable internal components I always try and reseat if I get hard crashes. If you’re on Mac, you can try SMC and PRAM resets. They can sometimes fix a buggy Mac.

I really appreciate the suggestions. I have an M1 Max MacBook that has no trouble running large sample libraries including other drum libraries. BFD works in standalone and has never worked as a plugin in Logic in the two years I have had the computer. The new symptom of system crashes happens when the computer is attached to the drive that has my BFD sample folders. It is possible the drive is the problem but I have other sample libraries on the same drive that continue to work normally. I have decided to put my time and effort into other software. If an update is released, I may try again. Thanks again for your reply.

1 Like

Hi jacubert,

i have got the same problem and I solved it the following:

I had moved one bfd library, so the path in bfd 3 was wrong. In my case this caused the described problem. Logic crashed on every start when bfd 3 was loaded as a plugin. Same Error massage like yours.

As soon as I removed the library. everything was fine.

To find out what library is affected, I rescanned the BFD 3 plugin in Logic. The rescan stuck in the middle and after shutting down Logic I found a warning on my desktop, telling me the path of the missing library.

Maybe this helps.

Best Regards