Audio Error 02 - Any Solutions? [SOLVED]

2018 Apple MacBook Air running Monterey 12.3
BFD3 v3.4.3.7

using the stand alone app I get:
Audio Error 02 Cannot open the audio stream because no valid samplerate was found

I cannot get any sound through the internal speakers, bluetooth headphones or external speaker monitors.
I try switching between all of them in Audio Preferences but no luck.

Can anybody help ?

Having bluetooth headphones connected when I start up BFD3 was causing the Audio Error 02 issue. I just disconnected them and started up BFD3 then reconnected them and it worked fine. I don’t use my BT headphones often so I didn’t bother troubleshooting any further, it’s simple enough to disconnect and reconnect.

To get sound working at all I have to reset the mixer on BFD3. every time, no matter what setup I’m using even if there’s no Audio Error 02.

I did have another issue with my audio interface and Audio Error 02 that was resolved by using Aggregate Devices on Macs Audio MIDI setup page… read on for the details.

Try a PRAM reset? Does your audio work with other apps? I quick search pulls up some core audio issues with Monterey. Check Privacy settings in Sys Prefs. Not sure, but maybe BFD3 needs access?


Audio works on all other programs with no issue.
Did a pram reset and I unplugged from my dock and disconnected my bluetooth headphones.
BFD3 starts with no Audio Error 02 but still no sound.
If I start up with my Bluetooth headphones connected I get the Audio Error again.

TLDR got rid of the Error but still no sounds from the stand alone app

Weird. If you go to Preferences->Open Audio Preferences->Outputs, what do you see? This is the preferences in the tool bar at the top of the screen, not the other one.

1 Like

Ok I got it working but I’m not sure why it works this way.

Step 1: Disconnect the Bluetooth Headphones
Step 2: Start the BFD3 stand alone app and audio defaults to the internal speakers with no Audio 02 Error
Step 3: Reset mixer in BFD3 ( I don’t know why this gets the audio working but it does, it’s a new install so there’s no saved or preloaded presets but for some reason it works )

Now it works as it should.
I can then turn on my bluetooth headphones and switch to them in the Audio Preferences page of BFD3 and it’ll work just fine.
I still have to test with my monitor speakers when I get home, hopefully it’ll work since thats what I do all my music on.

The Audio Error is back when plugged into my audio interface at home.

If you’re trying to use multiple output devices, you need to create an “aggregate device” in Audio setup, which combines the BT and main outs of your audio interface. Then select that aggregate device as the audio output in BFD3, or any other music apps. I haven’t had any luck with BT speakers with audio apps like Pro Tools, but it’s worth a shot.

1 Like

Yeah, I feel like you’d have to debug the Bluetooth itself to figure out what codecs it’s presenting and at what bit rates. I have to say, though, it’s one of those things I’m not all that interested in understanding. :smile: I almost always opt for a wire of some kind if I can help it.


@kafka Yeah, that’s a great point about making sure both audio devices are using the same bit rate & sample rate. That would obviously be an issue. The only BT device I use is a mouse, but I always use a wired keyboard, as it’s needed for boot screen commands in macOS.

1 Like

Thanks for all of your replies, to be clear I’m not trying to get the BT headphones to work now but my speaker monitors that are connected via 1/4 jacks to my Behringer U-Phoria UMC22 USB Audio Interface.

I tried the Aggregate Device on my Mac and it worked!
It looked like my AI (audio interface) was split between inputs and outputs. When I combined them into an Aggregate Device on the Macs Audio MIDI Setup it worked when I went booted BFD3.

Thank you guys for all your help, glad to have it up and working again!!

EDIT: For the recored I still have to reset the mixer on BFD3 on every startup to get the audio working.
It’s painless but still a weird quirk that I don’t know how to fix. Just wanted to document it here in case anyone else has an issue.

1 Like

Cool, glad you got it to sorta work ok. A little strange your audio interface Ins/Outs show as separate devices though. Do you have a DAW you can test BFD3 in, to see if the mixer no sound/reset is the same for you as in standalone? You can at least test in Garageband, which is free to download. If you don’t resolve that though, I’d say posting a formal bug report in that section to bring it to the attention of the inMusic staff.

1 Like

Ok so I got it working in GarageBand but I still have to do the mixer reset.

To be clear the steps are:

  1. Start up BFD3 and get no sound
  2. Click Mixer Reset, it asks to confirm, I select yes. Then is asks to remove all unused channels and I select yes.
  3. The preloaded drum kit and all but 3 channels (AmbMix, Metronome and Master) are then removed.
  4. I select any drum kit from the kit section.
  5. Audio works.

One other thing you can troubleshoot and possibly add to your bug report, is in BFD Prefs, select no preset on start up. Then open BFD3 and try and load a preset/kit and see if you get sound upon loading, without having to reset the mixer.

1 Like

Funnily enough it was set to no preset on startup already.
However I choose a random kit to load on startup for troubleshootings sake and it worked when I restarted without having to use the mixer reset.

So I guess it’s fixed but sort of a strange work-around.
Should I keep the bug report open?

Do you see the same issue and workaround in both Garageband and Standalone?

yes if i set a preloaded kit in both standalone and GarageBand then audio works as it should on startup in both.

If you’re all set now, then maybe it might be ok to delete your bug report. Idk, it’s up to you and if you feel there is no further issue. Seems like it was just some audio confusion on your end. I did actually just get that same error code as you now, but I had my audio interface powered off.

So I was thinking, is your AI getting enough bus power? Might be worth a look in the Behringer support for that interface and see if any issues with your macOS set up are floating around, or even better, a firmware update.

Also, you can check it’s status in System Information/System Report/Audio and USB to make sure the OS is seeing the interface correctly.