[UNDER REVIEW] Searching sound forever,,,,

Hello
I use M1 MacBook Pro
OS monterey
Logic Pro

I can play BFD3 as standalone but, I can not play in logic as AU plugin.
It is searching sounds forever…
Can I fix it??

I too am having this same issue. BFD3 works as stand-alone, but not as an AU plugin in Logic. Unable to load kit pieces or presets.

M1 MacBook Pro
OS Monterey
Logic Pro 10.7.0

1 Like

Yep same issue here! Tried an external drive didn’t work, just freezes on content locations screen if i hit any button

In my experience this is due to not running Logic Pro under Rosetta. BFD is not native (yet) to M1. Find the Logic Pro app → Get Info → check Open Using Rosetta

I should say I am not running Monterey - I am on Big Sur - but the symptom is identical.

Eagerly awaiting M1 native!!

2 Likes

Thank you :slight_smile: This solved my issue.

Sorry, I don’t want to be overly obtuse here, but… run Logic with Rosetta?
Is there an option within Logic to run Plug-Ins with Rosetta?
Thanks all!

Kicking the tires on the new 3.4.4.19 beta and it seems to have the same issue. Launching BFD in Logic 10.7.4 on MacOS 12.3.1… it hangs “searching”. Will try Rosetta and see what happens.

On edit… Rosetta seems to work but BFD will not load up on native Monterey.