[UNDER REVIEW] Had to re-scan locations, BFD is hanging in the middle

I had done some maintenance on my computer and disconnected my external hard drives just until I was done. After re-connecting the drives it seems the computer somehow changed the letter of my external drives. So, IN BFD’s Options to choose locations, I removed all current paths in BFD’s “Content location folder” and then tried to Re-scan doing a “Search Folder” pointing to the drive with all my BFD data. It seems the process gets stuck, or looks “busy” at one of the locations while exploring and says exploring 0%. It’s still seems to be going but it’s been a couple of hours at this point. It shows what I think to be ALL the locations, but is still hanging. What can I do?

@brad Could you please tell us what version of BFD3 you have installed?

The early 3.4 versions had this issue. BFD took some steps to alleviate it, and it did improve. However, I’m not sure it’s ever gone away entirely - depending on what you’re trying to scan. From what I can tell, it seems to be more likely to get hung up if there are a large number of grooves in the path**. I’ve found that the solution is to add and scan the directories for the expansions individually, rather than trying to do them all at once.

**note: it may not be, strictly, the quantity that is at issue, but maybe a combination of the quantity and the version, or something like that

Out of interest, which grooves do you have installed and how are they installed?? I can try to replicate the setup here and see if I get any hangs.

For anyone who has strange content locations issues, you can clear out the database files and re-add everything manually - one at a time - and that should be enough to get up and running.

The database files are located here:

Win - C:\Users[USERNAME]\AppData\Roaming\BFD Drums\BFD3
OSX - /Users/[USERNAME]/library/application support/BFD Drums/BFD3

Clear out anything with a .database extension, as well as the datapaths.xml file, then launch BFD3 and re-add your data-paths.

I’ve reorganized my grooves substantially since I last ran into the issue. I have a large collection of Groove Monkeys that it has hung on before. Typically I don’t run into an issue when scanning just the Groove Moneys themselves. But, for instance, if I try to scan the Platinum Samples grooves or some other large collection, at the same time, it might have hung.

And in terms of install locations and directory layouts and things, was it just the default serving suggestions from the installers?

That’s where the problems occur. If you use the default installers, they tend to put all non-audio content in the same location, so you can’t separate the scanning and it hangs. If you break your content up into manageable chunks, you can get through it.

I have version
Everything is such a mess allover again. I’ve not created new directories. I’ve not pointed to any directory that wasn’t as before except now the drive has different letter (it’s the very same external hard drive). I’ve done none of this, but now BFD goes nuts. Right now license manager asked me to download and install an expansion pack that I’ve had for years. Jazz and Funk. It DOES exist on this external hard drive and somehow BFD also asked me to install after downloading,…again. It’s like a loop of endless procedures that have already been done. What’s going on? does anyone have a suggestion? Who has the time to go through this every time I wanna use a drum sampler?

The drive is now called Drive K: so here are the directories with BFD data. I’m not smart enough to know which data it is or that should be scanned again but here it is and they all appear in the BFD content locations window. BFD/BFD and BFD/BFD/BFD
all of “THIS” next stuff, appears in either of these two directories: BFD/BFD or BFD/BFD/BFD. So it’s not as if I’ve pointed to some arbitrary directory.

Core Library and Core library Grooves
Grooves are : Jacques Mathis, Platinum samples Installer/ payload /grooves. modern Rock Grooves
London sessions/Payload/grooves
BFD2 /Grooves BFD2/ system
BFD3 core library grooves
BFD Eldorado/payload installer
BFD Jazz and Funk.
BFD Jazz Noir

I’ll stop here. This should give you an idea.

But it goes on and on. All showing up either in the BFD/BFD/BFD directory or the BFD/BFD directory. I even see Updates and installers and payloads in these directories. It’s nuts.

YES. I just pointed to the BFD directory and the software did the rest.
In answer to “kafka”, I’m not sure how I’d do that without the software goin’ nuts again. I’ll go back and start fresh by deleting the directories and choose it all over again. How can I be specific on just kits and I assume grooves too?

How would I do that? Go to the last directory instead of the top directory?

Can you send me some screenshots of BFD going nuts and License Manager asking you to download and install an expansion pack?? I need to see what is going on to make sense of it.

To an e-mail address? What is it? Or where should I send the screen shots? I would probably have to do a few screen shots to capture what’s goin’ on. I have already “Removed ALL content paths” at this moment. So I’m ready to start from scratch.

Just private message me here on the forum please.

OK, but before I do that, I’ve started fresh scans and all I scanned were the audio folders in the “end” of the directory from within each expansion pack, incl. BFD Core library. And that’s all it scanned. I also scanned a BFD2 folder’s audio folder, but that came up as needing a license and license manager came up. So I closed that down. I unchecked that folder as I think it’s included in the London Sessions and Eldorado expansion packs. So, let me work here and see if that worked out. Thanks so much Andrew. You’ve really helped me a lot. I can’t thank you enough. Maybe I’ve finally gotten somewhere.

Yeah. Just go to your “setup content paths”, and highlight one of those directories, so it’s blue. Then press the rescan button below. When it completes, go to the next, etc.

So far it looks right. Thanks Kafka. Much appreciated.

1 Like

Hi Brad,

Did you manage to get some screenshots you could send us please?

No, I actually did a whole new scan and pointed to the Drive again. I scanned one expansion pack at a time. So far it looks good.

1 Like

Thanks Brad, good that it seems to be fixed for you, however we’d still like to get to the bottom of this.

Could you please try and describe what you saw when the BFD “went nuts” and when License Manager was asking you to download and install an expansion pack?

Many thanks,

Well. Because the Drives were all re-named I had to do a new scan. I did. Starting with the directory in the hard drive that was labeled BFD BFD BFD. However even non-audio content folders got scanned this included all data in all the directories. It was taking forever and was stuck at 0%. So, I stopped it. rescanned just the Folders or directories that started on the expansion packs. So instead of a blanket scan on the BFD BFD BFD directory on my external drive I went deeper in each one and only scanned the expansion pack labeled directories. . I did a scan for each expansion pack that I had. THAT worked. The goin nuts thing? Was as I said. License manager asked me to download and install an expansion pack that I’ve had for years. Jazz and Funk. WHY? It DOES exist on this external “same” external hard drive and somehow BFD also asked me to install after downloading,…again. It’s like a loop of endless procedures of authorization, downloading, and installing that had already been done. After re-scanning, by only pointing to the directory named after each expansion pack, I got it to scan and work. Pointing to the main directories, BFD,… only created chaos. By chaos, I mean constant looping of License Manager, asking me to authorize, download an install, over and over again.