[UNDER REVIEW] BFD License Manager Error loading

I registered and authorized BFD and 2 Expansions.
Now every single time I try to access BFD License Manager to download the products I get the error
“There was an issue retrieving your list of products”

Any solution?

Running MacBook Pro M1 16G and BigSur 11.4

Thanks

Same on Windows 10 here.

Same discussion here:

Some suggestions that might work would be to log out and log back in again.
It might be trying to open your browser and cant for some reason so maybe open the your browser and log into to your profile Customer Login

If none of that does anything try uninstalling and reinstalling the licence manager.

This has to be a bug though and was ‘supposed’ to have been fixed in the 3.4.2.4 build.

Steve

4 Likes

THAT DID IT FOR ME. Holy crap. I’ve programmed some bugs myself over the years but nothing as random as “oh all your auths are gone, cya”.

Thanks man.

1 Like

Logging out of and back into the License Manager app itself worked for me. User>log out. Logging in will then take you to the browser/website login page.

Thank you Steve63!

1 Like

Thanks! This solved it!

PS: is that a way to download the core library via URL or it has to be done via the License Manager (10min and it stills saying 0.0k downloaded)

I think via the LM is only way it can be done sadly.

What’s your Internet speed?

Steve

Hi @mirovaz ,

Thank you for this report. I have raised the issue and we may be in touch should we require any further information.

Kind regards,
Clive

1 Like

I have 240M cable.
Cant find a way to download the core library via the LM

When you open the LM, do you see BFD3 listed in your list of products on the left?

If so, click on it and it should give you two download options, one for the software and the other for the core library/content installer, further to the right you’ll see a ‘download’ button just click on that.

Steve