Unable to download Imperial Drums expansion

Just purchased Imperial Drums on sale. Was able to activate, and download proceeded until it got to 7.0 of 7.5 Gb then stopped. I waited 4 hours, after the 7 Gb only took about 15 minutes. I tried pausing and restarting. I closed the LM with it paused, then restarted. I deleted the existing download and started over, then did the same after closing LM. Then logged out of LM and logged back in and restarted. Deleted data then logged out and restarted after rebooting PC. Manually deleted the folders in my download location and restarted. None of this has worked and I can’t download Imperial Drums. System specs below.
Any suggestions?

Win Pro x64 1909

I had similar issues downloading Oblivion last week. The speed was abysmal and kept freezing on me. I kept closing/opening the LM and it would help for a minute. I got to the end and it said there was an error in the downloaded content. I finally got the download to finish and the installer was ok.

inMusic’s servers are worse now than say a year ago. I don’t remember this difficulty downloading content.

1 Like

Yeah, It’s definitely not on my end. I double-checked with Speedtest.com and my download was 430 Mps. I just downloaded the latest Spitfire Lab, Cello Moods, and the 1.6 Gb file took about 15 sec.
I’ve gotten to 7.0 and 3.8 Gb trying to download Imperial, but once it stops it never seems to be able to restart. Isn’t that the purpose of having a download manager?
I’ll keep trying and hopefull it will work at some point.

Update: Finally got it to work with the new license manager beta.

1 Like