Total memory leak when loading preset (resolved)

well, thought i’d seen everything…

trying to finish up a couple of projects this week and just in time for Friday deadlines, the daw starts to crap out. debugging identified BFD3 as the culprit : totally consuming all available RAM (32G) ?!!

no clue as to what triggered this, other than a minimal Win10 Pro service update…

had been running well enough but ok, maybe time to update to
no luck, exact same issue.
same in standalone mode with absolutely nothing else running (after checking another daw)
will launch, but maxes out available RAM in about a minute as soon as a preset is loaded
tried a number of user presets, and then a few from BFD, all with the same result.

atm any project with BFD in it is completely dead in the water (= all the current ones on the books…)

ticket entered.

busking is starting to look like the more lucrative option

You could maybe try uninstalling BFD3, restarting PC and install again. I had recently had an issue with BFD3 just all of a sudden crapping out in Pro Tools, but doing the above I think got me up and running again.

This thing has bugs that just start popping up out of nowhere, after having worked solid for a year.

It’s been a long time, but I think there’s a button in settings that loads the entire kit into RAM. Make sure that’s not pressed.

Or maybe there’s a bug in reading the settings, and it’s worth either blowing that away or doing a reinstall.

thx for the prompt, de/reinstall seemed to make a difference after a simple check, :+1: for now.

1 Like