Standalone won't save

Version 3.4.4.31

I thought it was only my automation maps that wouldn’t save, but no, it’s everything. From the file menu, I’ve tried ‘Save Kit’, ‘Save Preset’ and also ‘Save Automation’ and ‘Save Key + Automation Maps’ when on the automation tab. In all cases, none of the settings appear to be getting saved. There are no errors reported, and the only thing that seems amiss is that when I close the app it warns that there are unsaved changes. When restarting, none of the changes I made are persisted.

Is anyone else seeing this behavior? I used to use Reaper as my host and never had that issue then. I can’t use Reaper anymore for a couple of reasons, one being that BFD3 doesn’t authorize there.

I have just saved a preset I made as well as a kit I built from scratch, close the standalone app and opened again, I am able to load the preset I saved as well as the kit. I haven’t had a chance to try the automation or maps yet.

thanks, @deangersmith. When you reopen the app, does it load your modified file automatically, or do you have to manually load it? I’ve always run BFD on a headless machine and it still appears to load the last file I had loaded, but without the saved changes. Honestly, I don’t think it’s saving at all for me since when I go to close the app after having saved, it still warns that changes would be lost.

I’m going to mess around with pathing tonite – perhaps it’s just a permissions issue that’s failing silently.

@dkadrioski You can choose which Preset you want to load on, App Open in BFD3 Prefs. Otherwise, the only other way to recall last saved Preset/Kit is through a session in your DAW.

1 Like

@dkadrioski I choose to load mine blank every time, but as @Fender_Bender has stated it is an option in the preferences.

I used to get that ‘changes will be lost’ message all the time but not anymore unless I’ve actually made changes to something whilst in standalone app.

I’ll confirm a bit later today :slight_smile:

interesting, I didn’t think to check WHICH file it was loading, just assumed it was always the last one loaded

So it looks like my preset file is corrupted :frowning:

BFD3 loads fine, with what appears to be an older version of the file (seems to come from some temp cache, judging by the runtime logs). It will let me save the preset to file, but if I try to load that saved file, the app crashes.

I ran the file through an XML validator and it looks fine. I think it just got hosed at some point :confused:

I’m guessing I have little recourse than to try and rebuild it from scratch. :sob:

1 Like