[RESOLVED] License Manager Reports Core Library has already been installed when it hasn't

Hi Everyone.
Bit sad my first post in this forum is for something that seems pretty broken. I’ve sent an email to support for this but haven’t had a response so hoping someone else has experienced this problem and has a fix.
Did a quick check through some topics but couldn’t find any relevant posts.

Back in April 2021 I purchased an upgrade from BFD2 to BFD3.
Until now I haven’t tried to run the BFD3 installation.
I’ve just built a new computer and completed a clean installation of BFD3. When I try to download and install the Core Library using the download ticket, License Manager shows that I have already installed the core library. This is definitely not correct and I can’t seem to find a way to get past this issue.

Appreciate any help on this.


You click on the ‘play’ button in middle of 3 icons on right top of interface to install.

Thanks for the reply.
Unfortunately that doesn’t work because license manager thinks the core library is already installed when it isn’t.

Sorry I misunderstood. The only thing I can think of is that it has installed it to a path that isn’t being searched. Do you know where LM thinks it has been installed? I expect that you have tried uninstalling and reinstalling.

No worries. I appreciate your help!
I changed the download location in the licence manager and tried to download the core library using the ticket file and got the same result. Licence manager thinks the core library has already been installed when it hasn’t.
Whenever I run the ticket file licence manager just shows 100% complete immediately.

The 100% green line doesn’t mean it’s installed, it just means it’s finished downloading.

If pressing the play button doesn’t run the installer, just click on the magnifying glass, that will take you to the exe file (dmg if you’re on a mac) and then just run that.


Thanks for the reply.
My problem is that the download did not occur but the licence manager thinks it did.
I would remember waiting for a 38GB download to complete. The first time I clicked on the core library ticket the licence manager showed 100% for the download instantly. No download of the core library actually occurred prior to the status being shown as 100% complete.

Clicking on the magnifying glass takes me to an empty folder/

Could you tell me the name of the name of the .exe file. I’ll do a search for it manually but I’m pretty sure it wasn’t downloaded.


Just search for, ‘BFD3 Core Library Installer’.

If that yields noting then maybe reinstall the LM if you’ve not tried that already.

There isn’t an uninstaller for the LM but you can just delete it at,

C:\Program Files\BFD Drums\BFD License Manager

I’m assuming it’s the latest version?


1 Like

Thanks again Steve,

I’m now downloading the Core Library
I was using Uninstalled that and ran
Seems t be working now.

Thanks again to you both Steve63 & operandx