Remapped, now London Session presets/kits won't load

Using 3.4.4, having to re-download all my kits, London Sessions was working, but then I got a “would you like to remap” popup, and I said yes. Now everything loads fine except London sessions Presets and Kits. Actually, the presets and kits seem to load, but there are no drums. It’s like they don’t know where the kits pieces are, although the location of those didn’t change. Any way to remap them?


I was having issues like this yesterday with Dark Farm and Heavy, i cleared all content paths and rescanned, then restarted my machine (although the restart in not really necessary on Mac OS, imo). But it worked for me, the kit pieces were all showing up again after that.

I appreciate the response. I tried your suggestion, even including the reboot, but no dice. Really don’t understand why it’s ONLY London Sessions. Grrrr.

I think I remember having an issue with the London Presets. My suggestion is locate where they are installed. If they’re installed in the System location, move the entire London Sessions Presets folder there to your User BFD3 Presets folder. Then rescan user content paths in BFD3, or vise versa.

I have done totally the opposite on both my systems, moved everything into the system folder and completely removed from users folder, all the audio content is on an external ssd. It’s working so well for me this way.

I think I will do that as well

I moved all presets to /Library/Application Support/BFD Drums/BFD3/System/ then into their various folder eg: favourites, Maps, Presets (most important one) Grooves etc, although I do have all the imported grooves in the Users/username/Documents/BFD Drums/BFD3/Grooves folder as I have so many I just left them like that, working great.

I found that it eliminated all the kit presets that were showing twice in the Presets browser in the app too. Something I have disliked since forever.

That double this and double that crap is what I want to rid

I’ve done a little of all your recommendations. what seems to have finally worked is removing the bfd2 files from the /Library/Application Support/BFD Drums/BFD2/ side and ONLY have the bfd3 presets and kits. Not sure why, at this point don’t care! seems to work now. Thanks for all your suggestions!

1 Like

Yes I did that too, that’s what was causing all the double presets, people on MacOS, in the groove browser if you see double presets you can right click them and select show in finder and that shows you where they are, I was finding one in the users folder and one in the application support folder.