Plugin not showing libraries, standalone works fine

I have an issue where standalone BFD3 works fine, however when I instantiate it within a DAW, it loads fine, but then the presets/kits/pieces sidebar is stuck on “Searching” and never seems to load any libraries. The drum contextual menu doesn’t load anything either. Essentially, there’s no way to load anything. Any thoughts?

What DAW are you using? Can you rescan your content once in the DAW?

Is the plugin version definitely the same version as standalone?? Can you check the version numbers in the about box in both instances??

John, it might be a Rosetta issue (assuming for a moment that you’re on Mac and using a recent OS). When I switched to a new Mac and Monterey last week, I experienced the same thing at first: after installing BFD3, the standalone worked fine, but the AU (loaded in in Logic) refused to load anything: no kits, no samples, nothing. And ‘Searching’ did indeed freeze the plugin. Only after I set Logic to run in Rosetta-mode, did BFD3 work fine as a plugin as well.


It turned out to be the Rosetta setting. I guess both DAWs I tried (Ableton and Reaper) are now Apple Silicon native and BFD isn’t yet. Thanks for the tip!!