Monterey Mac M1 and Logic Pro

Hi All

I recently upgraded my MacBook from an old intel based (catalia) and Logic Pro. To my great surprise, BFD3 worked straight away both in stand alone and as a Logic plugin.
I had to re authorise, but no issues here with LM. Then just had to re scan the data files and off we went, all working well.

Have to say I feared the worst, but all good!!!

Cheers

1 Like

Are you running Logic native or in Rosetta? A lot of us have had issues running BFD as a plugin in Logic when Logic is running native (the fix being to run Logic itself in Rosetta). But in my case I nave neither upgraded to BFD 3.4.3.7 nor Monterey because so many issues have been reported. Was waiting for a clean M1-compatible release.

It all worked perfectly here on an Intel MBP under Monterey. Not a Logic user.

1 Like

I used Logic under Rosetta2, as BFD3 is an intel based app.
I initially ran BFD3 stand alone before trying Logic.

OK, thanks. Most (all besides BFD3 that I know of) plugins that are not native will still run if Logic is started native (not under Rosetta). I guess the Logic plugin interface can run the plugins themselves on Rosetta while Logic is native. However, nobody has gotten this to work with BFD3 to my knowledge. Still awaiting a version that is either native or runs successfully under native Logic as a Rosetta plugin.

That being said, your success with Monterey is good to hear - I didn’t think we had achieved confidence that we could upgrade to Monterey and safely run BFD3 with Logic running on Rosetta on an M1.

@betatesters

Does latest beta version of BFD3 (3.4.4) work under Rosetta running Logic in native mode on a Mac M1?

1 Like