MIDI Playback Problem with Logic

Hi. New user here from the recent sales of BFD3.

Noob question but I cannot seem to find the answer online.
I can load up BFD3 just fine in Logic and the Groove Editor works fine.
But I cannot make BFD3 respond to MIDI data playing in the DAW. Clicking anywhere on the Piano Roll or dragging MIDI data from the Groove Palette to the timeline will not produce any MIDI input to BFD3.
Thanks for helping out! :kissing_heart:

Running BFD3 in Rosetta mode on a Monterey 12.6 Mac Studio with M1 Max.

Edit:
Pressing the kit pieces in the Kits tab or the keyboard in the Key Map tab does produce a sound to my DAW. I think it is only MIDI data that BFD3 is not receiving from Logic.

1 Like

@musicianw Welcome aboard friend! I know this has happened to me in the past, but I just can’t remember exactly what the issue is. I’m pretty sure it’s something obvious and simple, especially considering you are getting some output.

When you installed BFD3 and used the setup wizard, did you choose Logic as your Main Host Application? In BFD3 Preferences under MIDI, there is an Octave numbering scheme. You could try messing with that.

Also in preferences under GUI, make sure the Shortcuts tick box isn’t enabled when using BFD3 with your DAW.

1 Like

@Fender_Bender
Thanks for your reply!

I tried reconfiguring it with the setup wizard, and it automatically help me changed to -2 octave numbering. I also experimented with different octaves, but all to no avail.

I attach the screenshot to the current configuration of the application.
Hope this might ring a bell.

That all looks about right to me. If you put another sampler on the same track that you have BFD3 on currently, is it able to playback that MIDI groove you dragged from BFD3?

If you have a MIDI controller, does that trigger sound? If so, try recording some BFD3 MIDI with your controller, into your DAW and see if it will play that back. I’m just thinking the MIDI grooves aren’t lining up properly in the DAW.

What about Logic’s piano roll… try clicking all the keys on it to see if any sounds are triggered (even those not in the MIDI data on the track). If yes, then it’s just a matter of the grooves not lining up.

MusicianW, is the MIDI In Channel of the Track where you loaded BFD3, set correctly? See, the only way I can recreate your problem – I’m also running BFD3 in Logic (Rosetta mode) – is when I set the Midi In Channel of the Track where BFD3 is instantiated, to anything other than either ‘All’ or ‘1’. As long as it’s set to ‘All’ or ‘1’, BFD3 responds perfectly to incoming MIDI, as soon as I set to ‘2’ or higher however, BFD3 stops responding.

And it makes no difference on which Track you load BFD3, the MIDI In Channel of the Track should ALWAYS be set to either ‘All’ or ‘1’.

Depending on the way you configured Logic after installation, these numbers might be ascending from one Track to the next — an unlikely eventuality, but it might have happened — and if you then happen to load BFD3 on a Track that has its Midi In Channel set to, say, 4 or 7, BFD3 won’t respond to any MIDI-data you feed it.

_

Hi @basrikke , thanks for chiming in to help! Much appreciated!

I hope I was setting it up correctly - the MIDI In Channel to All and the one in BFD3 to Omni. Experimented with both on ‘1’, still doesn’t produce a sound. But you can see from the top (I connected my MIDI keyboard) that there is MIDI signal coming in but no sound being triggered.

@Fender_Bender
I also tried replacing the instrument plugin with other drums samplers like SD3 or NI’s Studio Drummer and they seemed fine in making a trigger from the MIDI grooves from BFD3. Playing on the MIDI keyboard or pressing on the piano roll doesn’t produce any sound.

Mmm. If you can make BFD3 to produce sound by clicking its instruments, and you’ve also made sure that MIDI enters BFD3 — I’m still not sure if that is actually true though; can’t really tell from the screenshot which you posted —, I can’t think of a single explanation why BFD3 shouldn’t respond to that incoming MIDI. (Unless there’s still something very wrong with the mapping.)

But about making absolutely sure that MIDI is entering BFD3: can you check if the MIDI icon (next to the speaker icon in the black display at the top of the interface) is lighting up when you press a note? If it doesn’t, there’s no MIDI coming in. Another way to check it is by opening up the MIDI Log (Menu>Tools>Show MIDI Log) where are all the incoming MIDI is being listed. If nothing appears in that window when you press a key on your controller keyboard, there is no MIDI entering BFD3.

_

Can confirm that both the MIDI icon is not lighting up and there is nothing showing up on the MIDI log. So I think the problem lies in the MIDI entering BFD3. Not quite sure how did MIDI transfer between Logic and BFD3…

Maybe I’ll try a reinstall later to see if that helps reset everything?

Thanks @Fender_Bender and @basrikke for all your help!
I was digging through the past forum posts and decided to give a Logic Pro reset a try - and it did worked!

I solve this issue by:
Choose Logic Pro > Settings (or Preferences) > Reset All Settings (or Preferences) Except Key Commands.

Hope this helps some newbie users out there (if there are any)!

Edit:
Was just playing with the settings in Logic Pro, found out that if I click MIDI 2.0 inside Preferences, BFD3 will not sound.

1 Like

Great to read that your problem is solved, MusicianW.