License Manager cannot retrieve list of products

When launching License Manager, it retrieves the list of my products (BFD3 and three expansion packs), then it throws up the following dialog with an OK button as the only option:

“There was an issue retrieving your list of products.”

“Our server was unable to process the request. Please try again shortly. Server message: The request could not be authorized”

The list of products is correct, but all of them show a status of “Not authorized (license invalid)”

Mac mini M1 2020, Ventura 13.4

To be honest, I wasn’t really expecting this to work. I’ve owned and loved BFD3 since 2015 and got a few good years out of it while fxpansion owned it, but it stopped working after being taken over by InMusic, and it’s never worked since. I try the latest version of License Manager once a year to see if there have been any breakthroughs but, so far, we don’t seem any farther along than last year.

Anyway, if anyone has a magic incantation or other means of resuscitating this product, it’d be cool to use it again. For now, I’m using Superior Drummer and EZdrums and they’ve been rock solid, but don’t seem to have the punch and transparency that BFD3 has back in the day (at least from what I remember).


Forgot to mention that, if I try to enter my serial number into License Manager (copy/pasting it from InMusic’s “Product Registrations” page), it throws up the following dialog:

The request could not be authorized


Probably just their servers acting shitty… per the usual. Not ideal, but just wait a few hours and try again. Pretty unacceptable truthfully, but they don’t seem interested in addressing this ongoing issue.

1 Like

Hey @quantumonion

Could you please try logging out of your account in BFD License Manager and logging back in again?


Thanks Joe! Will give your suggestion a shot in a few hours when reunited with my Mac.

Same issue here, also on an M1 Mac Ventura 13.4.

Logging out and back in temporarily fixed it, but now I get the “There was an issue retreiving your list of products” error every time, and both BFD and the license manager tell me I’m logged out every time I open them.

No luck. I logged out and back in and the website displayed the following:

**There has been an error processing your request**
***Exception printing is disabled by default for security reasons.***
**Error log record number: 73156b14580390c131148ca6545978366ba7e6b3b2d2c5bd530878f0e977fd23**

But, despite the above, BFD License Manager now says that all my products have a status of Authorized.

I then installed both BFD and BDF Core Library from within License Manager. Launched BFD (standalone) and it crashed in (crashed thread below).

I tried launching several more times and it crashes every time.

Crash summary:

Process:               BFD3 [6312]
Path:                  /Applications/
Identifier:            com.bfddrums.BFD3.standalone
Version:               3.4.5 (
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Crashed thread summary:

Crashed Thread:        15

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called

Crashed thread info.

Thread 15 Crashed::
0   libsystem_kernel.dylib        	       0x198bc0724 __pthread_kill + 8
1   libsystem_pthread.dylib       	       0x198bf7c28 pthread_kill + 288
2   libsystem_c.dylib             	       0x198b05ae8 abort + 180
3   libc++abi.dylib               	       0x198bb0b84 abort_message + 132
4   libc++abi.dylib               	       0x198ba02a8 demangling_terminate_handler() + 52
5   libc++abi.dylib               	       0x198baff48 std::__terminate(void (*)()) + 16
6   libc++abi.dylib               	       0x198bafed8 std::terminate() + 36
7   BFD3                          	       0x11528d854 0x114eb0000 + 4053076
8   CoreAudio                     	       0x113168774 0x113068000 + 1050484
9   CoreAudio                     	       0x113072c30 0x113068000 + 44080
10  AudioToolboxCore              	       0x19a93a4b4 caulk::expected<unsigned int, int> caulk::function_ref<caulk::expected<unsigned int, int> (ACAudioSpan&)>::functor_invoker<acv2::_AudioConverterFillComplexBuffer(OpaqueAudioConverter*, int (*)(OpaqueAudioConverter*, unsigned int*, AudioBufferList*, AudioStreamPacketDescription**, void*), void*, unsigned int*, AudioBufferList*, AudioStreamPacketDescription*, AudioStreamPacketDependencyInfo*)::$_1>(caulk::details::erased_callable<caulk::expected<unsigned int, int> (ACAudioSpan&)> const&, ACAudioSpan&) + 184
11  AudioToolboxCore              	       0x19a89f21c acv2::AudioConverterChain::ObtainInput(acv2::AudioConverterBase&, unsigned int) + 860
12  AudioToolboxCore              	       0x19a9f0d40 acv2::Resampler2Wrapper::ProduceOutput(ACAudioSpan&) + 228
13  AudioToolboxCore              	       0x19a89e968 acv2::AudioConverterChain::ProduceOutput(caulk::function_ref<caulk::expected<unsigned int, int> (ACAudioSpan&)>, ACBaseAudioSpan&) + 176
14  AudioToolboxCore              	       0x19a939f78 acv2::_AudioConverterFillComplexBuffer(OpaqueAudioConverter*, int (*)(OpaqueAudioConverter*, unsigned int*, AudioBufferList*, AudioStreamPacketDescription**, void*), void*, unsigned int*, AudioBufferList*, AudioStreamPacketDescription*, AudioStreamPacketDependencyInfo*) + 500
15  CoreAudio                     	       0x113072624 0x113068000 + 42532
16  CoreAudio                     	       0x11316e5ac 0x113068000 + 1074604
17  CoreAudio                     	       0x113076884 0x113068000 + 59524
18  CoreAudio                     	       0x19aed193c HALC_ProxyIOContext::IOWorkLoop() + 6628
19  CoreAudio                     	       0x19aecf87c invocation function for block in HALC_ProxyIOContext::HALC_ProxyIOContext(unsigned int, unsigned int) + 116
20  CoreAudio                     	       0x19b032564 HALB_IOThread::Entry(void*) + 88
21  libsystem_pthread.dylib       	       0x198bf7fa8 _pthread_start + 148
22  libsystem_pthread.dylib       	       0x198bf2da0 thread_start + 8

Thread 15 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000000   x1: 0x0000000000000000   x2: 0x0000000000000000   x3: 0x0000000000000000
    x4: 0x0000000198bb45e4   x5: 0x000000016b29a260   x6: 0x0000000000000067   x7: 0x0000000000000002
    x8: 0x811442b19b606304   x9: 0x811442b0f04bd304  x10: 0x0000000000000200  x11: 0x000000016b299d90
   x12: 0x0000000000002001  x13: 0x0000000000006101  x14: 0x00000000ffffffff  x15: 0x0000000000002000
   x16: 0x0000000000000148  x17: 0x00000001f8718f60  x18: 0x0000000000000000  x19: 0x0000000000000006
   x20: 0x000000016b2bb000  x21: 0x000000000001490b  x22: 0x000000016b2bb0e0  x23: 0x000000016b29a410
   x24: 0x0000000000000400  x25: 0x0000000000020000  x26: 0x000000016b2ba410  x27: 0x00000001518a0450
   x28: 0x0000000000000400   fp: 0x000000016b29a1d0   lr: 0x0000000198bf7c28
    sp: 0x000000016b29a1b0   pc: 0x0000000198bc0724 cpsr: 0x40001000
   far: 0x000000016b2b4010  esr: 0x56000080  Address size fault

Hey @quantumonion

What audio device is it you’re using?

Could you try launching BFD3 with no audio devices connected to it and tell me if it still crashes?
If there is no crash, try the following;
1. With BFD3 still open, plug in your external audio device
2. Open BFD3s audio prefferences by clicking BFD3 in the menu bar at the top of the screen and go to Settings>Audio prefferences
3. Press the refresh button in the audio prefs

I think your audio settings will update to your external audio device at that point


1 Like

Hi Joe, thank you for the suggestion!

I’m using Dante Virtual Soundcard connecting to a Dante network with Allen & Heath SQ-7, DT-168, and a few DiNet DAN-RX2 for monitors and the talent’s headphone mixes.

Let me try as you suggest and I’ll report back in the next hour or so.

Hi Joe,

Yes, stopping DVS and using the Mac’s internal speakers (or the speakers in an LG display) does work. Since both of these are running at 48kHz, I tried changing Dante Virtual Soundcard from 96kHz to 48khz and that’s also working. So, I’ll run at 48kHz for now.

Thanks for your suggestion! Good to have BFD back!


1 Like

Actually, I WAS running the Dante side at 48kHz, It was BFD that was configured initially for for 96kHz (sorry, I misremembered!). So, I think the sample rate mismatch between BDF and DVS was more the problem. Stopping DVS allowed BDF to startup and this is where I changed the sample rate (BDF’s audio preferences). Anyway, just wanted to straighten that out so as not to mislead anyone.

This is still going on in September 2023 and I’m seeing people have been voicing concerns… Completely unacceptable… “Our server was unable to process the request. Please try again shortly. Server message: The request could not be authorized”


Agreed. If their servers aren’t going to be reliable 99% of the time, then they need to ditch this type of authorization scheme. This is hurting the brand more than anything else.

1 Like

I’ve just stubbled upon the same problem on my identical machine M1 2020 Mac mini Ventura. Also BFD won’t run at all and just crashes in stand alone. Anyone got any thoughts. I’m a Beta tester for BFD player and that loads but is no longer authorised.