Licence manager won't launch

Had a blue screen earlier whilst licence manager was running.

Call of Duty was open on the task-bar and when I closed it I got a blue screen saying Bad Pool Caller.

After rebooting licence manager no longer launches. Trier uninstalling (deleting folder) and reinstalling but still won’t launch. :frowning:


Further to the above, I have 4 kits on my contents page that are now ‘unlicenced’ (image attached.

Of course now the licence manager is broken I can’t licence them. I had hoped the licence manager might launch from the contents page since it won’t launch from the desktop but no deal.

All sorted now.
I did a search for everything named BFD3 Licence Manager and deleted it.
Rebooted and reinstalled and now it’s working again. :slight_smile:



Thank you, sir, you are a legend.

I had the same issue. Seems that deleting the registry of the license manager is what does it.
Simple reinstall is not enough, and there is no need to touch the other components.
I was afraid of losing the license and then being unable to reenable it.

1 Like

I’m in it now. This is a pain in the ass. I’ll try this, thanks

I can’t get it to work

I’ve deleted the license manager at least 3 times, re-downloaded it. The license manager won’t launch. Looks like BFD is going to ruin tonight’s recording session. What’s next ?

If you’re willing to try one more time, uninstall, reboot, then reinstall.

What would really help is if you have CCleaner or some other registry cleaner to clean out any old registry entries that are getting in the way. CCleaner has a registry back up fuction built in so just say YES when it asks to backup.

So: uninstall > CCleaner > reboot > re-install.

Thanks, I will try it tomorrow. I re-installed pre- migration BFD, thank god it works.

1 Like

I tried it. I have Avast Cleanup. No go. The License Manager Installer works, but the License Manager itself won’t launch. I tried running it as an administrator, but no.

Im tired of this, I will continue with BFD 3.3, and check back in a few weeks.

Thanks again

Bummer. Sorry to hear that. That really should have worked. Not sure what’s going on with LM, but it’s a bit of a mess for sure.

Hey, so I was clicking on the new license manager for fun, and a window popped up that said Windows “Defender “?was blocking the app. I clicked on allow access, still did not work. But that was different.

I got so excited, I did not really read the pop up. Also, all of my windows security is disabled.

And, before I downloaded The London Sessions, the new license manager was working, BFD stand alone was working.

I’ve got BFD 3.1 working so I’m not panicking. Should I delete all the new BFD and start over ? Or wait for a new update?