Importing grooves problem

ive noticed when ive imported new grooves like a groove monkey pack bfd alters some of the data. like the velocity or timing is different from the original file. anyway to make it just transfer flat? ill check and the midi will be the same across different versions (slate,sd3,addictive) and only the groove i imported into bfd3 is different. i also had not made any adjustments in the groove editor either. thanks

I usually import groove monkey files as general midi and they seem to be ok and not altered.

1 Like

I just got started messing with midi grooves. I found that when I preview a groove in BFD (groove monkee) it sounds good, then I drag it into Pro Tools and it is then dropped into the wrong octave on the midi scale.Which makes everything sound thin and weak.

Im sure theres a coherent way to say this, but Im trying.

Do you know of an easy way to fix this other than dragging the notes up to the correct octave ?

So, this appears to be a problem with “The Police” drum groove pack. I wonder if it has something to do with being imported as a BFD2 pack ?

Nevermind, it just happened with the BFD Oblivion pack, and with a BFD3 Groove…

The MIDI map is more than likely incorrect for Pro Tools.GrooveMonkee is one of the few that supplies a lot of mappings with their packs.

GrooveMonkee does not recommend Pro Tools…

Recommended: No
Pros: Industry standard
Cons: No MIDI auditioning

"If you’re looking to use commercial MIDI libraries, you’ll need a 3rd party drum app that supports it.
Or you’ll have to import the loops one at a time."

You could try to export the MIDI using a Pro Tools Keymap…you’ll have to create one as I don’t see a Pro Tools map in the Key Maps I haven’t used Pro Tools…Beat Detective,creating Groove Templates etc in a long time…I think there was a trick to change the timebase on the MIDI track(s) in Pro Tools to “Samples” instead of “Ticks.” This prevents the MIDI from changing tempo…but that is about all I can remember…

MIDI Export settings

“The current MIDI Key Map is used for mapping Drum articulation events to MIDI notes when exporting Grooves or the Drum Track”

thanks for the reply. so i imported my groove monkee files with their bfd2 setup( bfd3 if available). Ive bought 4 packs and im not quite used to them yet.

the layout of drums is fine, its all just shifted an octave up ( not all the groove packs do this). by the time i noticed this, my brain was fried from a couple hours of searching through libraries. Im really looking for good drum fills for my songs.

hopefully someone out there has conquered this.

I did try grabbing individual pieces and dragging them up an octave, and that is no fun. I end up screwing everything up.

I have to look into it more,

@TomLaRosa Check/adjust the Octave Numbering Scheme in BFD3 MIDI Prefs?

The Octaves are incorrect…when importing directly into Pro Tools?..or BFD3?
You mentioned previewing in BFD3…but dragging the same MIDI Groove directly into Pro Tools.
as mentioned by Fender Bender there is a preference to shift Octaves in BFD3 for Normal …-2…-1…
Preferences > MIDI > Octave Numbering Scheme…
I don’t know how this will affect the MIDI Groove behavior importing directly into Pro Tools unless the MIDI Groove will save/export with a 2 Octave change so you can import directly into Pro Tools.

Hey, thanks again.

So the Grove Monkee files are loaded into BFD’s grooves folder. In BFD i click on them and they preview perfect. Then, I drag and drop files from BFD onto the ProTools Midi Track (amazing).

The problem is some files jive perfectly with whatever settings im on, but then some land on a different octave on the midi track.

Ive been playing with it and Ive found that your / my “keymap” selection in the setup wizard dramatically affects this. If I set my keymap to BFD2, it reverses my situation ( some work, some dont)

Some of Groove Monkees packs are formatted for BFD2, I think this is where Im getting hosed. If I remember right, only one Groove Monkey pack offered BFD3 format.

I found the Midi Map button in the key map window, I did not get it to work…

Im afraid that I may be fukd. My beats were programmed with the BFD3 Keymap, then GroMomks grooves come in in BFD2 keymap. I think that where Im at.

Hopefully there is a solution. going to go to Groove Monks web site.

Talk to Russ at Groovemonkee…if you have old MIDI grooves or purchased with a legacy account you can get updated versions of all your grooves…
I checked and according to the website the BFD2 are compatible…so something must be wrong somewhere and the instructions are dated as it points to the Fxpansion Folder.
BFD3
Our BFD2 files are 100% compatible with BFD3. They are in the “Other MIDI mappings” folder of your download.
Installing the BFD2 files into BFD3:

  1. Copy our BFD2 folder into your “Documents\FXpansion\BFD3\Grooves” folder
  2. Tools menu > ‘Set up content locations’
  3. Click ‘Rescan User Content Paths

Groovemonkee manual

Have you tried importing the grooves?..set the Groove Import Map to BFD3
Preferences > Grooves > Import MIDI Key map…

Then Import one of the grooves (Groove Browser Open…or Drag n Drop on the Palette)…
File > Load Groove from File…(There is also a Batch Import Option)

Ok. So, I have a lot more exploring to do. I sent an email to GM support.

Im new to using other peoples grooves, Ive been writing my own beats forever. So Im sure im screwing up somewhere.

Im starting to suspect that some of the grooves from BFD London Sessions could be a different midi map than the BFD3 Grooves. If so, thats part of my problem. Or, I could be wrong.

I have a session where I only used GM, and I modified the grooves in spots, and its real good.

Where things got crazy is, I had a session where I wanted to find drum fills for a song. I went through every groove library I have ( BFD2, BFD3, 4 different GMomkee) I was grabbing fills from everywhere and dropping them at the end of the session to sort out later. Its there where things got out of control.

So, yes the GM Grooves are imported into BFD3 using GM’s " other midi mapping" BFD2 Format. They work great.

it is possible that the old BFD Grooves are what screwed me up, and the more I messed with BFD settings, things got wierder.

My final BFD setup wizard settings were " Main Host" BFD Stand Alone and “Keymap” Import from preset. From there I did another session with only my beats and GMonkee and it went good.

I will look into your suggestions. Thanks a lot

Yes, London Sessions grooves needs a BFD2 Keymap loaded to line up right.

Why didn’t you select Pro Tools as your main host during the setup wizard? That’s where it decides the MIDI octave numbering scheme to use and disables shortcuts, I believe.

1 Like

In the particular session where things went crazy, I started changing all kinds of settings trying to make things work. Nothing fixed my problems.

After getting overwhelmed, I went into another session where I used only GroovMonk, and beats I made. Everything was good. So I checked BFD3 settings, where things were working, and thats what the settings were. So I figure its working, Im not going to mess with it.

Im about to go in and look at things again. But Im thinking BFD2 London Sessions is the culpret. I think thats the oldest grooves I have. I may just delete them.

Hopefully Ive got it figured out. If not, Ill be back here whining shortly.

Thanks

So I ran an experiment. I created a new session and quickly drag and dropped a beat from every groove library i have.

Everything worked fine. All lined up. Even the London Sessions.

I dont know what happened before. As long as it works, Im good.

Ill be back if anything goes sideways.

Thanks for your help.

2 Likes