I give up on 3.4

Back to 3.3. Tried to migrate, BFD says error. I copy over the files. It sort of works… but now I have double entries. Ok, but my Gen 16 cymbal pack doesn’t work…get that fixed, except while it lists the cymbals as available, it will not load them. Recan just sits at 0%. Life is too short. I check back in a couple of months.


Is this when you open BFD3 and it tries to migrate your folders?

I had the exact same thing, tried it 3 or 4 times.

I’m not saying this will work for you and I have no idea why it worked for me, (could have just been coincidence) but I opened BFD3 as a plug in my sequencer (Cakewalk bandlab) and got the message saying migration was successful.
It wasn’t 100% successful and I had to do some editing but I’m mostly there now.

The scanner keeps crashing here too. It’s done it in previous versions too. :frowning:


1 Like

I copied everything over and that kind of worked. Except now I have two entries for everything; one from BDF and the other from fxpansion. I went into the registry and “fixed” the failed migration. So far, so good. Except my Gen 16 cymbal pack is messed up. It lists it as a choice when I add a new cymbal but doesn’t actually load the audio file. No error message, just does nothing. Rescan just sits at 0%. Really, 3.3 works fine. I can live without the Horsepower kit🙂. Also, I can’t be online 24/7. I haven’t even tried 3.4 in a DAW yet. Again, life is too short for this stuff. I’ll keep checking back but with such a shaky start it will be quite a while before I will trust any update to BFD3. I love the kits and the software though!
Rant ON… this is becoming such a problem everywhere. I have built a new computer and it is spewing out a 1khz tone. Corsair says EMI is not covered by warranty. My update yesterday for Cubase 11.0.20 crashes with the Neuraldsp amp sim. Is it Cubase? Is it ilok? Is it Neuraldsp?
Anyway, I would like to get frustrated with my fingering and chords etc instead of continual update frustrations. Rant OFF.


Wonderful. Trying to use in Cubase, Studio One, and Cakewalk. All of them crash. This is after reinstalling 3.4 because 3.3 didn’t work, kept calling up the Licence Manager, then would not proceed.i assume the registry is hosed, but who knows. I would completely wipe BFD3 and start over except I am afraid that it would not reinstall and I would never be able to get it back.

Wiping and reinstalling might be your best option and it’s what I did.

Just wipe the software and not the library.

Do you have many expansion kits and are they all installed into a master folder?

That is how I set my folder structure up and it helped simplify things.

I had a couple of expansion kits that showed up in the licence manager but BFD3 saw them as unlicensed so I downloaded them again and rescanned and now they are all good.


Some progress here. The 3.3 version was hopelessly borked. So I reinstalled 3.4(after thoroughly scrubbing it) and now it works. I still have double entries for everything’s as it scans the expansion folders for some reason. I need to send my old zildjian cymbal serial number back to support to be able to download and use it. I had to go into the registry to stop it from asking if I wanted to migrate from the fxpansion site. So it mostly works, but how screwed up is that install? Anyway, thanks for the support.

This is how I have my data paths set up. Dedicated ‘plugin data’ drive, all BFD-related data inside a master Fxpansion/ folder and the transition seems OK on Windows 10. Just waiting on getting some of my older expansions to work now.