First windowsAZvoid directory windows

Each time I use BFD in my porjects, i firstly have the first windows giving all my directories and licensed products… I have to close it to start to use my BFD. Does somebody knows haw to avoid this first boring windows ? I would like to directly view and control BFD GUI !

Do you have lots of expansion kits or just the BFD Core Library?

It sounds like there is something missing from your library. :thinking:

If you cold post some pictures of your content locations (directories) that might help.

Have you tried to rescan all your content paths?

On the 'content locations page, (directories) you’ll see a button saying, ‘Remove All Content Paths’
Once you have done that you could try adding them again and seeing if it still happens.


Yes it is probably not well organised on my PC… I send you four pictures : 2 from license manger, one with the roaming folder and one on the disk where I store the libraries… On teh license manager I see taht all is well licensed and installed but … it is very strange. For example, I have two folders for “percussions” !

… and I don’t see my license for ManuKatche Signature that I bought too… In the list of my licensed products…
I thank you very much to loose time for me !

First major issue I can see is that ALL of your kits are in a folder called ‘BFD3’
You should definitely change its name to something like, BFD Drums.

Then I would get rid of all of those update folders and crystaldiskmark (whatever that is)

Is the keymaps folder something that contains maps that you have created or are they factory ones?
The factory ones are located in a folder called maps that is at C:\ProgramData\BFD Drums\BFD3\System. You could copy the contents from the keymaps folder into the maps folder.

I think there is an issue with the licence manager moment where it list drums as registered, but not installed, even though the are installed. That can be ignored.

The last picture from your AppData\Roaming\BFD Drums folder is a little different to mine which is interesting but I don’t think it’s causing your problem.

Try taking the steps I have given you, then once you have moved those folders rescan ALL content locations and let us know what happens.


I did the following tasks : Move Keymap in the good folder (map), canceled all update and Crystaldisk mark folders, modified the name of my data folder (now named BFD Drums), rescanned all the data folders to reconstitue the libraries tree… For the moment, the toruble still exists 5when I launch BFD3, i have the view taht I have to close where as you can see, it seems that two licenses are not recognized). And now, I only see BFD3 installed in my licence manager ! It is strange because, in fact, it seems that I may use all my extensions librairies ein BFD3

Right, now I can see your contents page it’s obvious what the problem is.

The BFD2 library should not be on the list as it doesn’t work with BFD3.
If you no longer use BFD2 you can remove it from the contents page and as long as you have no intention of using BFD2 again you can delete the library too.

Also, you need to licence you Manu Katche snare.
If you’re unable to licence it you might need to see if you can get a new serial by filling in a support ticket here (Support : BFD Drums)
In the meantime I would just remove them from the contents page because that is why you are getting the pop up. Remove them and rescan ALL your contents.

If you bought the original BFD2 library you can still use it but you will need to download the new version which is now called The London Sessions (
It is the same library as the original but again, you will either have to contact support or @BFD_Drew or @Rayne and give them your original fxpansion account details and your BFD2 serial number and they can give you a new serial for the London Sessions and instructions on how to download it.

Some advice for the future, now that you have your master folder named, BFD Drums, if you’re going to install new expansion kits in that folder, I would suggest creating a folder inside your BFD Drums folder and giving it the name of the expansion you are about to install. This is what I’ve always done because sometimes the installer messes up so this avoids installation issues and keeps it neat and tidy.


OK… I have disabled BFD2 (that i don’t need) and MK Snare and it now…works fine; I am very glad of your support ! congratulations… I just don’t understand what is the reason I don’t see my license for MK snare because I bought it some years ago… I will follow your advice in the future…

1 Like