Error when trying to install. Can't figure it out

I had everything working fine before moving over to InMusic. Had some yellow triangles and in the process of fixing those seemed to have made things even worse. Now I can’t seem to do anything without the following error.

The folder it’s asking for isn’t around when I go hunting for it, which makes sense because doesn’t avid= pro tools? I’ve never had a version of pro tools installed. I use Logic.

Thoughts?

You might need to unhide system files on OSX to be able to find the location. Try pressing CMD+SHIFT+period key to unhide all system files and folders. Then dig down into the location the installer mentions, and delete the aaxplugin that will be there. The installer should run okay after you do this.

I’ve unhidden the system files and followed the path go>library>application support…but from there I don’t see a folder for Avid. It wants me to delete something I don’t have. At least that’s how it appears to me. I’ve never had a version of ProTools on my mac.

Thanks,

I feel that it’s just complaining that it can’t delete something that doesn’t exist. You could try creating it first. Just make that directory and put a file in it that you’ve renamed to BFD3.aaxplugin. Really, the install script shouldn’t get hung up on that.

Better yet, the install script should ask you which formats you want. I have other plugins that want to install every format possible. Really annoying.

18 days in and I still have gotten nowhere with this. I’m working with BFD support but it’s a pretty slow back and forth and I feel like we’re just going in circles. I tried following kafkas advice but that didn’t change the outcome. It’s possible I did something incorrectly as I don’t consider myself a computer expert. These are my exact steps below.

  • quit all running programs
  • restart computer
  • make sure I’m connected to the internet
  • open inmusic bfd license manager
  • go to downloads tab
  • hit play button on bfd3 update 3.4.2.4
  • close license manager
  • open bfd3 installer package
  • enter my computers password
  • click ‘next’ to begin installation
  • click ‘agree’ to terms and conditions
  • “please choose optional components/migrate bfd3 files” click ‘install’
  • "ALERT! Error deleting BFD3.aaxplugin. Please ensure Protools isn’t running, or delete /Library/Application Support/Avid/Audio/Plug-Ins/BFD3.aaxplugin manually, and try again. This installation will now abort.

Make sure when you do it that you’re getting the capitalization of the directories correct. Mine is exactly “/Library/Application\ Support/Avid/Audio/Plug-ins/”. Notice that “ins” is all lower-case.

Note that Avid actually capitalizes “Plug-Ins (Unused)”, but uses lower-case for “Plug-ins”.