Does BFD 3 work now with M1 chips

Hi there,

It’s been a while since I last had a stab at getting BFD 3 to work on my MacBook Pro M1 since upgrading last October (2022) but does it work now? Every time I tried to get the awful license manager to work or just BFD in general in Logic (both Rosetta or normal modes), it never worked!

Now I see they’ve released a BFD Player!

Is BFD 3 dead or should I go through the heartache of trying to get it to work again?!

Yes. It has been for a little bit now. Make sure you download the latest version 3.4.5, and that pesky license manager should work without issue.

I’ve managed to install it but it’s now showing up in Logic Pro, even though I’ve run the Audio Units scan and enabled it. I seem to have no end of problems running BFD since getting a new Mac.

I’m using BFD3 flawlessly on M3 now, the only exception that it’s not M3 native for AAX/Protools. I don’t use AU, so I can’t speak to that. I haven’t run into any issues with the license manager on Apple silicon.

Is it running Native on Mac Silicon? Most Mac software will run on an M2 under Rosetta, but I suspect the chances of a native silicon version of BFD are minimal.

Yes, it does. It’s still a plug-in that causes fairly frequent (and annoying) “An audio plug-in is reporting a probem …” error messages in Logic, especially when switching between documents that both have BFD3 instantiated, but at the same time I’ve also known BFD3 to run well for days on end without issues. This is on an M1 MacStudio Ultra running Monterey and LogicPro 10.7.9.

The error message described above however can get really irritating so, since a few weeks, I’ve switched to running BFD3 in Vienna Ensemble. Works flawlessly. I don’t know why I didn’t think of this earlier.

But yeah, BFD3 runs quite well on the newer Macs.
Given the “An audio plug-in is reporting a problem …” error (which means that Apple’s AU Hosting Service — awful piece of software — is crashing), I would say that BFD3, at the moment, is in a semi-native silicon compatible phase of its development. Which means: compatible enough to work (and work well much of the time), but not compatible enough to work totally error-free all of the time.


Can I ask which version of BFD3 you are running ? Are you running Logic as Silicon Native or under Rosetta 2 ?
I’m running the most recent update, which is now quite old, and it will run in Cubase / Logic etc under Rosetta 2 fine, but if either Logic or Cubase are loaded in Native Silicon format then BFD3 is not recognised as a valid plugin at all. S

I’m using BFD3 v3.4.5.28 (the most recent one) in LogicPro 10.7.9 which runs natively (i.o.w. non-Rosetta).

Versions prior to the last one, used to require Rosetta, yes (without Rosetta, you could still instantiate the BFD3 plug-in in Logic, but the plug-in wouldn’t load any content), but the current one should run fine (at least, as fine as I described above) without Rosetta.


Hello basrikke, Thanks for your help.
It sounds like I may not have the most recent version loaded. I got so sick of the licensing problems I’ve moved to Superior Drummer 3, (which is very smooth and easy to use in comparison to BFD3) but I have some older projects to resurrect that used BFD3. I’ll have another look at the plug in version. S