Cannot download bfd3.4.5.28 via the license manager

I have the latest version of license manager. However it will not search for updates. How might I get update 3.4.5.28? Thank you in advance for your time.

Hey @chunkulus

Can you open License manager, go to the Installed Products tab, click on BFD3 and take a screenshot and attach it here?

Could you also tell me what version of BFD3 and License Manager you currently have installed?

Thanks,
Joe

2 Likes

I can’t do anything.
“There was an issue retrieving your products” in LM. In BFD “invalid authorization” for all.
I’m REALLY PISSED OFF this time.

When I set this up, less than 30 days ago NB, it all worked. I haven’t used it because I didn’t know about a silicon-ready version and I expected gigantic performance issues. I need some drums on the project and this is the shit I have to eat instead.

it’s ludicrous, if inMusic has to make us this reliant on internet, they can’t bloody well have wholly unresponsive servers for indefinite periods. I’m now of the same view as all the people widely dismissing BFD3, sadly. My time is being stolen from me, and I don’t have a lot of time left FFS.

One person (Drew) cannot be the savior of [a project of] a veritable sociopathic conglomerate-model corporation.

3 Likes

And inMusic support’s reply to my ticket is absolutely useless. The person understood nothing of what I said.


the same as 24 hours ago

as though I’ve never had any BFD ever

1 Like

Have you tried downloading the LM again and replacing the existing one? I was having issues and even though my installed LM was the same as the current one, it seemed to work. Might be worth a shot.

1 Like

only half a dozen times, like banging my head against the wall

I fixed it just now. There was a file in [the hidden on Mac OS BTW] my name/Library/Application Support I wasn’t looking for (I don’t think I’ve ever had cause to look there) inMusic lock-something that once removed solved this.

This is IMO no less egregious, though.

The new version downloaded no es problemas

thx, though for your reply!

1 Like

The LM lied to me :wink:
servers had nowt to do with it

Yeah, I was gonna mention that it could just be their servers. This happened to me before and I had to wait a whole day to authorize again. This is precisely why this authorization scheme is a bad idea. You can’t have professionals who are depending on this to work, have to wait however long until the inMusic servers start responding again. Time is money lost and angry clients. This is why I’m guessing not many professional producers/engineers are using BFD3. But it’s also equally not fair to the rest of us. This shouldn’t still be happening in 2023 with years since the transition. If they still can’t see how this is hurting their reputation and product, then there is no hope.

1 Like

InMusic will always suck.

it was absolutely this file. MacOS (hidden by default) personal name/Library/Application Support/some inMusic file made to completely lock you out, and it works.

You have to use Terminal to show hidden files to locate it?

Nah, the quicker way is the Finder Menu Go with option key held, a greyed-out Library is revealed.
Everybody knows it but it’s a sneaky spot, I don’t recall ever having to think about Application Support there because every vendor ever uses the regular one.

Oh, I misunderstood. I have the user Library folder visible by default. You just click on your home folder, Command-J to show view options and check, show Library Folder. That way it’s always displayed in your user home directory. I’m constantly in Application Support, so it’s just easier to have the Library Folder always visible.

I know about it first because delete Cubase preferences.

This same thing is happening to me and I haven’t been able to find a work around for a month or two. It’s been pretty frustrating to say the least.

Not surprised. I have not been able to download ANYTHING for over a year now. It keeps giving me the message ‘2 files failed to download properly’.

Any ideas? I have run out of them.