BFD3 Standalone playing piano notes?

I am not sure if this is windows or BFD3. I have previously had the standalone working as designed. I migrated to a bigger hard drive and everything went well, nothing has had any issues, neither with the OS, nor with any program I’ve launched. Now it’s been a month since I upgraded and I’ve been using BFD3 in Studio One6. That has been running fine as well.

Last night as I noticed I had an available free expansion pack, so I used the BFD installation manager to download, authenticate and install the expansion. During testing to listen to the new drum sounds, I noticed I had no sound. So I turned on a groove track to play as I tried to get sound. When groove editor played the drums, I was hearing only piano notes.

Talk about oddity. I’m not sure if there is a default windows sound for midi that is piano notes, or if something is sounding off when it’s not supposed to. Does anyone have any idea what’s going on or, more importantly, how to get true drum sounds again? It as worked before, like I said.

Thanks in advance.

Edit (added)
I’m in Windows 10, 20GB ram upgraded, and 1TB SSD upgrade, on an Asus VivoBook 14. I’m using an external PreSonus AudioBox USB96 for my sound driver inside Studio One6 and windows stock drivers when in Standalone.

You have to manually add the new content path for the expansion under Tools in the BFD3 File Menu. That should sort that out. As for the piano sounds, I’m guessing this is something having to do with Studio One. Either you had some kind of piano plugin on the same track, or the DAW has something built-in where it plays a basic piano roll when there is no VSTi on the track. This doesn’t happen in Standalone?

Thanks for the heads up about manually pointing the app to the files, I’ll see if that helps.

As for the piano sounds, I would think that would be the case if I was in Studio One, except this is happening only when I’m in the Standalone BFD3. I have normal drum sounds in my Studio One when using BFD3. I don’t get it. Do you know if Windows uses piano as the default midi sound for referencing midi?

Check you AUDIO/MIDI Preferences and see if the MIDI Mapper/Microsoft GS Wavetable Synth is activated somewhere or application(s) using windows shared audio.
BFD3 is ASIO only and the GS Wavetable synth is WDM


The problem is that no expansion pack is loaded although I’ve installed few times but still doesn’t shows…