BFD3 making me pull my hair out

Cool, feel free to send me a private message any time too.

I don’t know if this will help but I too have Andy Johns drums as well as many others. My problem came when trying to launch BFD3 and it would ask for LM to register drums. As soon as the licensing manager would authorize my drums, the same window would stay up asking me to authorize and I couldn’t get BFD3 to run. I ran into a separate issue with some bad audio drivers that made me re-install Windows 11 which meant that I had to re-install all of my programs. Anyway when I re-installed BFD3, everything worked perfectly. The preset kits load (which they didn’t before) and the kits load. All the expansion packs are there as well. I think maybe trying to uninstall and delete any folders that have anything to do with BFD on your computer may help. Anyway, I hope this helps

1 Like

Ok, thank for the support.

While it took a while I have also had more support from InMusic, who have given me a number to call should I need to go through it with them.

I have decided to have a cleanout and I uninstalled all my BFD stuff and started from scratch.

I have now installed the BFD3 software and the stock BFD3 sounds (Sound great) and they work fine.
It seems the issue is the Licence manager is glitchy. It’s very slow (As is the online registry on the account there, which takes days for anything there to show up, adding to the confusion). Add that with people rushing through with something that’s usually straight forward and I am not surprised there are a few issues for some.

You are instructed to download from there but the download does not then install the data, you have to do this by pressing the “play” icon that is supposed to appear when the data has downloaded so it can then be installed. But the play icon does not always appear after the download and it just hangs after downloading. It seems you can get past this by going to the root installation folder after the download and opening the installation directly and thus bypassing the play icon. For my expansion pack when this happened I just closed down the license manager and reopened it. When I did this it started to rescan the downloaded files and then when it finished, the play icon did appear and I was able to install it that way.

It is looking like more of a Licence manager bug than the BFD3 itself.

That said, more to go! so fingers crossed I manage those as well.

If the play icon doesn’t show up, that usually means the download did not finish. This could be due to a local networking thing, and License Manager sometimes hangs in such a situation - solution is to restart License Manager, and allow it to resume downloading.

If the “Play” button in the LM doesn’t work, you just go to where your BFD3 downloads are and double-click the installers from there. This is assuming the downloads are completed to begin with.

Yep. And no matter how many times I ask about it I get no response. Their website STILL says that an internet connection is still only needed for product download. Nothing about having to have my DAW online to keep authorised.

1 Like