BFD3 login issue


I have an urgent problem.

My problem is I’m supposed to render a mix today to go for mastering, and suddenly, no drums anymore and I have this message:

BFD3 has been disabled because you are not logged into your inMusic account. Please run the BFD Licence Manager.

Which I did. But I couldn’t connect, and in the licence manager I have:
- Not authorized (licence invalid)

Also I’m logged in and when I try to «refresh product list», I have this message:
- Our server was unable to process your request

This is really uncomfortable.

But at the same time I see that the licence manager is automatically downloading again 8GB of already installed products.

Now that it’s downloaded the manager asks me to run the installer by clicking the play button.
For me it’s really incomprehensible. This is not an update, we’re talking about 10 years old sample package. I’m very scared I’m going to loose all my work.

What should I do ?

Thank you very much.

Ok I’ve managed to log in.

But now when I open my projects, the drum samples slot are empty. I have to reload them manually.

But I don’t remember which one I had !!

Is there a way to make the samples reload automatically ?

Ok, I really need help.

I have the same problem on all the songs of the album.

Since I’ve managed to log in, all the samples have disappeared. I mean all.
I have only empty instances of BFD3 on all my tracks, on every tune I’ve been working on with BFD3 !!

My tuning are still there but they are no memory of the samples that was in used.

So I can still look for the samples and with luck, I’ll arrive at the same result, or something as good, but I don’t have the time to go by this tedious process.

Have you tried rescanning your contents to see if they show up?
Are you seeing yellow triangles?
Are your samples on an external drive that you unplugged perhaps?


Thank you for your help !

Have you tried rescanning your contents to see if they show up?

How would you do that ?

Are you seeing yellow triangles?

No, the drum images are greyed out like when you load the plugin for the first time and you don’t have any kit loaded yet. But there are still my modifications (for example differences in level).

Are your samples on an external drive that you unplugged perhaps?

No, it’s BFD3 that took care of the installation of the samples on my main hard drive.

It’s the second time that it happens. I can open older sessions of my mix to note on a paper all the samples that I used for the kit and find them back like this in my actual session.

But it’s really a time consumming process and out of the flow. I don’t rembember if the first time it happens it was also due to a licence problem.

In BFD3, go to 'Tools and click on, ‘Set Up Content Locations’
At the bottom of that gab you’ll see a row of buttons, hit the one that says, ‘Rescan All Content Paths’


P.S. It’s a really good idea to save all your projects as presets, this will load everything the way you had it set.

What I always do when the InMusic servers play up — which happens way too often —, is log out of the Licenser and log back in. The latter via the website (to where you’re redirected from within the Licenser) which always acts as if it’s hanging after you type in your credentials, but it actually registers the log-in because if you then return to the Licenser, you should see that everything is activated again. Has worked every time so far. Although it shouldn’t happen in the first place, I agree. Still, it only takes a minute to get up and running again.



Thanks for the tip basrikke.

When I updated, it did scan all the contents and brought me to the page you said. So it seemed to work.

I’m going away for 10 days, I’ll explore the matter when I’ll come back.

Thanks for your help !