Bfd3 expansion packs install error

Hi everyone, a little help here with the installation of bfd3 content libraries in MacBook Pro up to date with macOS Monterey. when i try to launch the install dialog i get the message that the app can’t get opened. I tried already changing the settings in system preferences security & privacy with no luck, still getting the same message. I have looked around the net for this problem and found a workaround for the installation from the terminal with chmod +x command but i can’t make it work, don’t know if i’m missing something entering the path of the app file. Hope someone could help me with this, maybe there’s a way copying the audio files in a folder and getting the license manager to read these audio files and recognizing them. Bfd3 v3.4.4.31 already installed and running fine inside ableton live but without content. Didn’t got that message, just with the libraries. These libraries are the ones updated from InMusic Brands. Thanks in advance for any help.


So you can’t open the installs for the content libraries, or for BFD3 app too? You need to install them from the licensing manager. Once you have registered and authorised the serial number for the pack in te license manager, the download will be come available and you can run it from within the license manager. Did you try and rescan the content libraries?

@PGN What about if you right-click the core content install app to show package contents and run the terminal-based install file from within the MacOS folder? That’s worked for me in the past, when macOS won’t run an installer normally.

Thanks, i tried double clicking the file BFDInstallSystem inside the MacOS folder but it opens the file in TextEdit. Also tried to right click this file to show Open With but the terminal is greyed out and don’t let me select it. Can i just drag this file to the terminal window opened?

Thanks, i didn’t try to rescan because i have no content installed. Hope this works :+1: