BFD3 crashing following Gobbler Update?

I’m begging for help over here! The issue seems insanely confusing to me. Thank you in advance…

In the last two weeks I’ve suddenly had erratic slowdowns and crashing when I try to load projects with BFD3 running as a plugin within them. Initially I found that drum kit load times were suddeningly taking about 5x longer. Then it started crashing completely every time I load. BFD3 standalone does seem to work alone - this issue only happens using BFD3 within logic.

I really don’t know if this is at all connected, but…

Over the years I have gone to extreme lengths to avoid OS updates, etc., to avoid instability with the system, and that has always avoided this kind of issue. However, just one thing I know of has changed: Just before these problems started, Slate emailed and made me switch over from Gobbler for my plugin managment to Slate directly. They walked me through the switch over on my iLok. The slate stuff works fine, but now BFD3 in Logic is bricked. Slate won’t help me becuase they say their plugins are not at fault, and I’m not sure who’s right.

Screen grab of crash report attached.

I see you’re able to help a lot of people out, @BFD_Drew BFD_Drew - Thanks in advance if you have any ideas!

My spec is:

  • Logic 10.6.2
  • My OS is 10.15.7.
  • iMac 3.8 GHz 8-Core Intel Core i7
  • 72gb RAM
  • Apollo TwinX Dual core.

Have you tried uninstalling BFD3, and doing a complete fresh install? I’d do the same with the license manager!

Thanks for the suggestion. That might help, but I’ve just now discovered that the release notes for Logic 10.6.3 (I currently have 10.6.2), lists…

  • Fixes an issue where Logic Pro may quit unexpectedly when loading projects with plug-ins that use PACE/iLok copy protection.

…which sounds like it might be related. The apps store won’t let me get that version though (I don’t want to update my full OS, which will cause its own headaches IMO). Anyone know where I can get this specific version? Thanks!

BFD v3.3.1 is not supported. BFD is no longer associated with FXpansion. Only version above v3.4 are supported.

Thanks - I’ve now updated to v3.4.3 - the issue is still the same.

So no fresh install? I would completely remove license manager and BFD and start with a fresh install. It sorted a few things out for me when I did that, but on Macbook Pro MonteryOS 12.0.1.
On my Mac Pro which has MojaveOS 10.14.6, BFD works amazingly.

That shouldn’t make any difference. v3.4 is a completely separate installation. v3.4 and v3.3 can co-exist. The caveat to that is the licensing of the content, which is at least sometimes different for v3.4.

Can I get the full crash log?