BFD3 and Studio One

Hello All,

I am having and issue with BFD and Studio One key maps on BFD3 and the Studio One not matching up. Anyone else have this problem?

John

What’s the issue exactly?? The note octave difference?? Some DAW’s name notes differently, and there’s a preference in BFD3 for the note octave naming, so you can match BFD3 to your DAW.

If that’s not it, let me know what the issue is :slight_smile:

Drew,

The issue is the key map that I have created does not roll over to studio one in the midi editor. There is a edit pitch names button is studio one but I cant do anything, it’s grayed out. I have attached a photo of what I am talking about.

John

I have been using BFD3 and Studio One for some time now and this has always seemed to be the case. The pitch names for BFD3 seem to be “hardwired” and you are not able to change this as the OP indicated. This is not the case for the other drum VSTi that I use such as MODO drums. They allow you to choose a pitch name preset of your choosing within Studio One.

I used to be able to get around this by imbedding an instance of BFD3 in a Studio One multi instrument but with recent versions of Studio One 5 this no longer seems to work. I have always found this frustrating and I don’t know if this was intentional or not.

Okay try this.

  1. Setup a preset with your keymap in it. Feel free to add any drums and what have you. Stuff you’d like as default.
  2. Save the preset to your user presets folder; give it a name you can spot in a menu.
  3. In the Preferences find the data sub-panel.
  4. There is an option here for start-up preset. Choose you preset in the menu.

Now any time you add BFD to a project, it should load that preset and the keymap.

The reason your keymap in BFD isn’t being shot across to Studio One properly is because Studio One only polls the keymap on plugin load. It doesn’t do it every time you make a change, if I remember rightly.

I have done that already. It should work but it still doesn’t load in the keymap(s) from BFD.

What version of Studio One are you using???

If BFD loads in the keymap internally, then I would suggest this is a bug with Studio One. We don’t have any control over what the DAW presents, we just load our note map. It’s the DAW’s job to poll the plugin for any note map changes.

I’ve just tried saving a custom preset here with a custom map inside of it. When I launch a new instance of BFD3, the keymap is indeed shown as I programmed it:

Your image looks different to mine. Are you on an older version of Studio One???

It must be the DAW. Because Im still running Studio One 3.5.6.

I’m using Studio One 5.3 and have been a user of it since version one. I’ve always noticed an issue with BFD drums mapping in Studio One and so I just opt to use the “import drum map” feature from within the plugin to get BFD to behave as I want. Once I have a preset kit and preset map and mixer setup, it no longer remains a problem. It’s not a perfect solution, but it is a solution.