BFD Licence Manger

Once again have opened BFD3 to find Licence Manager is failing to reach server and licence the product correctly.

I have lost tons of stuff and investment through BFD1 and BFD2, grudgingly accepted this, but now even BFD3 wont run. Had cut over successfully and licensed product and was working…now I go back for a client project and nothing is there.

Click on Authorise and get “Our server was unable to process the request. Please try again shortly. Server Message: The request could not be authorised.”

It was all working so why would it be looking to reauthorise anyway?

Time and money spent on BFD over the years is down tbe drain as frankly impossible to work on projects using BFD3 if out of the blue it stops working.

Licence Manager BFD3
BFD3 on launch just says not logged into you InMusic Account run BFD Licence manager… which then fails to connect to server???

Whats happening???

Licence Manager v is the latest I could find and seemed to iron out that risk.
I use Mac Monterey, (in a few minutes updating that to v 12.1)

Hope this helps.


You shouldn’t have lost any expansion packs. Can you be more specific? It can probably be corrected.

No… I have installled and still get the " There was an issue retrieving your list of products…our server was unable to process the request" message

Just dont believe whats happened after the hours spent ironing this out before :slightly_frowning_face:

Full versions if BFD1 BFD2 Nick Mason Expansion packs… although at the moment getting a basic BFD3 session up and running is better than nothing :slightly_frowning_face:

Yeah. Someone can correct me if I’m wrong, but the Sonic Reality’s are the one major exception to the support question, I believe.

Drumdrops & sonic reality don’t seem to be working with BFD right now.

I think @BFD_Drew has been in contact with them but not sure what progress has been made, if any.


My old Drumdrops licenses all work in BFD3.4. They migrated just fine. No issues.

Right, I got given the licences by fxpansion as a freebie and they all show up in the LM but there is nothing to be downloaded.
Can you download them from the LM?


No, that’s over and done with.

When you say, “that’s all over and done with” I’m assuming you mean fxpansion or can they not be downloaded via the LM.

I’ve tried inputting the serial numbers I was given, into the LM but they are not recognised.


Any form of download or support from anywhere. They were never downloadable from FXpansion or the LM. As far as serial numbers go, all I know is they migrated over with the rest of my expansions, and they still work.

As far as the Drum Drops stuff goes, I reached out to them to get them up to date with our system. I even offered to do all the work for them, unfortunately radio silence.


Ya, having a real problem with two kits of theirs, can’t get these projects to play all the way through without blowing up in very repeatable spots. All projects ran perfectly before the relaunch of BFD (only adding audio overdubs and trying to mix).Spent way more time than I can afford trying to troubleshoot the root cause (existing active projects, ouch) but thinking it -might- be related to the structure of their kits as there are no “kit pieces”, only mic channels with some additional factor related to kit piece hits sent to BFD as DAW MIDI and audio re-routed back to the DAW through “kit mic” channels. Swapping in a BFD (non-DD) kit lets me get through playback, so pretty sure it has something to do with the using DrumDrops in BFD. I’ve attached a screenshot of a typical “event”.

Will hit up DrumDrops as well, can’t hurt. Feel free to share any points that will help the cause.