Alesis Nitro Max - Tom Not Working

Hi, Just got the new Drumeo Alesis Nitro Max and the family is excited to get into drumming!

We quickly realized the edrum kit doesn’t actually make noise unless plugged into headphones. A few google searches later, we came across BFD for plugging the kit into our computer.

Making sure the drum kit is plugged in before BFD Player is launched, and setting Local mode off and General Midi mode on, we were able to get it recognized as the drivers were automatically installed. All of the drums appear to work except for the left (high) Tom.

I don’t see any way to manually try and look for the tom since it automatically detected my drum set correctly as the Nitro Max.

Is there anything I’m doing wrong?

Thanks much in advance! Excited to get drumming.

I presume by “Left” you are sitting at the Kit and looking at the High Tom (Tom 1)
You have conflicting MIDI maps… GM Mode loaded for the Module…Nitro Max for BFD Player.
For BFD Player Load the Nitro Max Key Map (Engine > Keymap > Alesis Nitro Max) …LOCAL CONTROL OFFGM MODE OFF in the Module.

GM MODE is for use with Software that only use GM Standard Mapping (GM 1)…like Melodics and Vst/Software that doesn’t include MIDI Maps for all of the various E-Drum Brands.
GM Mapping doesn’t support Multiple Zones including “Rims”.
GM Standard MIDI Mapping for the High Tom is MIDI Note 50.
The Nitro Max Model Default MIDI Mapping and the BFD Player Nitro Max Keymap for MIDI Note 50 is for the Tom Rim.
The Nitro Max MIDI Mapping for the High Tom Head (Tom 1) is MIDI Note 48.
The Nitro Max Toms are single Zone and don’t have a “Physical” Rim.
The Harness is TRS so you may be able to upgrade to Dual Zone Toms…I haven’t had anyone in the Forum confirm if it’s only a Hardware Limitation…the User Guide shows MIDI assignments for the Rims…
The Nitro Max Default MIDI Map is very similar to the GM Standard (GM1).

GM MODE is also for accessing the GM Percussion set in Modules that have it and allowing an external controller access to it or put the Module in a MIDI Loop…as far as I know the Nitro Max doesn’t have a GM Section as it’s not listed in the User Guide (GM Section is Not listed in other Alesis User Guides as well…but they have it) and it may be a Medeli Re-Brand (most Alesis Modules are Medeli re-Brands) which I currently don’t have any info which Module the Nitro Max is based on as it’s a New Desgn with BFD Sound base.

Appreciate the quick response!

I had to read your response a bunch of times and hopefully I’m following. And yes, I was referring to High Tom (Tom 1).

If I understood correctly, I just needed to set the drum module both to Local Off and GM Off right? I tried setting it that way, then turned on BFD Player and High Tom still doesn’t seem to trigger.

Also confirming I have BFD Player set to Input Device: “Alesis Nitro Max”.

I get what you mean about the multiple zones. Like you said, I believe all 3 toms were universal and do not have rim zones. Is there some way I can override the mapping so it detects as midi 48 instead of 50?

Did you load the MIDI/Key map?..I don’t see it mentioned in your post.

To the right of Preset is a little box with an arrow pointing down…it’s a drop down menu…

Load the Nitro Max Key Map (Engine > Keymap > Alesis Nitro Max)

User Guide pg 15

To adjust the pad settings:

  1. Make sure the module is in Normal mode (top Mode LED is lit).
  2. Hit the pad whose settings you want to adjust.
  3. Press the Voice button.
  4. Press – / + buttons to change a sound.
  5. Press the Voice button again to view and edit these settings on the display:
    • NUM / H-C**: Pad voice (drum, cymbal, or percussion sound)
    • VOL: Pad volume
    • PAN: Pad panning
    • PIT: Pad pitch
    • REV: Pad reverb
    MID: MIDI note. See the (5.0) Appendix for a list of the default MIDI note
    numbers for each pad.
    • P-S: Pad song switch (selects whether or not a song will play when that pad
    is struck)
    • P-N***: Pad song number (selects which song will play when that pad is
    struck, if P-S is set to ON)
  6. Use the – and + buttons to adjust the value

Also , according to the User Guide…there is a GM Section (General MIDI Percussion).

User Guide pg 21

To adjust the MIDI settings:

  1. Hit the pad whose settings you want to adjust.
  2. Press Utility repeatedly until the desired setting appears on the display:
    • LOC (Local Mode):
    o When set to ON, playing your electronic drum kit will trigger the sounds
    in the drum module.
    o When set to OFF, playing your electronic drum kit will trigger sounds in a
    computer connected to the module’s USB port, bypassing the drum
    module’s sound library.
    o GM (General MIDI Mode): When set to ON, Channel 10 in the drum
    module will use General MIDI percussion sounds.
    o When set to OFF, Channel 10 in the drum module will use the module’s
    internal drum sounds.

You are truly the best! It’s working!

I never would have seen that little drop down. I’ll admit every time I read through your notes, my brain was somehow linking the second sentence to the third and leading right into the Local Control and GM Mode, so I thought I had already done the step by seeing Alesis Nitro Max in the Input (clearly not the Key map), so I didn’t realize the Key Map was separate.

As to make sure I really appreciate everything you spent the time to write out, the User Guide Page 15 settings, I think I better understand but to repeat in my own words. If I wanted to say be silly and change Tom 1 to map to Tom 2 and switch Tom 2 to Tom 1, I could go to each drum pad, change the Voice option, and the Midi note and flip them right? I noticed this when I tried changing my Tom 1 to 50 and as a result is sounding like the Tom rim.

I haven’t quite appreciated the GM notes that you sent but it sounds like this may not even be a feature of my set so maybe another time in the future when I get more advanced.

For now, my kids will be delighted to blast the house with drum sounds during the day, and I can play with headphones at night.

I also wasn’t the only one that had an issue and was worried I might be stuck but glad I got this working. I’ll link this over to Reddit where I saw someone else with the same problem.

Again a huge thanks to the super fast response and detailed instructions.