Adding subchannels/submics to kick channels


I recently upgraded to BFD3 from BFD2 and so far love the sounds and features available, especially the freedom now available in selecting pieces for a kit, however, one thing that is really bothering me is sub-mics for kick and snare.

The main Kick drum has both In and Out mic subchannel’s, but the second kick drum doesn’t and I can’t find a way of adding them to it. I’ve scoured the options, the manual and possible tutorials on YouTube but nothing. So, I was wondering, does anyone know how you do this, or if you even can?

If you can’t then that seems like a serious oversight :confused:

In and Out are different samples. It’s either part of that kit piece, or it’s not. You should see all available channels appear when you load it.

Which pieces are you trying to load for the first and second kicks?

Hi, thank you for the reply.

Initially, I had loaded the Mapex Kick 3 (Plastic) from the Oblivion Expansion into both slots and Kick 1 had the in and out while Kick 2 did not. I have since tested all the kicks from the expansion and the BFD3 library, both with the same kick in both slots and with different kicks in each channel and almost every single time only Kick 1 had the In and Out channels. On one occasion I did manage to get In and Out channels for both Kick 1 and 2 but I can’t remember what combination of kicks I did to get that.

It made sense that some kicks may not have samples for in and out but saying as I can load the same Kick into Slot 1 and have In and Out and then into Kick slot 2 and not have them has me confused.

It’s working fine for me. I see both the In and Out channels for Mapex Kick 3 (Plastic) on both Kick and Kick2.

Try toggling the “Expand/Contract all channels” button. Even though Kick is expanded, when you add Kick 2, it’s contracted. You have to hit that button again to see both channels.


Yeah, I tried pressing the Expand/Contract button a few times in case it needed to be refreshed to display them. I also tried clicking on the little expand/contract arrow for the individual kit piece as well, but that didn’t work either. I’ve also tried it in the Standalone App and in Reaper but the same thing happens in both.

I tried resetting BFD as well, in case I had changed some settings while playing around with it and that was why it wasn’t working but that didn’t help.

I tried looking for a setting but I couldn’t see anything that might relate to it so wondering if it could be a bug with my install?

At least I know that it should be doing what I wanted, I just don’t know why it isn’t doing it.

Had this problem as well with a snare. (Unable to expand a kit piece with known multiple channels). The mixer channels have a kit piece designation (i.e. Snare 1, Snare 2) and I was wondering if that had something to do with it. It makes a difference in where it’s displayed in the kit view. Haven’t done any in depth debugging, but in at least one instance, closing BFD3 and the DAW managed to fix the problem.

1 Like

Are you on the latest BFD3 build and LM? I believe this was a bug that may have been sorted a couple builds back. I had issues with missing snare channels.

1 Like


Hooray, that worked thank you :slight_smile: That’s such an obvious thing to check, haha, I can’t believe I didn’t think of checking if the software was up to date, thank you :slight_smile:


Nice. Glad that sorted it out for you. I remember that bug was making my head go nuts.