Long time BFD2 user having no luck installing / authorising BFD3


OK scratch some of the below. The latest update seems to have made authorization ok. However, the standalone version is still an immediate crash on launch. Any info on that most welcome.


Hi all,

I can see this has been mentioned before, so I won’t labour the point of what an absolutely horrible user experience the migration to InMusic was.

Anyway, suffice to say after much wailing and gnashing of teeth, BFD3 still doesn’t work. The standalone version blinks out of existence on launch, and the VST version comes up, but is locked out with a message saying “bfd3 has been disabled because the product needs authorisation”.

However, in the license manager, whether run from in the plugin or separately, everything shows as authorised. I tried a couple of rounds of de-authorising / re-authorising, but all that’s got me is that I’ve now apparently hit the maximum number of de-authorisations.

I’ve messaged support as the pop up suggested, but no response as yet (though that was only a couple of hours ago). So thought I’d chance my arm here.

Am on Windows 10, I should mention.

Any ideas from the good people of the forum? Found a thread mentioning this but uit didn’t seem to come to any conclusions.


New version out to try, hope this brings you a working BFD!

EDIT: Oops, I missed your edit of having tried the new version. My eyes are an idiot.