Dragging MIDI groove from right palette crashes DAW & BFD3

Hi folks. I’ve written about this and had a few responses already on different threads. This concerns BFD3 crashing my DAW and also in stand alone mode when I try to drag a MIDI groove (as MIDI) from the right side groove palette into the DAW timeline or onto my desktop (a feature advertised as part of the BFD3 work flow).

It is happening to me in Mac Sierra and an older machine. But everything else is functional on this computer and OS, so I have to suspect it’s something related to how BFD3 interacts, or fails to interact, with the computer itself. NOTE: this is occurring even after I updated to BFD3 v3.44. However, the issue was already present (for me) in previous versions.

Not sure where to start. But my regular BFD3 folder for presets is in the documents folder and my samples for BFD3 are on another internal drive.

Some people have said it crashes on their systems too. I’d like to hear from you so maybe we can narrow down the cause of what seems like a very random bug that doesn’t affect every user.

NOTE: The drag and drop MIDI groove from palette feature DOES work on my PC in Windows 10, so this is either computer or OS specific. What I don’t understand is why it doesn’t work on the Mac.

Also, it’s crashing in standalone, and in Studio One 4.6.1, Digital Performer 10.13 and Reaper 6.x.

No idea, shooting ideas blind to narrow it down:

  • At which point of the drag and drop process does it crash? The moment you click, the moment you leave the window, the moment you release the mouse button?
  • Does this happen with all grooves?
  • Do you have non ANSI characters in the path of the grooves, or in the names of the grooves? (I had groove related crashes in the past because I had used non-English characters to name them. Once I renamed them, everything was back to normal.
  • Can’t think of anything else for the time being.
1 Like

Just tried it in standalone: it crashed as soon as I started dragging. And that was the case in the previous version of BFD3. Clicking is fine, because it just selects the file. But as Soon as I click & drag, it crashes.

Also, I didn’t even load up a kit - it was empty. I used those “730 Days” grooves right at the top of the left menu. Double click on those and they populate the right menu. From there, I click on the top one, drag and CRASH. That’s it. My paths look okay. I have a space in my HD name, but that would ordinarily get filled in with a %20 or something.

Also, just tried another set of grooves halfway down the menu. Same result. Crashed again.

Also, a related groove dragging crash issue that Drew stated would be fixed in 3.44. However, this person quoted in the link below — a beta tester — posted that that issue wasn’t fixed yet either. Perhaps there is a single cause connecting all these groove related crashes.

Made a LICEcap animated GIF of the crash in Standalone mode.
Here I am just starting BFD3, loading the groove palette by clicking on the content in the left hand groove menu, then attempting to drag a groove from the right hand menu onto the desktop. As soon as the dragging starts, BFD3 crashes. Constantly and consistently.


Already told you on Big Sur and Cubase 12 Pro no problem at all. Maybe a workaround would be to export it with right click on the groove as a Midi file?
Or from the File menu “Export Groove Midi”.

1 Like

I was told this was fixed. I’ll investigate on Monday and post more.


1 Like

2013 iMac , Monterey 12.4, 32 GB Ram
ALL BFD is on a separate TB spinning WD Black HD

StudioOne 5.5.2
Cubase 11.0.41


I did the Groove Editor Palette and also the the Grooves Browser on the left for giggles

  1. Drag from BFD 3 Stand Alone app to desktop = NO CRASH
  2. Stand Alone into an open Studio One/Cubase= NO CRASH
  3. BFD as an Instrument in S1/Cubase= NO CRASH

**Cubase will NOT let me drag from the Grooves Browser when using Stand Alone or as a VSTi inside of Cubase. The file turns into a blue file folder and not a midi file as we usually see when trying to do that.

No crashes with Cubase either here.

Hope this helps

1 Like

I have been using the workaround. But I want the feature itself to work on my computer. I’m open to the fact that it may be related to my computer. But I already wrote about this issue here last year and have had sufficient responses from other users to believe it may be part of a larger problem. And clearly, if there was already a drag and drop issue present elsewhere, then this is known and familiar behavior, at least to some.

re; your NOTE: I’m not sure that cubase can keep you from dragging from BFD3 in standalone mode, unless you’re trying to drag directly into the cubase timeline. I think you’re supposed to drag to desktop only and from there into the software. Not sure. Just a hunch.

UPDATE: I just tried dragging and dropping MIDI grooves (as MIDI) on my PC, both in standalone and inside of Studio One 5.2. It worked! Also, this was using BFD3 v3.4.3.

So the issue seems to be related to my Mac Sierra install. I may try installing BFD3 on another hd in the same computer but on High Sierra (which is the highest I can go on this machine).

I would guess it is a permissions issue on your machine. The os doesnt give bfd permission to write to it’s temporary location and this causes a crash.

Can you try repairing permissions?

1 Like

I repaired perms and then tried dragging in standalone onto the desktop and it crashed again. Here is the crash report (top most part) that says its a segmentation issue - so probably to do with permissions or access issues of some kind.

When dragging the default grooves, what is happening - where is the file info coming from? Library/…? or Documents/… or perhaps /BFD3/…/some folder?

Process: BFD3 [557]
Path: /Applications/BFD3.app/Contents/MacOS/BFD3
Identifier: com.bfddrums.BFD3.standalone
Version: 3.4.4 (
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: BFD3 [557]
User ID: 501

Date/Time: 2022-05-28 19:46:43.871 -0400
OS Version: Mac OS X 10.12.6 (16G2136)
Report Version: 12
Anonymous UUID: 4139E6AE-E988-0F6E-5A4B-0052813A54C6

Time Awake Since Boot: 140 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

Dragging grooves from BFD3 to Pro Tools, or Desktop working fine for me.

macOS 10.13.6
Pro Tools 2021.6

1 Like

Thanks. :slight_smile: It does appear to be something specific to my Mac setup, or perhaps to Macs having established a particular configuration relationship with BFD3, perhaps. I’m sure with enough people posting and suggesting troubleshooting ideas, I’ll get to the bottom of this.

BFD3 works fine otherwise, just this one feature. So it’s not a deal breaker for using it, but it would be nice to see it working.

Macbook Pro (mid 2015), MontereyOS 12.4, Cubase 12 Pro

Dragging from standalone into DAW working as expected.
Dragging from BFD within DAW working as expected.
Dragging as one track for all Drums working as expected.
Dragging as one track per Drum working as expected.
Dragging as one track per Drum Articulation working as expected.

Happy days, I know this is still being worked on but gave it a try anyway, Dragging as Audio still crashing DAW.

1 Like