BFD1 User here! Thinking about jumping into the BFD3 upgrade on M1 Mac. Yay or nay?

Well, in my use it isn’t buggy, I don’t have legacy installations or older version per se installations at all.
Or an installation problem I know of, except once I apparently didn’t finish an installation.

On my M1 Mac, bought it Friday (14" MBP, the newer one), BFD3 licenses won’t be validated by the inMusic server. Not one of them. OS12.2.1

@Civilization3 I think there is a further update on the situation with the M1 build elsewhere in the forum but I maybe misremembering. I seem to recall a little update from Drew in another thread.

@BFD_Drew Another item for an FAQ? With huge disclaimers of how the progress/release hopes are up to change at any minute, maybe out of date info etc etc. It could save users having to search the forum for a tiny bit of info that impacts their use of BFD/purchasing decisions for BFD use.

Well, how de doo. Just tried it again (no change in the system except a lot of other stuff lives here now), and it all authorized. But after installing the actual BFD3, it’s back to balking completely. New issue: maximum simultaneous product authorizations reached. This is just egregious. This will be the second of two machines, one of which is gone.

no meaningful support channel appears, logged into inMusic. Sales support, and the form after choosing ‘technical support’ looks… incomplete, not right

DigitalPerformer 11 doesn’t like it running Native on Apple Silicon. BFD3 passed inspection, but crashes DP upon instantiation. If I run DP under Rosetta, BFD will work, but crashes on quit.

I’ve got Komplete. Kontakt runs Native. Gonna’ see if that will work for me… lots of kits to choose from. Absent further development, I think I’m pretty much done with BFD.

Both, in random alternation. :face_with_raised_eyebrow:

probably, depending. Apparently users that have files strewn all over have a bear of a time migrating. I have not touched the “Migrate” button in the application, and this was not any kind of problem for me.
However the new version has authorization and protection that fxpansion did not.

Donno from Logic. Here (sorry if this is still here in other guises, I didn’t see it today), I have it running in Rosetta 2 in Nuendo 11 also in Rosetta. and it is performing very nicely like this. Before M1 I was dogmatic about running any instrument in Cubendo because in the same process of the host it would likely be more trouble than in VE Pro. M1 and this, unsupported v. of BFD3 flips that script 180º. VE Pro cannot stand it.
The interest here is that one License Manager, with a .2 at the end, works for one configuration and another, with a .3 works with a different one. The former here is Nuendo and standalone work. Initially it was making me reauth every single time, now it behaves normally. The latter is running the LM from VE Pro means success while the standalone is completely kaput; and the performance is as bad as when I was way underspec back early in the century, there wasn’t enough latency possible to get a project to work.

NB: Silicon SoC aka M1 isn’t supported at all. However it kind of miraculously works here, after some really bad times initially, where I figured I would have to give it up until it was supported.

There Drew.
I fixed your post for you.

Hi strange enough my migration has been less painful than I expected So far. My worry is I am on windows 19044 or something and cannot update further but everything seems to run fine except I cant find the kits for my jazz and funk all the drums are there just no kit also lost the 8bit add on I had received with an update1.5 maybe but I didn’t use it anyway.so when do I find out it doesn’t work unless windows 1909.

@magoktheleader I have BFD1.5, but never got the 8bit add-on you’re referring to. How do/did you get that?


Your website still says ‘Internet connection for product download’ Then, when some poor sucker falls for that, they discover that they have to have their DAW online every 90 days to check the licence.

@jih64 They mentioned they got the 8-bit kit as an add-on with an old BFD1.5 update. I was assuming they got it for free, as they said they “received” it, but perhaps I misunderstood?

I have used BFD since the first edition came about, on Mac computers; last years mostly on a Mac Pro 2008 and then an iMac since 2019. I’ve run BFD with a Roland TD12, as standalone or in Cubase. Never used the grooves.

I used to love BFD and I have many expansion packs. I have built many presets, as interesting projects collecting info about historically important drummers and their kits.

Since the migration to InMusic one year ago I’ve had nothing but problems with BFD3.
First the repetitive register/authorize process where I had to have both BFD’s and InMusic’s license systems installed in parallel to be able to switch between different kits and presets, since the new system didn’t find those files - yes, I rescanned and rescanned and added BFD2 paths etc. in absurdum. Numerous fresh reinstallations of BFD3 to make it work - for a while - with the licenser.

Then I migrated from iMac to Mac Studio (Apple Silicon M1 processor) this spring. What a nightmare! I downloaded and installed the latest BFD3 edition, which did work, to some extent. But it can’t find presets, kits nor grooves I’d like it to - only the ones that came with the BFD3.
When rescanning the app gets stuck and rescans forever.
None of my expansion packs can load, it doesn’t matter if I point to where they are located (presets, kits and sounds).
The license manager (only InMusic’s this time) says the expansion packs are registered/authorized/approved but the sounds or kits/presets fail to load.
I’ve downloaded the expansion packs again for fresh installation but the installers will not open/work on M1 computers.
Some expansion packs - 3rd party ones - are not even available for downloading. I happen to have copies on old harddrives but they won’t install.

I miss being able to run the presets I’ve built through the years; the Bill Ward 1969-70 preset is only one of them…

So, sad to say, I gave up and put my money on the worst competitor, which I must say works like a charm.
I strongly recommend against trying your old BFD1 & 2 files on an M1.

and . . . . . . . . . . . . . ?

The current ‘public’ version of BFD3 doesn’t support the M1 but an latest update specifically for the M1 was released for us beta testers on Monday 1st of August.
Not having an M1 I can’t comment on how it’s gong other than a few minor issues.

Great that your happy with SD3 but a shame you didn’t save yourself some money and wait for the official M1 update.

Steve

I’m afraid an official M1 update would not help me with the problems described in my post, i.e. being able to install expansion packs or finding presets other than those installed with the app itself, or?

It wouldn’t play my JnF or Andy Johns kits… or the older London session and so on.

I’ve found the best way to circumvent the freezing on user scanning, you have to remove all content paths and then add them back again. That always works for me.

1 Like